Loading ...
Sorry, an error occurred while loading the content.

Audio Questions

Expand Messages
  • Stephanie Maks
    I ve got Ken s audio drivers from OpenZipit loaded into my Zipit now (the three modules in the go2 script), and got the matching /dev entries as well. I don t
    Message 1 of 4 , Nov 1, 2005
    • 0 Attachment
      I've got Ken's audio drivers from OpenZipit loaded into my Zipit now
      (the three modules in the go2 script), and got the matching /dev
      entries as well. I don't have madplay or any of the mad libraries or
      id3 libraries though, as I don't plan on playing any mp3s.

      I've tried sending some wav files through like this:
      cat sound.wav > /dev/zipaudio

      Some wav files produce static, others don't seem to do anything at
      all. I've found though that doing this seems to make the zipit
      unstable, i.e. I've had it lock-up / crash sometimes, after I've been
      sending stuff to /dev/zipaudio

      Can anyone give me some pointers? Do I need to have a specially
      configured .wav file?

      Or is there a simpler way to make the zipit go 'beep'? A console
      beep like when you type ctrl-G would be perfect.

      Thanks again!

      -Stephanie
    • Ken McGuire
      Sending .wav files to /dev/dsp or /dev/zipaudio will at best result in static, they are in Microsofts .wav format (of which there are several flavors) and
      Message 2 of 4 , Nov 1, 2005
      • 0 Attachment
        Sending .wav files to /dev/dsp or /dev/zipaudio will at best result in
        static, they are in Microsofts .wav format (of which there are several
        flavors) and cannot be understood by the driver.
        At the /dev/dsp, /dev/audio, /dev/zipaudio etc. level, the
        files/stream needs to be raw or oss format. On a linux pc decode a mp3
        to a file and the result will be in raw or oss format. This can then
        be sent directly to the driver by cat soundfile > /dev/zipaudio.
        Hope this helps, there are lots of how-to's out there which leave a
        lot unsaid. best to read the sources.
        ...ken...


        --- In zipitwireless@yahoogroups.com, Stephanie Maks <va3uxb@m...> wrote:
        >
        > I've got Ken's audio drivers from OpenZipit loaded into my Zipit now
        > (the three modules in the go2 script), and got the matching /dev
        > entries as well. I don't have madplay or any of the mad libraries or
        > id3 libraries though, as I don't plan on playing any mp3s.
        >
        > I've tried sending some wav files through like this:
        > cat sound.wav > /dev/zipaudio
        >
        > Some wav files produce static, others don't seem to do anything at
        > all. I've found though that doing this seems to make the zipit
        > unstable, i.e. I've had it lock-up / crash sometimes, after I've been
        > sending stuff to /dev/zipaudio
        >
        > Can anyone give me some pointers? Do I need to have a specially
        > configured .wav file?
        >
        > Or is there a simpler way to make the zipit go 'beep'? A console
        > beep like when you type ctrl-G would be perfect.
        >
        > Thanks again!
        >
        > -Stephanie
        >
      • thesoftwareguy22
        So were you able to get the /dev/zipaudio to play anything? would love to hear if it worked... Ray ... now ... or ... at ... been
        Message 3 of 4 , Dec 18, 2005
        • 0 Attachment
          So were you able to get the /dev/zipaudio to play anything?
          would love to hear if it worked...

          Ray

          --- In zipitwireless@yahoogroups.com, Stephanie Maks <va3uxb@m...>
          wrote:
          >
          > I've got Ken's audio drivers from OpenZipit loaded into my Zipit
          now
          > (the three modules in the go2 script), and got the matching /dev
          > entries as well. I don't have madplay or any of the mad libraries
          or
          > id3 libraries though, as I don't plan on playing any mp3s.
          >
          > I've tried sending some wav files through like this:
          > cat sound.wav > /dev/zipaudio
          >
          > Some wav files produce static, others don't seem to do anything
          at
          > all. I've found though that doing this seems to make the zipit
          > unstable, i.e. I've had it lock-up / crash sometimes, after I've
          been
          > sending stuff to /dev/zipaudio
          >
          > Can anyone give me some pointers? Do I need to have a specially
          > configured .wav file?
          >
          > Or is there a simpler way to make the zipit go 'beep'? A console
          > beep like when you type ctrl-G would be perfect.
          >
          > Thanks again!
          >
          > -Stephanie
          >
        • jayk806
          Hi Ray, I m pretty new to the group, having only had my zipit for a couple weeks - but I just got some cool stuff going, and I saw your message and figured
          Message 4 of 4 , Dec 18, 2005
          • 0 Attachment
            Hi Ray,

            I'm pretty new to the group, having only had my zipit for a couple
            weeks - but I just got some cool stuff going, and I saw your message
            and figured it'd be a good time to share.

            I've been able to play a good deal of audio through my zipit. With
            wav files, you need to be sure that the wav files are encoded a
            particular way - the /dev/zipitaudio device seems to like 44100Hz
            two-channel wavs using signed 16bit encoding (little endian) If you
            can convert your wavs to this format, you will be able to dump them
            straight into /dev/zipitaudio device. (sox options for this format
            are: -c 2 -r 44100 -w -s)

            As an aside, I know from reading older posts that a few people use
            PowerPC linux boxes. I do as well (I have a mac-mini running debian)
            I've found that the wavs I produce with some programs there are not
            so happy with regard to byte order. I thought that specifying
            little-endian or big-endian would solve the problem, but it didn't.
            All I could get was static even with the other settings right. I've
            found that if I run the wavs through sox with the -x (swap byte
            order), the resulting file usually works.

            As a side note to those who are interested - I have spent most of the
            day working on audio on the zipit and I have had some major success.

            Right now I am listening to music on my zipit, streaming from a player
            running on my desktop linux machine. It's a little involved to get
            going and I'm still tweaking the setup on both sides but it works.

            It's using next to no CPU on the desktop machine, takes about 30-40%
            on the zipit (mostly just pulling data over the network) It is
            sending un-compressed audio, so it eats a bit of the network bandwidth
            - but not enough to slow anything else down, and there is
            plenty of CPU left on the Zipit to do other things.

            I'm pretty excited about it, and I wanted to share the news with you
            all. :-)

            I only got it all working properly an hour or two ago, so it's still
            pretty rough. If there is interest, I'll post details once I clean it
            up a bit.

            Cheers!

            Jay

            --- In zipitwireless@yahoogroups.com, "thesoftwareguy22"
            <combsray@h...> wrote:
            >
            > So were you able to get the /dev/zipaudio to play anything?
            > would love to hear if it worked...
            >
            > Ray
            >
            > --- In zipitwireless@yahoogroups.com, Stephanie Maks <va3uxb@m...>
            > wrote:
            > >
            > > I've got Ken's audio drivers from OpenZipit loaded into my Zipit
            > now
            > > (the three modules in the go2 script), and got the matching /dev
            > > entries as well. I don't have madplay or any of the mad libraries
            > or
            > > id3 libraries though, as I don't plan on playing any mp3s.
            > >
            > > I've tried sending some wav files through like this:
            > > cat sound.wav > /dev/zipaudio
            > >
            > > Some wav files produce static, others don't seem to do anything
            > at
            > > all. I've found though that doing this seems to make the zipit
            > > unstable, i.e. I've had it lock-up / crash sometimes, after I've
            > been
            > > sending stuff to /dev/zipaudio
            > >
            > > Can anyone give me some pointers? Do I need to have a specially
            > > configured .wav file?
            > >
            > > Or is there a simpler way to make the zipit go 'beep'? A console
            > > beep like when you type ctrl-G would be perfect.
            > >
            > > Thanks again!
            > >
            > > -Stephanie
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.