Loading ...
Sorry, an error occurred while loading the content.

ForecastService :: getForecastByAdGroup call

Expand Messages
  • dnsh_nryn
    Hello, I would be grateful if someone could tell me what is wrong with this XML request which I send to the Panama sandbox when requesting the
    Message 1 of 5 , Mar 16, 2007
    • 0 Attachment
      Hello,

      I would be grateful if someone could tell me what is wrong with this
      XML request which I send to the Panama sandbox when requesting the
      getForecastByAdGroup method in the Forecast service.

      The error code that is returned is E1001, the message is "Invalid
      Message Request". I would appreciate it a lot if someone could look at
      my XML request and let me know what is missing or incorrect.

      <?xml version="1.0" encoding="utf-8"?>
      <SOAP-ENV:Envelope
      xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
      xmlns:xsd="http://www.w3.org/2001/XMLSchema"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
      xmlns:ns8934="http://tempuri.org">
      <SOAP-ENV:Header>
      <username>--username--</username>
      <password>--password--</password>
      <license>--license--</license>
      <masterAccountID>--master account id--</masterAccountID>
      <accountID>--account id--</accountID>
      </SOAP-ENV:Header>
      <SOAP-ENV:Body>
      <getForecastByAdGroup xmlns="http://marketing.ews.yahooapis.com/V1">
      <adGroupID>1853389</adGroupID>
      <forecastRequestData>
      <accountID>--account id--</accountID>
      <marketID>US</marketID>
      <matchTypes>
      <ForecastMatchType>SponsoredSearch</ForecastMatchType>
      <ForecastMatchType>ContentMatch</ForecastMatchType>
      </matchTypes>
      </forecastRequestData>
      </getForecastByAdGroup>
      </SOAP-ENV:Body>
      </SOAP-ENV:Envelope>

      Many thanks for your help
      Cheers, Dinesh
    • Yahoo! Search Marketing Monkey
      A cursory glance at the XML and it seems okay. Are you sure that ad group ID is valid? -Y!SM Monkey
      Message 2 of 5 , Mar 16, 2007
      • 0 Attachment
        A cursory glance at the XML and it seems okay. Are you sure that ad
        group ID is valid?

        -Y!SM Monkey

        dnsh_nryn wrote:
        > Hello,
        >
        > I would be grateful if someone could tell me what is wrong with this
        > XML request which I send to the Panama sandbox when requesting the
        > getForecastByAdGroup method in the Forecast service.
        >
        > The error code that is returned is E1001, the message is "Invalid
        > Message Request". I would appreciate it a lot if someone could look at
        > my XML request and let me know what is missing or incorrect.
        >
        > <?xml version="1.0" encoding="utf-8"?>
        > <SOAP-ENV:Envelope
        > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
        > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
        > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
        > xmlns:ns8934="http://tempuri.org">
        > <SOAP-ENV:Header>
        > <username>--username--</username>
        > <password>--password--</password>
        > <license>--license--</license>
        > <masterAccountID>--master account id--</masterAccountID>
        > <accountID>--account id--</accountID>
        > </SOAP-ENV:Header>
        > <SOAP-ENV:Body>
        > <getForecastByAdGroup xmlns="http://marketing.ews.yahooapis.com/V1">
        > <adGroupID>1853389</adGroupID>
        > <forecastRequestData>
        > <accountID>--account id--</accountID>
        > <marketID>US</marketID>
        > <matchTypes>
        > <ForecastMatchType>SponsoredSearch</ForecastMatchType>
        > <ForecastMatchType>ContentMatch</ForecastMatchType>
        > </matchTypes>
        > </forecastRequestData>
        > </getForecastByAdGroup>
        > </SOAP-ENV:Body>
        > </SOAP-ENV:Envelope>
        >
        > Many thanks for your help
        > Cheers, Dinesh
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
      • Yahoo! Search Marketing Monkey
        You might need to pass in bid values for the match types you enable. I m not able to test it right now, so give that a try. Also make sure the ad group id is
        Message 3 of 5 , Mar 16, 2007
        • 0 Attachment
          You might need to pass in bid values for the match types you enable.
          I'm not able to test it right now, so give that a try. Also make sure
          the ad group id is valid.

          http://ysm.techportal.searchmarketing.yahoo.com/docs/reference/data/ForecastRequestData.asp

          Note the matrix of match types and which bids are used.

          -Y!SM Monkey

          dnsh_nryn wrote:
          > Hello,
          >
          > I would be grateful if someone could tell me what is wrong with this
          > XML request which I send to the Panama sandbox when requesting the
          > getForecastByAdGroup method in the Forecast service.
          >
          > The error code that is returned is E1001, the message is "Invalid
          > Message Request". I would appreciate it a lot if someone could look at
          > my XML request and let me know what is missing or incorrect.
          >
          > <?xml version="1.0" encoding="utf-8"?>
          > <SOAP-ENV:Envelope
          > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
          > xmlns:xsd="http://www.w3.org/2001/XMLSchema"
          > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
          > xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
          > xmlns:ns8934="http://tempuri.org">
          > <SOAP-ENV:Header>
          > <username>--username--</username>
          > <password>--password--</password>
          > <license>--license--</license>
          > <masterAccountID>--master account id--</masterAccountID>
          > <accountID>--account id--</accountID>
          > </SOAP-ENV:Header>
          > <SOAP-ENV:Body>
          > <getForecastByAdGroup xmlns="http://marketing.ews.yahooapis.com/V1">
          > <adGroupID>1853389</adGroupID>
          > <forecastRequestData>
          > <accountID>--account id--</accountID>
          > <marketID>US</marketID>
          > <matchTypes>
          > <ForecastMatchType>SponsoredSearch</ForecastMatchType>
          > <ForecastMatchType>ContentMatch</ForecastMatchType>
          > </matchTypes>
          > </forecastRequestData>
          > </getForecastByAdGroup>
          > </SOAP-ENV:Body>
          > </SOAP-ENV:Envelope>
          >
          > Many thanks for your help
          > Cheers, Dinesh
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
          >
          >
          >
        • dnsh_nryn
          ... http://ysm.techportal.searchmarketing.yahoo.com/docs/reference/data/ForecastRequestData.asp ... Hello Y!SM Monkey, Many thanks for your advice! Sorry it
          Message 4 of 5 , Apr 2 6:13 AM
          • 0 Attachment
            --- In yws-searchmarketing@yahoogroups.com, "Yahoo! Search Marketing
            Monkey" <plummerm@...> wrote:
            >
            > You might need to pass in bid values for the match types you enable.
            > I'm not able to test it right now, so give that a try. Also make sure
            > the ad group id is valid.
            >
            >
            http://ysm.techportal.searchmarketing.yahoo.com/docs/reference/data/ForecastRequestData.asp
            >
            > Note the matrix of match types and which bids are used.
            >
            > -Y!SM Monkey

            Hello Y!SM Monkey,

            Many thanks for your advice! Sorry it took so long to reply, I was on
            vacation last week and read your tips for the Forecast service this
            morning. When I included a value for the sponsoredSearchMaxBid it
            worked fine. Oddly the documentation on the Panama API website states
            that a value for sponsoredSearchMaxBid (and contentMatchMaxBid) is
            optional .... have I misunderstood something here?

            Big thank you for your valuable assistance!
            Cheers, Dinesh
          • Yahoo! Search Marketing Monkey
            ... Hey there, These are optional because you only have to set them when you set the associated status to on . Use the matrix at the top of the page to
            Message 5 of 5 , Apr 2 8:56 AM
            • 0 Attachment
              > Many thanks for your advice! Sorry it took so long to reply, I was on
              > vacation last week and read your tips for the Forecast service this
              > morning. When I included a value for the sponsoredSearchMaxBid it
              > worked fine. Oddly the documentation on the Panama API website states
              > that a value for sponsoredSearchMaxBid (and contentMatchMaxBid) is
              > optional .... have I misunderstood something here?

              Hey there,

              These are optional because you only have to set them when you set the
              associated status to "on". Use the matrix at the top of the page to
              determine which status flags turn which bid fields into required parameters.

              Hope that helps,

              -Y!SM Monkey
            Your message has been successfully submitted and would be delivered to recipients shortly.