Loading ...
Sorry, an error occurred while loading the content.

GetReport -> Category Summary

Expand Messages
  • rks10x
    I am having a problem with the Category Summary report. Here is my XML:
    Message 1 of 2 , Sep 6, 2005
    • 0 Attachment
      I am having a problem with the Category Summary report. Here is my XML:

      <?xml version="1.0" encoding="UTF-8"?>
      <DTCRequest xmlns:xs="http://www.w3.org/2001/XMLSchema-instance"
      xs:schemaLocation="urn:/ows/aws/1.2
      https://x-secure.overture.com/schema/dtc/1.2/dtc_request.xsd"
      xmlns="urn:/ows/aws/1.2" username="XXXXXX" password="XXXXXXXX"
      key="XXXXXXXXXXXXXX" >
      <Actions accountId="XXXXXXXXXXX" >
      <GetReport>
      <CategorySummary endDate="2005-9-6" beginDate="2005-9-1" />
      </GetReport>
      </Actions>
      </DTCRequest>

      Here is the response I am getting:

      <?xml version="1.0" encoding="UTF-8"?>
      <DTCResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="urn:/ows/aws/1.2
      http://www.overture.com/schema/dtc/1.2/dtc_response.xsd"
      xmlns="urn:/ows/aws/1.2" success="false"
      reason="cvc-datatype-valid.1.2.1: '2005-9-6' is not a valid
      'dateTime' value."></DTCResponse>

      What am I doing wrong. I just can't seem to find it.

      Thanks,

      Keith
    • Yahoo! Search Marketing Monkey
      Hi Keith, Try zero-padding your date fields. So instead of passing 2005-9-6 , use 2005-09-06 . Barring that, a valid dateTime field may also require the
      Message 2 of 2 , Sep 6, 2005
      • 0 Attachment
        Hi Keith,

        Try zero-padding your date fields. So instead of passing "2005-9-6",
        use "2005-09-06". Barring that, a valid "dateTime" field may also
        require the time, so possibly "2005-09-06 00:00:00".

        -Y!SM Monkey

        rks10x wrote:
        > I am having a problem with the Category Summary report. Here is my XML:
        >
        > <?xml version="1.0" encoding="UTF-8"?>
        > <DTCRequest xmlns:xs="http://www.w3.org/2001/XMLSchema-instance"
        > xs:schemaLocation="urn:/ows/aws/1.2
        > https://x-secure.overture.com/schema/dtc/1.2/dtc_request.xsd"
        > xmlns="urn:/ows/aws/1.2" username="XXXXXX" password="XXXXXXXX"
        > key="XXXXXXXXXXXXXX" >
        > <Actions accountId="XXXXXXXXXXX" >
        > <GetReport>
        > <CategorySummary endDate="2005-9-6" beginDate="2005-9-1" />
        > </GetReport>
        > </Actions>
        > </DTCRequest>
        >
        > Here is the response I am getting:
        >
        > <?xml version="1.0" encoding="UTF-8"?>
        > <DTCResponse xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        > xsi:schemaLocation="urn:/ows/aws/1.2
        > http://www.overture.com/schema/dtc/1.2/dtc_response.xsd"
        > xmlns="urn:/ows/aws/1.2" success="false"
        > reason="cvc-datatype-valid.1.2.1: '2005-9-6' is not a valid
        > 'dateTime' value."></DTCResponse>
        >
        > What am I doing wrong. I just can't seem to find it.
        >
        > Thanks,
        >
        > Keith
      Your message has been successfully submitted and would be delivered to recipients shortly.