Loading ...
Sorry, an error occurred while loading the content.

BOSS API web search returns no results

Expand Messages
  • Paul Hiatt
    We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day),
    Message 1 of 10 , Jul 16, 2013
    • 0 Attachment
      We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
      {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
      If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
      1. My users get no results (or a delay while I retry the request)
      2. Given this is a paid API, I'm paying for failed requests
      Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
    • phiatt72
      Just FYI I m still seeing this issue, albeit not as frequently as before. ---In ysearchboss@yahoogroups.com, wrote: We are trying to offer yahoo
      Message 2 of 10 , Sep 30, 2013
      • 0 Attachment

        Just FYI I'm still seeing this issue, albeit not as frequently as before.



        ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

        We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
        {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
        If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
        1. My users get no results (or a delay while I retry the request)
        2. Given this is a paid API, I'm paying for failed requests
        Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
      • dev_50kft
        yep, I m seeing the same thing, especially searching for non-celebrity names, like = { bossresponse = { responsecode = 200 ,
        Message 3 of 10 , Nov 19, 2013
        • 0 Attachment

          yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


           => {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


          just me? what searches are others using that receive no results?


          Keith 



          ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

          Just FYI I'm still seeing this issue, albeit not as frequently as before.



          ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

          We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
          {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
          If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
          1. My users get no results (or a delay while I retry the request)
          2. Given this is a paid API, I'm paying for failed requests
          Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
        • <saweniger@...>
          Same here too. Normal search query like cats and dogs returns sometimes no results. Sascha ... yep, I m seeing the same thing, especially searching for
          Message 4 of 10 , Nov 19, 2013
          • 0 Attachment

            Same here too. Normal search query like 'cats and dogs'  returns sometimes no results.


            Sascha



            ---In ysearchboss@yahoogroups.com, <dev_50kft@...> wrote:

            yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


             => {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


            just me? what searches are others using that receive no results?


            Keith 



            ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

            Just FYI I'm still seeing this issue, albeit not as frequently as before.



            ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

            We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
            {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
            If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
            1. My users get no results (or a delay while I retry the request)
            2. Given this is a paid API, I'm paying for failed requests
            Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
          • jf
            I have some unit tests that issue the same searches and BOSS frequently returns sporadic results. One minute a query returns results, the next minute that
            Message 5 of 10 , Nov 19, 2013
            • 0 Attachment
              I have some unit tests that issue the same searches and BOSS frequently returns sporadic results.  One minute a query returns results, the next minute that same query returns no results.  There's a reason why the BOSS API is about 10% the cost of Google's API.
            • dev_50kft
              Searches like cats and dogs seems to work, but good call I should set up some tests along these lines to see if it s intermittent. The weird things is names.
              Message 6 of 10 , Nov 19, 2013
              • 0 Attachment

                Searches like "cats and dogs" seems to work, but good call I should set up some tests along these lines to see if it's intermittent.


                The weird things is names. If I search someone's name (a non-celebrity) more often than not, I get no results. Any ideas why that would be?


                I'll keep the thread updated with what I figure out.


                Keith



                ---In ysearchboss@yahoogroups.com, <jfister@...> wrote:

                I have some unit tests that issue the same searches and BOSS frequently returns sporadic results.  One minute a query returns results, the next minute that same query returns no results.  There's a reason why the BOSS API is about 10% the cost of Google's API.
              • Rahul Hampole
                Hello Sascha, I tried running these queries multiple times and was unable to see this issue happen. Do you have some stats that you can share over how often
                Message 7 of 10 , Nov 20, 2013
                • 0 Attachment
                  Hello Sascha,
                  I tried running these queries multiple times and was unable to see this issue happen. Do you have some stats that you can share over how often you are seeing the issue, etc? 

                  ~BOSS Team


                  From: "saweniger@..." <saweniger@...>
                  Reply-To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
                  Date: Tuesday, November 19, 2013 1:43 PM
                  To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
                  Subject: [ysearchboss] RE: BOSS API web search returns no results

                   

                  Same here too. Normal search query like 'cats and dogs'  returns sometimes no results.


                  Sascha



                  ---In ysearchboss@yahoogroups.com, <dev_50kft@...> wrote:

                  yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


                   => {"bossresponse"=>{"re! sponsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


                  just me? what searches are others using that receive no results?


                  Keith 



                  ---In ysearchboss@yahoogroups.com, <hiattp@...&g! t; wrote:

                  Just FYI I'm still seeing this issue, albeit not as frequently as before.



                  ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                  We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
                  {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
                  If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
                  1. My users get no results (or a delay while I retry the request)
                  2. Given this is a paid API, I'm paying for failed requests
                  Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
                  !

                • <saweniger@...>
                  Hey Rahul, actually we dont have any logs if no result is given. We just found that out as we deployed a new yahooboss service. But i will ask the devops team
                  Message 8 of 10 , Nov 20, 2013
                  • 0 Attachment

                    Hey Rahul,


                    actually we dont have any logs if no result is given. We just found that out as we deployed a new yahooboss service. But i will ask the devops team and provide an answer here if possible. We are using news and web search and its related to both of them.


                    Sascha 



                    ---In ysearchboss@yahoogroups.com, <rhampole@...> wrote:

                    Hello Sascha,
                    I tried running these queries multiple times and was unable to see this issue happen. Do you have some stats that you can share over how often you are seeing the issue, etc? 

                    ~BOSS Team


                    From: "saweniger@..." <saweniger@...>
                    Reply-To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
                    Date: Tuesday, November 19, 2013 1:43 PM
                    To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
                    Subject: [ysearchboss] RE: BOSS API web search returns no results

                     

                    Same here too. Normal search query like 'cats and dogs'  returns sometimes no results.


                    Sascha



                    ---In ysearchboss@yahoogroups.com, <dev_50kft@...> wrote:

                    yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


                     => {"bossresponse"=>{"re! sponsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


                    just me? what searches are others using that receive no results?


                    Keith 



                    ---In ysearchboss@yahoogroups.com, <hiattp@...&g! t; wrote:

                    Just FYI I'm still seeing this issue, albeit not as frequently as before.



                    ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                    We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
                    {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
                    If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
                    1. My users get no results (or a delay while I retry the request)
                    2. Given this is a paid API, I'm paying for failed requests
                    Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
                    !
                  • 3a86660f10d0a8567a78bc3c451af18a
                    I m having the same problem with the Placefinder API. Getting no results. Any updates on what s happening? ... yep, I m seeing the same thing, especially
                    Message 9 of 10 , Nov 20, 2013
                    • 0 Attachment

                      I'm having the same problem with the Placefinder API. Getting no results. Any updates on what's happening? 



                      ---In ysearchboss@yahoogroups.com, <dev_50kft@...> wrote:

                      yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


                       => {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


                      just me? what searches are others using that receive no results?


                      Keith 



                      ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                      Just FYI I'm still seeing this issue, albeit not as frequently as before.



                      ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                      We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
                      {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
                      If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
                      1. My users get no results (or a delay while I retry the request)
                      2. Given this is a paid API, I'm paying for failed requests
                      Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?
                    • oliverfroitzheim
                      Hi there, I had the same issue. Maybe my fix will help you as well. I used to send the query url encoded (e.g. urlencode() in php). This worked absolutely
                      Message 10 of 10 , Jan 21, 2014
                      • 0 Attachment
                        Hi there, 

                        I had the same issue. Maybe my fix will help you as well. I used to send the query url encoded (e.g. urlencode() in php). This worked absolutely fine. But now it only works when there is no url encoding. By passing the raw data to the API it started working again. 

                        Hope this helps. 


                        Oliver

                        Am 20.11.2013 um 22:51 schrieb <kwebb@...> <kwebb@...>:

                         

                        I'm having the same problem with the Placefinder API. Getting no results. Any updates on what's happening? 



                        ---In ysearchboss@yahoogroups.com, <dev_50kft@...> wrote:

                        yep, I'm seeing the same thing, especially searching for non-celebrity names, like <first-name> <last-name>


                         => {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}} 


                        just me? what searches are others using that receive no results?


                        Keith 



                        ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                        Just FYI I'm still seeing this issue, albeit not as frequently as before.



                        ---In ysearchboss@yahoogroups.com, <hiattp@...> wrote:

                        We are trying to offer yahoo web results to our users and are piloting with ~100 queries per day. For approximately 10% of the queries (depending on the day), I get the following response:
                        {"bossresponse"=>{"responsecode"=>"200", "web"=>{"start"=>"0", "count"=>"0", "totalresults"=>"0"}}}
                        If I execute the exact same query upon receiving no results, I'll get results (90% of the time). What might explain this? It is concerning on two levels:
                        1. My users get no results (or a delay while I retry the request)
                        2. Given this is a paid API, I'm paying for failed requests
                        Is this a known issue that I can avoid somehow? Sometimes our requests come quickly back-to-back, is there a rate limit that I missed?


                      Your message has been successfully submitted and would be delivered to recipients shortly.