Loading ...
Sorry, an error occurred while loading the content.

response code is 200 but no ads are returned

Expand Messages
  • bitsforpeace
    We ve been approved (two days ago) for Ads but when when we call the JS function with the token nothing is returned:
    Message 1 of 3 , Jun 18, 2013
    • 0 Attachment
      We've been approved (two days ago) for Ads but when when we call the JS function with the token nothing is returned:

      render_ads({"bossresponse":{"responsecode":"200"}})

      Thus the code breaks:

      Uncaught TypeError: Cannot read property 'resultset' of undefined

      Has anyone seen this before?

      Thanks in advance for the guidance!
    • Rahul Hampole
      Hi Have you tried using the test=true in your JS call? See http://developer.yahoo.com/boss/search/boss_api_guide/ads_service_args.html This will allow you to
      Message 2 of 3 , Jun 18, 2013
      • 0 Attachment
        Hi
        Have you tried using the test=true in your JS call? See http://developer.yahoo.com/boss/search/boss_api_guide/ads_service_args.html 

        This will allow you to test the full functionality of your code without actually getting Ads. If this is not working correctly, then you can review your code further. 

        Please note that depending on where you are, Actual Ads may be not be returned due to IP's, Market (e.g. No ads in Israel), etc. 

        Thanks
        BOSS Team


        From: bitsforpeace <bitsforpeace@...>
        Reply-To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
        Date: Tuesday, June 18, 2013 1:07 AM
        To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
        Subject: [ysearchboss] response code is 200 but no ads are returned

         


        We've been approved (two days ago) for Ads but when when we call the JS function with the token nothing is returned:

        render_ads({"bossresponse":{"responsecode":"200"}})

        Thus the code breaks:

        Uncaught TypeError: Cannot read property 'resultset' of undefined

        Has anyone seen this before?

        Thanks in advance for the guidance!

      • bitsforpeace
        Hi Rahul ... Yes we have that set. ... This seems to be the problem. We are approved for US and Canada. But development is done here in Taiwan. When we try
        Message 3 of 3 , Jun 18, 2013
        • 0 Attachment
          Hi Rahul

          --- In ysearchboss@yahoogroups.com, Rahul Hampole <rhampole@...> wrote:

          > Have you tried using the test=true in your JS call? See http://developer.yahoo.com/boss/search/boss_api_guide/ads_service_args.html

          Yes we have that set.

          > This will allow you to test the full functionality of your code without actually getting Ads. If this is not working correctly, then you can review your code further.
          >
          > Please note that depending on where you are, Actual Ads may be not be returned due to IP's, Market (e.g. No ads in Israel), etc.

          This seems to be the problem. We are approved for US and Canada. But development is done here in Taiwan. When we try through a *cough* US proxy we get ads.

          I just assumed the user would get US and Canada ads :)

          We'll fix the JS code (FYI: the sample on your site will break if no ads are returned) and see about getting approved globally.

          Thanks for the help!

          Sean
        Your message has been successfully submitted and would be delivered to recipients shortly.