Loading ...
Sorry, an error occurred while loading the content.
 

Re: [ysearchboss] Re: BOSS Not Returning Search Results

Expand Messages
  • Paymon
    Your sending a bad request (400 error) since there is no query term ( q parameter specified in your query) below. so if you change it to this it will work:
    Message 1 of 8 , May 14, 2013
      Your sending a bad request (400 error) since there is no query term ('q' parameter specified in your query) below.

      so if you change it to this it will work:

      http://yboss.yahooapis.com/ysearch/images?q=dvd&count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

      Cheers!


      BOSS Team


      From: davidkassa <david.kassa@...>
      To: ysearchboss@yahoogroups.com
      Sent: Tuesday, May 14, 2013 7:10 AM
      Subject: [ysearchboss] Re: BOSS Not Returning Search Results

      My image search stopped working recently too.

      I just noticed it and started debugging today. I am getting a 400 bad request response.

      I think technically my query was wrong because I use common code for web and image where filter=[-porn] and looking at the image docs it needs to be filter=yes but that has historically worked and now I can't get image search working even when I remove this filter.

      My current query is http://yboss.yahooapis.com/ysearch/images?count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

      (Sorry to Paymon who's probably seen this message 3 times now)

      --- In ysearchboss@yahoogroups.com, Paymon <paymon_a@...> wrote:
      >
      > Hello Craig,
      >
      > Nothing has recently changed, BOSS image search does return results. Can you give us an example of your
      >  request for image search, that isn't working for you (minus your keys of course).
      >
      > Regards,
      >
      > BOSS Team
      >
      >
      > ________________________________
      >  From: craigrom37 <craig@...>
      > To: ysearchboss@yahoogroups.com
      > Sent: Sunday, April 14, 2013 11:48 AM
      > Subject: [ysearchboss] BOSS Not Returning Search Results

      >
      > Hello, It appears BOSS is only returning results when I query Wikipedia or news.  I'm not getting search results or images.  My query used to work for all searches.  Did something recently change?
      >
      > Please advise.
      >
      > thanks
      > Craig
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      >     http://docs.yahoo.com/info/terms/
      >



      ------------------------------------

      Yahoo! Groups Links

      <*> To visit your group on the web, go to:
          http://groups.yahoo.com/group/ysearchboss/

      <*> Your email settings:
          Individual Email | Traditional

      <*> To change settings online go to:
          http://groups.yahoo.com/group/ysearchboss/join
          (Yahoo! ID required)

      <*> To change settings via email:
          ysearchboss-digest@yahoogroups.com
          ysearchboss-fullfeatured@yahoogroups.com

      <*> To unsubscribe from this group, send an email to:
          ysearchboss-unsubscribe@yahoogroups.com

      <*> Your use of Yahoo! Groups is subject to:
          http://docs.yahoo.com/info/terms/



    • David Kassa
      The q=abraham+lincoln (I ve tried abraham%20lincoln too). Does it have to be the first parameter? That would strike me as odd.
      Message 2 of 8 , May 14, 2013
        The q=abraham+lincoln (I've tried abraham%20lincoln too). Does it have to be the first parameter? That would strike me as odd.


        On Tue, May 14, 2013 at 12:56 PM, Paymon <paymon_a@...> wrote:
         

        Your sending a bad request (400 error) since there is no query term ('q' parameter specified in your query) below.

        so if you change it to this it will work:

        http://yboss.yahooapis.com/ysearch/images?q=dvd&count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

        Cheers!


        BOSS Team


        From: davidkassa <david.kassa@...>
        To: ysearchboss@yahoogroups.com
        Sent: Tuesday, May 14, 2013 7:10 AM
        Subject: [ysearchboss] Re: BOSS Not Returning Search Results

        My image search stopped working recently too.

        I just noticed it and started debugging today. I am getting a 400 bad request response.

        I think technically my query was wrong because I use common code for web and image where filter=[-porn] and looking at the image docs it needs to be filter=yes but that has historically worked and now I can't get image search working even when I remove this filter.

        My current query is http://yboss.yahooapis.com/ysearch/images?count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

        (Sorry to Paymon who's probably seen this message 3 times now)

        --- In ysearchboss@yahoogroups.com, Paymon <paymon_a@...> wrote:
        >
        > Hello Craig,
        >
        > Nothing has recently changed, BOSS image search does return results. Can you give us an example of your
        >  request for image search, that isn't working for you (minus your keys of course).
        >
        > Regards,
        >
        > BOSS Team
        >
        >
        > ________________________________
        >  From: craigrom37 <craig@...>
        > To: ysearchboss@yahoogroups.com
        > Sent: Sunday, April 14, 2013 11:48 AM
        > Subject: [ysearchboss] BOSS Not Returning Search Results

        >
        > Hello, It appears BOSS is only returning results when I query Wikipedia or news.  I'm not getting search results or images.  My query used to work for all searches.  Did something recently change?
        >
        > Please advise.
        >
        > thanks
        > Craig
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        >     http://docs.yahoo.com/info/terms/
        >



        ------------------------------------

        Yahoo! Groups Links

        <*> To visit your group on the web, go to:
            http://groups.yahoo.com/group/ysearchboss/

        <*> Your email settings:
            Individual Email | Traditional

        <*> To change settings online go to:
            http://groups.yahoo.com/group/ysearchboss/join
            (Yahoo! ID required)

        <*> To change settings via email:
            ysearchboss-digest@yahoogroups.com
            ysearchboss-fullfeatured@yahoogroups.com

        <*> To unsubscribe from this group, send an email to:
            ysearchboss-unsubscribe@yahoogroups.com

        <*> Your use of Yahoo! Groups is subject to:
            http://docs.yahoo.com/info/terms/




      • Paymon
        no, there is no order to the parameters, but it must be present. your query term works for me; below is the first two results returned for term
        Message 3 of 8 , May 14, 2013
          no, there is no order to the parameters, but it must be present.
          your query term works for me; below is the first two results returned for term "abraham+lincoln":

          sinpp....

          <bossresponse responsecode="200"><images start="0" count="35" totalresults="5710000"><results><result><clickurl>http://our-hope.org/blog/wp-content/uploads/2011/05/Abraham_Lincoln.jpg</clickurl><size>72.1KB</size><format>jpeg</format><height>1344</height><refererclickurl>http://our-hope.org/blog/2011/05/abraham-lincoln-and-charles-finney/</refererclickurl><refererurl>http://our-hope.org/blog/2011/05/abraham-lincoln-and-charles-finney/</refererurl><title>Abraham Lincoln and Charles Finney « Our Hope</title><url>http://our-hope.org/blog/wp-content/uploads/2011/05/Abraham_Lincoln.jpg</url><width>1024</width><thumbnailheight>160</thumbnailheight><thumbnailurl>http://ts1.mm.bing.net/th?id=H.5060619192044220&pid=15.1&H=160&W=121</thumbnailurl><thumbnailwidth>121</thumbnailwidth></result>
          .....
          ......
          ........


          From: David Kassa <david.kassa@...>
          To: ysearchboss@yahoogroups.com
          Sent: Tuesday, May 14, 2013 11:01 AM
          Subject: Re: [ysearchboss] Re: BOSS Not Returning Search Results



          The q=abraham+lincoln (I've tried abraham%20lincoln too). Does it have to be the first parameter? That would strike me as odd.


          On Tue, May 14, 2013 at 12:56 PM, Paymon <paymon_a@...> wrote:
           
          Your sending a bad request (400 error) since there is no query term ('q' parameter specified in your query) below.

          so if you change it to this it will work:

          http://yboss.yahooapis.com/ysearch/images?q=dvd&count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

          Cheers!


          BOSS Team


          From: davidkassa <david.kassa@...>
          To: ysearchboss@yahoogroups.com
          Sent: Tuesday, May 14, 2013 7:10 AM
          Subject: [ysearchboss] Re: BOSS Not Returning Search Results

          My image search stopped working recently too.

          I just noticed it and started debugging today. I am getting a 400 bad request response.

          I think technically my query was wrong because I use common code for web and image where filter=[-porn] and looking at the image docs it needs to be filter=yes but that has historically worked and now I can't get image search working even when I remove this filter.

          My current query is http://yboss.yahooapis.com/ysearch/images?count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

          (Sorry to Paymon who's probably seen this message 3 times now)

          --- In ysearchboss@yahoogroups.com, Paymon <paymon_a@...> wrote:
          >
          > Hello Craig,
          >
          > Nothing has recently changed, BOSS image search does return results. Can you give us an example of your
          >  request for image search, that isn't working for you (minus your keys of course).
          >
          > Regards,
          >
          > BOSS Team
          >
          >
          > ________________________________
          >  From: craigrom37 <craig@...>
          > To: ysearchboss@yahoogroups.com
          > Sent: Sunday, April 14, 2013 11:48 AM
          > Subject: [ysearchboss] BOSS Not Returning Search Results

          >
          > Hello, It appears BOSS is only returning results when I query Wikipedia or news.  I'm not getting search results or images.  My query used to work for all searches.  Did something recently change?
          >
          > Please advise.
          >
          > thanks
          > Craig
          >
          >
          >
          > ------------------------------------
          >
          > Yahoo! Groups Links
          >
          >
          >
          >     http://docs.yahoo.com/info/terms/
          >



          ------------------------------------

          Yahoo! Groups Links

          <*> To visit your group on the web, go to:
              http://groups.yahoo.com/group/ysearchboss/

          <*> Your email settings:
              Individual Email | Traditional

          <*> To change settings online go to:
              http://groups.yahoo.com/group/ysearchboss/join
              (Yahoo! ID required)

          <*> To change settings via email:
              ysearchboss-digest@yahoogroups.com
              ysearchboss-fullfeatured@yahoogroups.com

          <*> To unsubscribe from this group, send an email to:
              ysearchboss-unsubscribe@yahoogroups.com

          <*> Your use of Yahoo! Groups is subject to:
              http://docs.yahoo.com/info/terms/








        • David Kassa
          Finally got back to this. The issue was that both my web search and image search shared type=html and, apparently, image search started being more strict with
          Message 4 of 8 , May 24, 2013
            Finally got back to this. The issue was that both my web search and image search shared type=html and, apparently, image search started being more strict with inputs.


            On Tue, May 14, 2013 at 1:09 PM, Paymon <paymon_a@...> wrote:
             

            no, there is no order to the parameters, but it must be present.
            your query term works for me; below is the first two results returned for term "abraham+lincoln":

            sinpp....

            <bossresponse responsecode="200"><images start="0" count="35" totalresults="5710000"><results><result><clickurl>http://our-hope.org/blog/wp-content/uploads/2011/05/Abraham_Lincoln.jpg</clickurl><size>72.1KB</size><format>jpeg</format><height>1344</height><refererclickurl>http://our-hope.org/blog/2011/05/abraham-lincoln-and-charles-finney/</refererclickurl><refererurl>http://our-hope.org/blog/2011/05/abraham-lincoln-and-charles-finney/</refererurl><title>Abraham Lincoln and Charles Finney « Our Hope</title><url>http://our-hope.org/blog/wp-content/uploads/2011/05/Abraham_Lincoln.jpg</url><width>1024</width><thumbnailheight>160</thumbnailheight><thumbnailurl>http://ts1.mm.bing.net/th?id=H.5060619192044220&pid=15.1&H=160&W=121</thumbnailurl><thumbnailwidth>121</thumbnailwidth></result>
            .....
            ......
            ........


            From: David Kassa <david.kassa@...>
            To: ysearchboss@yahoogroups.com
            Sent: Tuesday, May 14, 2013 11:01 AM
            Subject: Re: [ysearchboss] Re: BOSS Not Returning Search Results



            The q=abraham+lincoln (I've tried abraham%20lincoln too). Does it have to be the first parameter? That would strike me as odd.


            On Tue, May 14, 2013 at 12:56 PM, Paymon <paymon_a@...> wrote:
             
            Your sending a bad request (400 error) since there is no query term ('q' parameter specified in your query) below.

            so if you change it to this it will work:

            http://yboss.yahooapis.com/ysearch/images?q=dvd&count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

            Cheers!


            BOSS Team


            From: davidkassa <david.kassa@...>
            To: ysearchboss@yahoogroups.com
            Sent: Tuesday, May 14, 2013 7:10 AM
            Subject: [ysearchboss] Re: BOSS Not Returning Search Results

            My image search stopped working recently too.

            I just noticed it and started debugging today. I am getting a 400 bad request response.

            I think technically my query was wrong because I use common code for web and image where filter=[-porn] and looking at the image docs it needs to be filter=yes but that has historically worked and now I can't get image search working even when I remove this filter.

            My current query is http://yboss.yahooapis.com/ysearch/images?count=35&format=xml&market=en-gb&oauth_consumer_key=MY_KEY&oauth_nonce=MY_NONCE&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1368509652&oauth_version=1.0&q=abraham+lincoln&start=0&type=html&oauth_signature=MY_SIG

            (Sorry to Paymon who's probably seen this message 3 times now)

            --- In ysearchboss@yahoogroups.com, Paymon <paymon_a@...> wrote:
            >
            > Hello Craig,
            >
            > Nothing has recently changed, BOSS image search does return results. Can you give us an example of your
            >  request for image search, that isn't working for you (minus your keys of course).
            >
            > Regards,
            >
            > BOSS Team
            >
            >
            > ________________________________
            >  From: craigrom37 <craig@...>
            > To: ysearchboss@yahoogroups.com
            > Sent: Sunday, April 14, 2013 11:48 AM
            > Subject: [ysearchboss] BOSS Not Returning Search Results

            >
            > Hello, It appears BOSS is only returning results when I query Wikipedia or news.  I'm not getting search results or images.  My query used to work for all searches.  Did something recently change?
            >
            > Please advise.
            >
            > thanks
            > Craig
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
            >     http://docs.yahoo.com/info/terms/
            >



            ------------------------------------

            Yahoo! Groups Links

            <*> To visit your group on the web, go to:
                http://groups.yahoo.com/group/ysearchboss/

            <*> Your email settings:
                Individual Email | Traditional

            <*> To change settings online go to:
                http://groups.yahoo.com/group/ysearchboss/join
                (Yahoo! ID required)

            <*> To change settings via email:
                ysearchboss-digest@yahoogroups.com
                ysearchboss-fullfeatured@yahoogroups.com

            <*> To unsubscribe from this group, send an email to:
                ysearchboss-unsubscribe@yahoogroups.com

            <*> Your use of Yahoo! Groups is subject to:
                http://docs.yahoo.com/info/terms/









          Your message has been successfully submitted and would be delivered to recipients shortly.