Loading ...
Sorry, an error occurred while loading the content.

Re: [ysearchboss] Re: Strange result from Blog search when no results available

Expand Messages
  • Rahul Hampole
    Hi Mark I tried this /ysearch/blogs?q=san%20francisco&market=en-us&format=xml and it seems to be getting results. The query you provided does not have any blog
    Message 1 of 4 , Apr 17, 2013
    • 0 Attachment
      Hi Mark
      I tried this /ysearch/blogs?q=san%20francisco&market=en-us&format=xml and it seems to be getting results. The query you provided does not have any blog results

      <bossresponse responsecode="200"><blogs start="0" count="20" totalresults="449688"><results><result><score>2436</score><provider>etc</provider><clickurl>http://www.wired.com/gadgetlab/elsewhere/microsoft-coming-to-san-francisco-in-june-for-its-next-big-developer-confab-20130326/</clickurl><dispurl>http://www.wired.com/gadgetlab/elsewhere/microsoft-coming-to-san-francisco-in-june-for-its-next-big-developer-confab-20130326/</dispurl><title>Microsoft Coming to <b>San</b> <b>Francisco</b> in June for Its Next Big Developer Confab</title><abstract>Build 2013, Microsoft&#39;s big developer conference, will take place June 26 to 28 at the Moscone Center in <b>San</b> <b>Francisco</b>.</abstract><keyterms/><date>2013/4/17</date><author/><icon>http://l.yimg.com/pp/favicons-new/wired.com.png</icon></result><result>

      Best
      Rahul


      From: markwreed <markwreed@...>
      Reply-To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
      Date: Wednesday, April 17, 2013 10:18 AM
      To: "ysearchboss@yahoogroups.com" <ysearchboss@yahoogroups.com>
      Subject: [ysearchboss] Re: Strange result from Blog search when no results available

       

      I think you can use any query that returns no results.

      For my testing and the results shown below, I used the following random sequence of characters as my query

      kjadkvanbklv

      I was originally looking into a meaningful query that happened to not have any hits and then realized that any query without results was returning the same way.

      Mark.

      --- In ysearchboss@yahoogroups.com, Rahul Hampole <rhampole@...> wrote:
      >
      > Hi
      > Can you provide an example here for the query you provided?
      > Thanks
      > Rahul
      >
      >
      > From: markwreed <markwreed@...<mailto:markwreed@...>>
      > Reply-To: "ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>" <ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>>
      > Date: Wednesday, April 17, 2013 8:10 AM
      > To: "ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>" <ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>>
      > Subject: [ysearchboss] Strange result from Blog search when no results available
      >
      >
      >
      > If you query BOSS for blogs and it has no results, it still returns a <result> element...
      >
      > <?xml version="1.0" encoding="UTF-8"?>
      > <bossresponse responsecode="200">
      > <blogs start="0" count="0" totalresults="0">
      > <results><result></result></results></blogs></bossresponse>
      >
      > Should there be a "<result>" element in the response?
      >
      > The other BOSS sources do more what I would expect...
      >
      > <?xml version="1.0" encoding="UTF-8"?>
      > <bossresponse responsecode="200">
      > <images start="0" count="0" totalresults="0"><results></results></images></bossresponse>
      >
      > Mark.
      >

    Your message has been successfully submitted and would be delivered to recipients shortly.