Loading ...
Sorry, an error occurred while loading the content.

5445Re: Sudden Drop in YBoss PlaceSpotter Quality?

Expand Messages
  • afar7520
    Jul 12, 2013
    • 0 Attachment
      Hi Rahul,

      Thank you. But I would please urge that you look at this quickly. We are paying quite a lot to hit your API (something like $200/month) and the response time on this issue has been very disappointing.

      ~ Evan

      --- In ysearchboss@yahoogroups.com, Rahul Hampole <rhampole@...> wrote:
      >
      > Hi Evan
      > Give me a day or two and I need to do some tests using oAuth. I tried this with the YQL query and it works fine http://y.ahoo.it/p0O0o so guessing this has something do with encoding.
      >
      > Best
      > BOSS Team
      >
      >
      > From: afar7520 <afar7520@...<mailto:afar7520@...>>
      > Reply-To: "ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>" <ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>>
      > Date: Wednesday, July 10, 2013 2:19 PM
      > To: "ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>" <ysearchboss@yahoogroups.com<mailto:ysearchboss@yahoogroups.com>>
      > Subject: [ysearchboss] Re: Sudden Drop in YBoss PlaceSpotter Quality?
      >
      >
      >
      > Hi Rahul,
      >
      > I believe I provided this in my original message.
      >
      > For example, if I hit the service with the string "oak park illinois" it returns
      > a Status Code 200 with a blank body.
      >
      > There is a city, called Oak Park, in the state,"Illinois" and that is what I'd expect to be returned. Not a blank body.
      >
      > If I hit the service with the string "oak park, illinois" it returns a 200 and a
      > blank body.
      >
      > HOWEVER, if I hit the service with "oak park,illinois" [notice I've removed a
      > space], I get the response:
      >
      > {"administrativescope"=>
      > {"woeid"=>"2347572",
      > "type"=>"State",
      >
      > So, does that answer your question? Have you tried querying the service yourself with "Oak Park Illinois" vs "Oak Park, Illinois" vs "Oak Park,Illinois"?
      >
      > Thanks,
      >
      > Evan
      >
      > --- In ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com>, Rahul Hampole <rhampole@> wrote:
      > >
      > > Hi
      > > Can you provide a content sample? I want to see what you were providing and the expectations of results so that I can see where the issue is happening?
      > >
      > > Thanks
      > > BOSS Team
      > >
      > >
      > > From: afar7520 <afar7520@<mailto:afar7520@>>
      > > Reply-To: "ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com>>" <ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com>>>
      > > Date: Monday, July 8, 2013 1:52 PM
      > > To: "ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com>>" <ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com>>>
      > > Subject: [ysearchboss] Re: Sudden Drop in YBoss PlaceSpotter Quality?
      > >
      > >
      > >
      > > Hi Rahul,
      > >
      > > Not really sure what you are asking. Since I'm using OAuth, I can't exactly drop in a URL right here to make it clear.
      > >
      > > I'm hitting this url:
      > >
      > > ENDPOINT = "http://yboss.yahooapis.com/geo/placespotter
      > >
      > > With these parameters:
      > >
      > > {
      > > documentType: 'text/plain',
      > > outputType: 'json',
      > > documentContent: URI.escape(" my content goes here! " )
      > > }
      > >
      > > And I'm using this sort of OAuth (ruby snippet);
      > >
      > > OAuth::Consumer.new(APP_ID, APP_SECRET, {
      > > :site => "https://api.login.yahoo.com/oauth/v2/ ",
      > > :request_token_path => "/oauth/v2/get_request_token",
      > > :access_token_path => "/oauth/v2/get_token",
      > > :authorize_path => "/oauth/v2/request_auth",
      > > :signature_method => "HMAC-SHA1"})
      > >
      > > But have you looked at the examples I posted in my original question? Have you tried those internally against the Placespotter? Can you please tell me if I should be expecting better results?
      > >
      > > Thanks,
      > >
      > > Evan
      > >
      > > --- In ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>, Rahul Hampole <rhampole@> wrote:
      > > >
      > > > Apologies on not getting back on this. We missed your earlier question.
      > > >
      > > > Can you provide the full call you are making?
      > > >
      > > > Regards
      > > > BOSS Team
      > > >
      > > >
      > > > From: afar7520 <afar7520@<mailto:afar7520@>>
      > > > Reply-To: "ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>>" <ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>>>
      > > > Date: Tuesday, July 2, 2013 10:34 AM
      > > > To: "ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>>" <ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>>>
      > > > Subject: [ysearchboss] Re: Sudden Drop in YBoss PlaceSpotter Quality?
      > > >
      > > >
      > > >
      > > > Is anyone listening at Yahoo? This issue is very detrimental to my work. Likewise, we are still paying for these API calls which are no longer giving valid responses.
      > > >
      > > > --- In ysearchboss@yahoogroups.com<mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com><mailto:ysearchboss%40yahoogroups.com>, "afar7520" <afar7520@> wrote:
      > > > >
      > > > > Hi,
      > > > >
      > > > > I've been using YBoss PlaceSpotter for several months now, but recently, I've noticed a dramatic change in the quality of the results.
      > > > >
      > > > > For example, if I hit the service with the string "oak park illinois" it returns a Status Code 200 with a blank body.
      > > > >
      > > > > If I hit the service with the string "oak park, illinois" it returns a 200 and a blank body.
      > > > >
      > > > > HOWEVER, if I hit the service with "oak park,illinois" [notice I've removed a space], I get the response:
      > > > >
      > > > > {"administrativescope"=>
      > > > > {"woeid"=>"2347572",
      > > > > "type"=>"State",
      > > > > ....
      > > > >
      > > > > Any idea why this may have changed? And why this is being suddenly fickle?
      > > > >
      > > > > This is via http://yboss.yahooapis.com/geo/placespotter
      > > > >
      > > >
      > >
      >
    • Show all 11 messages in this topic