Loading ...
Sorry, an error occurred while loading the content.

Re: A Bug:AutoComplete And Modal's Panel

Expand Messages
  • jennykhan
    Sorry, but this is still not enough information. Using the code you originally sent, I m able to show and then hide the modal panel and then successfully use
    Message 1 of 7 , Jan 30, 2007
    • 0 Attachment
      Sorry, but this is still not enough information. Using the code you
      originally sent, I'm able to show and then hide the modal panel and
      then successfully use both AutoComplete widgets. If you are still
      seeing a problem, please post a reproducible example online with
      specific test case steps so we can try to troubleshoot.

      Thanks,
      Jenny



      --- In ydn-javascript@yahoogroups.com, "langzi.tech" <langzi.tech@...>
      wrote:
      >
      > Hi,jennykhan:
      >
      > If you want to reproduce the issue,you can use any yui's
      > examples.
      >
      > The problem is you must trigger the Panel to Show
      > with "ShowModal" at first,then the AutoComplete will can't work
      > fine,if not,it work fine.
      >
      > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
      > wrote:
      > >
      > > Hi there,
      > >
      > > Thank you for the additional information. However, I am still not
      > able
      > > to reproduce the issue. If anyone could post a link to an online
      > > reproducible case, it would be much appreciated.
      > >
      > > Thanks,
      > > Jenny
      > >
      > >
      > >
      > >
      > > --- In ydn-javascript@yahoogroups.com, "takitzis" <takitzis@>
      > wrote:
      > > >
      > > > I believe the problem is the same as mine.
      > > >
      > > > We have an AutoComplete.
      > > > We also have a panel with modal=true.
      > > > The autocomplete works fine until I show the panel and then hide
      > it.
      > > > After the hide action, the autocomplete is stops working.
      > > >
      > > > If the same panel has the option modal=false, If I show and then
      > hide
      > > > the panel the autocomplete works fine, after the hide action.
      > > >
      > > > So, the major problem is after the show/hide action of a panel
      > with
      > > > modal=true.
      > > >
      > > > This is a problem only in IE (6 & 7) and not on Firefox and
      > Opera
      > > > where the autocomplete works fine, no matter the modal state of
      > the
      > > > panel. I've tryed all the possible combinations of queryDelay,
      > > > useIFrame, useShadow, minQueryLength, maxCacheEntries and on all
      > > > combinations the IE keeps to deny to show the autocomplete,
      > after the
      > > > hide action of a modal panel.
      > > >
      > > > It seems that the Autocomplete is not fired up, after the hide
      > action
      > > > of the modal panel, because on IE, it never enters at the
      > > > formatResult function.
      > > >
      > > > Any possible solution ?
      > > >
      > > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
      > > > wrote:
      > > > >
      > > > > Hi there,
      > > > >
      > > > > By definition, your modal Panel instance should not allow
      > > > interaction
      > > > > with any other page elements, including AutoComplete. The
      > behavior
      > > > you
      > > > > are seeing is to be expected.
      > > > >
      > > > > Regards,
      > > > > Jenny
      > > > >
      > > > >
      > > > >
      > > > >
      > > > >
      > > > > --- In ydn-javascript@yahoogroups.com, "langzi.tech"
      > <langzi.tech@>
      > > > > wrote:
      > > > > >
      > > > > > if you have a autocomplete and a panel.
      > > > > > the modal of panel is true.
      > > > > >
      > > > > > if you show panel,then the autocomplete will can't show
      > dropdown
      > > > box.
      > > > > >
      > > > > > i test this issue in the yui's examples.
      > > > > >
      > > > > > if show panel1(modal=false),the autocomplete work fine.
      > > > > >
      > > > > > if show panel2(modal=true),the autocomplet work not fine.
      > > > > >
      > > > > > code:
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.