Loading ...
Sorry, an error occurred while loading the content.

Re: Strange Menu Rendering Problem

Expand Messages
  • ianitlxndr
    Message 1 of 3 , Jan 1, 2007
    • 0 Attachment
      --- In ydn-javascript@yahoogroups.com, Todd Kloots <kloots@...> wrote:
      >
      > Hey Ken -
      >
      > Are you still experiencing this problem? I wasn't
      > able to reproduce this issue in IE 6 or 7. One tip -
      > if you are building a menu completely from JavaScript
      > you always need to call the "render" method with a
      > node reference or id. You can only call "render" with
      > no arguments if you are building your menu from
      > existing markup. This is covered on the Menu landing
      > page under the section titled "Basic Setup."
      >
      > I hope that helps.
      >
      > - Todd
      >
      > --- Ken Robinson <kenrbnsn@...> wrote:
      >
      > > I have a menu on a page that renders fine when I use
      > >
      > > oMenuBar.render(document.body), but when I leave out
      > > the
      > > "document.body" or put in a string with the name of
      > > the DIV where I
      > > want it to render, it works fine in Firefox but not
      > > in MSIE6. In
      > > MSIE, the information in the menu area displays
      > > briefly and then disappears.
      > >
      > > This is using v0.12 and menus generated via JSON.
      > > The site is behind
      > > a corporate firewall, but I will try to generate an
      > > example which
      > > shows the same symptoms to post publicly.
      > >
      > > Ken
      > >
      > >
      > >
      > >
      > > Yahoo! Groups Links
      > >
      > > (Yahoo! ID required)
      > >
      > > mailto:ydn-javascript-fullfeatured@yahoogroups.com
      > >
      > >
      > >
      > >
      > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.