Loading ...
Sorry, an error occurred while loading the content.

RE: [ydn-javascript] Modal dialog is grayed out

Expand Messages
  • Steven Peterson
    This is probably related to your z-index or the location that you re rendering your Dialog. You should try rendering your Dialog to document.body --
    Message 1 of 3 , Nov 30, 2006
    • 0 Attachment

      This is probably related to your z-index or the location that you’re rendering your Dialog.  You should try rendering your Dialog to document.body -- myDialog.render(document.body) – regardless of where the markup is initially located, so that the ordering works properly. Also, make sure that your Dialog has a z-index higher than the mask. This is calculated automatically by the Panel class, but any custom CSS being used may affect your results.

       

      Steven Peterson

      Web Developer, Platform Engineering

      Yahoo!

       

       

      From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of daweiwang
      Sent: Thursday, November 30, 2006 5:51 PM
      To: ydn-javascript@yahoogroups.com
      Subject: [ydn-javascript] Modal dialog is grayed out

       

      When i set dialog modal parameter to ture, when the dialog is shown,
      it's grayed out as the background page, this happens for IE7.

      Same page works well with Firefox 2.0, there is no any javascript
      error in firefox error console.

      Anyone know what is wrong?

    • daweiwang
      Thank you, Steven. This works great(render to document body). ... where the ... Also, make ... calculated ... affect ...
      Message 2 of 3 , Dec 3, 2006
      • 0 Attachment
        Thank you, Steven. This works great(render to document body).

        --- In ydn-javascript@yahoogroups.com, "Steven Peterson"
        <y_stevenp@...> wrote:
        >
        > This is probably related to your z-index or the location that you're
        > rendering your Dialog. You should try rendering your Dialog to
        > document.body -- myDialog.render(document.body) - regardless of
        where the
        > markup is initially located, so that the ordering works properly.
        Also, make
        > sure that your Dialog has a z-index higher than the mask. This is
        calculated
        > automatically by the Panel class, but any custom CSS being used may
        affect
        > your results.
        >
        >
        >
        > Steven Peterson
        >
        > Web Developer, Platform Engineering
        >
        > Yahoo!
        >
        >
        >
        >
        >
        > From: ydn-javascript@yahoogroups.com
        [mailto:ydn-javascript@yahoogroups.com]
        > On Behalf Of daweiwang
        > Sent: Thursday, November 30, 2006 5:51 PM
        > To: ydn-javascript@yahoogroups.com
        > Subject: [ydn-javascript] Modal dialog is grayed out
        >
        >
        >
        > When i set dialog modal parameter to ture, when the dialog is shown,
        > it's grayed out as the background page, this happens for IE7.
        >
        > Same page works well with Firefox 2.0, there is no any javascript
        > error in firefox error console.
        >
        > Anyone know what is wrong?
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.