Loading ...
Sorry, an error occurred while loading the content.

Re: Auto Complete Issue in Firefox - sample link included - please help

Expand Messages
  • jennykhan
    Hi there, I m not able to reproduce the problem using your code but pointing to the latest YUI builds. Can you confirm which version you are using? Thanks,
    Message 1 of 11 , Nov 30, 2006
    • 0 Attachment
      Hi there,

      I'm not able to reproduce the problem using your code but pointing to
      the latest YUI builds. Can you confirm which version you are using?

      Thanks,
      Jenny





      --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@...>
      wrote:
      >
      > The Issue is this:
      > In IE 6 & 7 the auto complete works as it should.
      > However, in Firefox 1.5, when data is entered into the imput field found
      > within a fieldset, the shadow and container do NOT drop below the imput
      > field, but instead appear below the label.
      >
      > Here's the link to see for yourself
      > <http://www.keithgill.info/auto-complete_ignorance/restore-what.html>
      >
      > Notable:
      > The YUI CSS exists at block level, plus I am calling several external
      > styles. Even when removing these external styles, and using the exact
      > YUI code, problems exist.
      >
      > Thanks in advance for your help.
      >
    • mayfindher
      Hi Jenny, thanks for responding. The version I am using is: 0.11.4 Quick question: When you went to the following link,
      Message 2 of 11 , Dec 4, 2006
      • 0 Attachment
        Hi Jenny, thanks for responding.

        The version I am using is: 0.11.4

        Quick question:
        When you went to the following link,
        http://www.keithgill.info/auto-complete_ignorance/restore-what.html
        and typed "T" in the input field, were you able to see the problem?
        If not, what browser, version and OS are you running?

        Apart from updating to the latest version, do you have any suggestions
        as to how I can fix this issue?

        Thanks for your assistance Jenny.

        Sincerely,
        Keith



        --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@...> wrote:
        >
        > Hi there,
        >
        > I'm not able to reproduce the problem using your code but pointing to
        > the latest YUI builds. Can you confirm which version you are using?
        >
        > Thanks,
        > Jenny
        >
        >
        >
        >
        >
        > --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@>
        > wrote:
        > >
        > > The Issue is this:
        > > In IE 6 & 7 the auto complete works as it should.
        > > However, in Firefox 1.5, when data is entered into the imput field
        found
        > > within a fieldset, the shadow and container do NOT drop below the
        imput
        > > field, but instead appear below the label.
        > >
        > > Here's the link to see for yourself
        > > <http://www.keithgill.info/auto-complete_ignorance/restore-what.html>
        > >
        > > Notable:
        > > The YUI CSS exists at block level, plus I am calling several external
        > > styles. Even when removing these external styles, and using the exact
        > > YUI code, problems exist.
        > >
        > > Thanks in advance for your help.
        > >
        >
      • jennykhan
        Hi Keith, When I went to your site, I did see the problem. However, in order to troubleshoot, I need to have a reproducible case locally. Since I m not able to
        Message 3 of 11 , Dec 13, 2006
        • 0 Attachment
          Hi Keith,

          When I went to your site, I did see the problem. However, in order to
          troubleshoot, I need to have a reproducible case locally. Since I'm
          not able to reproduce using the latest builds of the library,
          unfortunately I can't offer much advice on how to fix your problem.

          Regards,
          Jenny





          --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@...>
          wrote:
          >
          > Hi Jenny, thanks for responding.
          >
          > The version I am using is: 0.11.4
          >
          > Quick question:
          > When you went to the following link,
          > http://www.keithgill.info/auto-complete_ignorance/restore-what.html
          > and typed "T" in the input field, were you able to see the problem?
          > If not, what browser, version and OS are you running?
          >
          > Apart from updating to the latest version, do you have any suggestions
          > as to how I can fix this issue?
          >
          > Thanks for your assistance Jenny.
          >
          > Sincerely,
          > Keith
          >
          >
          >
          > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@> wrote:
          > >
          > > Hi there,
          > >
          > > I'm not able to reproduce the problem using your code but pointing to
          > > the latest YUI builds. Can you confirm which version you are using?
          > >
          > > Thanks,
          > > Jenny
          > >
          > >
          > >
          > >
          > >
          > > --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@>
          > > wrote:
          > > >
          > > > The Issue is this:
          > > > In IE 6 & 7 the auto complete works as it should.
          > > > However, in Firefox 1.5, when data is entered into the imput field
          > found
          > > > within a fieldset, the shadow and container do NOT drop below the
          > imput
          > > > field, but instead appear below the label.
          > > >
          > > > Here's the link to see for yourself
          > > >
          <http://www.keithgill.info/auto-complete_ignorance/restore-what.html>
          > > >
          > > > Notable:
          > > > The YUI CSS exists at block level, plus I am calling several
          external
          > > > styles. Even when removing these external styles, and using the
          exact
          > > > YUI code, problems exist.
          > > >
          > > > Thanks in advance for your help.
          > > >
          > >
          >
        • assyriannation
          I m having the same problem in my site too. Its working fine on the IE, but not FireFox 2.0. I havent touched the code, but also not sure since when the
          Message 4 of 11 , Dec 14, 2006
          • 0 Attachment
            I'm having the same problem in my site too. Its working fine on the
            IE, but not FireFox 2.0.
            I havent touched the code, but also not sure since when the problem
            started.
            It used to work fine before.

            --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@...>
            wrote:
            >
            > Hi Keith,
            >
            > When I went to your site, I did see the problem. However, in order
            to
            > troubleshoot, I need to have a reproducible case locally. Since I'm
            > not able to reproduce using the latest builds of the library,
            > unfortunately I can't offer much advice on how to fix your problem.
            >
            > Regards,
            > Jenny
            >
            >
            >
            >
            >
            > --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@>
            > wrote:
            > >
            > > Hi Jenny, thanks for responding.
            > >
            > > The version I am using is: 0.11.4
            > >
            > > Quick question:
            > > When you went to the following link,
            > > http://www.keithgill.info/auto-complete_ignorance/restore-
            what.html
            > > and typed "T" in the input field, were you able to see the
            problem?
            > > If not, what browser, version and OS are you running?
            > >
            > > Apart from updating to the latest version, do you have any
            suggestions
            > > as to how I can fix this issue?
            > >
            > > Thanks for your assistance Jenny.
            > >
            > > Sincerely,
            > > Keith
            > >
            > >
            > >
            > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
            wrote:
            > > >
            > > > Hi there,
            > > >
            > > > I'm not able to reproduce the problem using your code but
            pointing to
            > > > the latest YUI builds. Can you confirm which version you are
            using?
            > > >
            > > > Thanks,
            > > > Jenny
            > > >
            > > >
            > > >
            > > >
            > > >
            > > > --- In ydn-javascript@yahoogroups.com, "mayfindher"
            <mayfindher@>
            > > > wrote:
            > > > >
            > > > > The Issue is this:
            > > > > In IE 6 & 7 the auto complete works as it should.
            > > > > However, in Firefox 1.5, when data is entered into the imput
            field
            > > found
            > > > > within a fieldset, the shadow and container do NOT drop below
            the
            > > imput
            > > > > field, but instead appear below the label.
            > > > >
            > > > > Here's the link to see for yourself
            > > > >
            > <http://www.keithgill.info/auto-complete_ignorance/restore-
            what.html>
            > > > >
            > > > > Notable:
            > > > > The YUI CSS exists at block level, plus I am calling several
            > external
            > > > > styles. Even when removing these external styles, and using
            the
            > exact
            > > > > YUI code, problems exist.
            > > > >
            > > > > Thanks in advance for your help.
            > > > >
            > > >
            > >
            >
          • sdezzi
            Keith, In your case, looking at the CSS on the linked page you provided, seems like it s the float:left you have on the LABEL tag which is causing the DIV
            Message 5 of 11 , Dec 14, 2006
            • 0 Attachment
              Keith,

              In your case, looking at the CSS on the linked page you provided,
              seems like it's the 'float:left' you have on the LABEL tag which is
              causing the DIV with id="hostAutocompleteContainer" to wrap around
              under the label (same for the "directoryAutocompleteContainer")

              Applying a 'float:left' to the #hostAutocompleteExternalDiv rule
              should probably fix it. This float gets cleared on the next P, so
              everything should look still look OK for the next LABEL.

              Or, you could apply a 'margin-left:120px' to the same rule, since
              you have a fixed 120px label.

              Either of these should stop the autocomplete div from wrapping
              around underneath the floated LABEL.

              I tried it out on IE6/WIN, OPERA9/WIN, FF1.5,2/WIN and works
              across all of them.

              NOTE: The 'P' tags you have do not seem to be interpreted correctly
              with the XHTML doctype and Firefox ends up wrapping only the LABEL
              instead of the LABEL and the AutoComplete DIV. Luckily this still
              works for what you're trying to do, but still, something to keep in
              mind.


              Assyriannation,

              If you could post your code or a link and we can see if it's a
              similar problem.

              Regards,
              Satyen

              --- In ydn-javascript@yahoogroups.com, "assyriannation"
              <neo.assyrian@...> wrote:
              >
              > I'm having the same problem in my site too. Its working fine on
              the
              > IE, but not FireFox 2.0.
              > I havent touched the code, but also not sure since when the
              problem
              > started.
              > It used to work fine before.
              >
              > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
              > wrote:
              > >
              > > Hi Keith,
              > >
              > > When I went to your site, I did see the problem. However, in
              order
              > to
              > > troubleshoot, I need to have a reproducible case locally. Since
              I'm
              > > not able to reproduce using the latest builds of the library,
              > > unfortunately I can't offer much advice on how to fix your
              problem.
              > >
              > > Regards,
              > > Jenny
              > >
              > >
              > >
              > >
              > >
              > > --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@>
              > > wrote:
              > > >
              > > > Hi Jenny, thanks for responding.
              > > >
              > > > The version I am using is: 0.11.4
              > > >
              > > > Quick question:
              > > > When you went to the following link,
              > > > http://www.keithgill.info/auto-complete_ignorance/restore-
              > what.html
              > > > and typed "T" in the input field, were you able to see the
              > problem?
              > > > If not, what browser, version and OS are you running?
              > > >
              > > > Apart from updating to the latest version, do you have any
              > suggestions
              > > > as to how I can fix this issue?
              > > >
              > > > Thanks for your assistance Jenny.
              > > >
              > > > Sincerely,
              > > > Keith
              > > >
              > > >
              > > >
              > > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
              > wrote:
              > > > >
              > > > > Hi there,
              > > > >
              > > > > I'm not able to reproduce the problem using your code but
              > pointing to
              > > > > the latest YUI builds. Can you confirm which version you are
              > using?
              > > > >
              > > > > Thanks,
              > > > > Jenny
              > > > >
              > > > >
              > > > >
              > > > >
              > > > >
              > > > > --- In ydn-javascript@yahoogroups.com, "mayfindher"
              > <mayfindher@>
              > > > > wrote:
              > > > > >
              > > > > > The Issue is this:
              > > > > > In IE 6 & 7 the auto complete works as it should.
              > > > > > However, in Firefox 1.5, when data is entered into the
              imput
              > field
              > > > found
              > > > > > within a fieldset, the shadow and container do NOT drop
              below
              > the
              > > > imput
              > > > > > field, but instead appear below the label.
              > > > > >
              > > > > > Here's the link to see for yourself
              > > > > >
              > > <http://www.keithgill.info/auto-complete_ignorance/restore-
              > what.html>
              > > > > >
              > > > > > Notable:
              > > > > > The YUI CSS exists at block level, plus I am calling
              several
              > > external
              > > > > > styles. Even when removing these external styles, and
              using
              > the
              > > exact
              > > > > > YUI code, problems exist.
              > > > > >
              > > > > > Thanks in advance for your help.
              > > > > >
              > > > >
              > > >
              > >
              >
            • assyriannation
              Here is the link to my site http://www.qeenatha.com Thanks ... ... ... are
              Message 6 of 11 , Dec 15, 2006
              • 0 Attachment
                Here is the link to my site
                http://www.qeenatha.com

                Thanks

                --- In ydn-javascript@yahoogroups.com, "sdezzi" <sdezzi@...> wrote:
                >
                > Keith,
                >
                > In your case, looking at the CSS on the linked page you provided,
                > seems like it's the 'float:left' you have on the LABEL tag which is
                > causing the DIV with id="hostAutocompleteContainer" to wrap around
                > under the label (same for the "directoryAutocompleteContainer")
                >
                > Applying a 'float:left' to the #hostAutocompleteExternalDiv rule
                > should probably fix it. This float gets cleared on the next P, so
                > everything should look still look OK for the next LABEL.
                >
                > Or, you could apply a 'margin-left:120px' to the same rule, since
                > you have a fixed 120px label.
                >
                > Either of these should stop the autocomplete div from wrapping
                > around underneath the floated LABEL.
                >
                > I tried it out on IE6/WIN, OPERA9/WIN, FF1.5,2/WIN and works
                > across all of them.
                >
                > NOTE: The 'P' tags you have do not seem to be interpreted correctly
                > with the XHTML doctype and Firefox ends up wrapping only the LABEL
                > instead of the LABEL and the AutoComplete DIV. Luckily this still
                > works for what you're trying to do, but still, something to keep in
                > mind.
                >
                >
                > Assyriannation,
                >
                > If you could post your code or a link and we can see if it's a
                > similar problem.
                >
                > Regards,
                > Satyen
                >
                > --- In ydn-javascript@yahoogroups.com, "assyriannation"
                > <neo.assyrian@> wrote:
                > >
                > > I'm having the same problem in my site too. Its working fine on
                > the
                > > IE, but not FireFox 2.0.
                > > I havent touched the code, but also not sure since when the
                > problem
                > > started.
                > > It used to work fine before.
                > >
                > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
                > > wrote:
                > > >
                > > > Hi Keith,
                > > >
                > > > When I went to your site, I did see the problem. However, in
                > order
                > > to
                > > > troubleshoot, I need to have a reproducible case locally. Since
                > I'm
                > > > not able to reproduce using the latest builds of the library,
                > > > unfortunately I can't offer much advice on how to fix your
                > problem.
                > > >
                > > > Regards,
                > > > Jenny
                > > >
                > > >
                > > >
                > > >
                > > >
                > > > --- In ydn-javascript@yahoogroups.com, "mayfindher"
                <mayfindher@>
                > > > wrote:
                > > > >
                > > > > Hi Jenny, thanks for responding.
                > > > >
                > > > > The version I am using is: 0.11.4
                > > > >
                > > > > Quick question:
                > > > > When you went to the following link,
                > > > > http://www.keithgill.info/auto-complete_ignorance/restore-
                > > what.html
                > > > > and typed "T" in the input field, were you able to see the
                > > problem?
                > > > > If not, what browser, version and OS are you running?
                > > > >
                > > > > Apart from updating to the latest version, do you have any
                > > suggestions
                > > > > as to how I can fix this issue?
                > > > >
                > > > > Thanks for your assistance Jenny.
                > > > >
                > > > > Sincerely,
                > > > > Keith
                > > > >
                > > > >
                > > > >
                > > > > --- In ydn-javascript@yahoogroups.com, "jennykhan"
                <jennyhan@>
                > > wrote:
                > > > > >
                > > > > > Hi there,
                > > > > >
                > > > > > I'm not able to reproduce the problem using your code but
                > > pointing to
                > > > > > the latest YUI builds. Can you confirm which version you
                are
                > > using?
                > > > > >
                > > > > > Thanks,
                > > > > > Jenny
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > >
                > > > > > --- In ydn-javascript@yahoogroups.com, "mayfindher"
                > > <mayfindher@>
                > > > > > wrote:
                > > > > > >
                > > > > > > The Issue is this:
                > > > > > > In IE 6 & 7 the auto complete works as it should.
                > > > > > > However, in Firefox 1.5, when data is entered into the
                > imput
                > > field
                > > > > found
                > > > > > > within a fieldset, the shadow and container do NOT drop
                > below
                > > the
                > > > > imput
                > > > > > > field, but instead appear below the label.
                > > > > > >
                > > > > > > Here's the link to see for yourself
                > > > > > >
                > > > <http://www.keithgill.info/auto-complete_ignorance/restore-
                > > what.html>
                > > > > > >
                > > > > > > Notable:
                > > > > > > The YUI CSS exists at block level, plus I am calling
                > several
                > > > external
                > > > > > > styles. Even when removing these external styles, and
                > using
                > > the
                > > > exact
                > > > > > > YUI code, problems exist.
                > > > > > >
                > > > > > > Thanks in advance for your help.
                > > > > > >
                > > > > >
                > > > >
                > > >
                > >
                >
              • Satyen Desai
                Hey Assyriannation, Try changing var myAutoComp = new YAHOO.widget.AutoComplete( query , container2 , myDataSource3); to var myAutoComp = new
                Message 7 of 11 , Dec 15, 2006
                • 0 Attachment
                  Hey Assyriannation,

                  Try changing

                      var myAutoComp = new YAHOO.widget.AutoComplete("query","container2", myDataSource3);

                  to

                      var myAutoComp = new YAHOO.widget.AutoComplete("myInput","container2", myDataSource3);

                  Your AutoComplete's INPUT markup is

                      <input name="query" id="myInput" ....>

                  And the AutoComplete constructor expects the ID as the first argument as opposed to the NAME


                  It probably works in IE with the name, because eventually document.getElementById is used to find the element, which in IE looks up elements by NAME as well as ID

                  Also, maybe a little more robust if you wait for the page to load or the AutoComplete INPUT/DIV elements to be available before you  attempt  to create the AutoComplete control instead of running the code inline, just to make sure they are part of the DOM [ see http://developer.yahoo.com/yui/event/#onavailable  for info on the onAvailable event ].


                • mayfindher
                  Thanks Satyen. The only thing I had to do was replace the position:relative tag with a float:left tag within the #hostAutocompleteExternalDiv and
                  Message 8 of 11 , Dec 18, 2006
                  • 0 Attachment
                    Thanks Satyen.

                    The only thing I had to do was replace the position:relative tag with
                    a float:left tag within the #hostAutocompleteExternalDiv and
                    #directoryAutocompleteExternalDiv.

                    As for your comment:
                    > NOTE: The 'P' tags you have do not seem to be interpreted correctly
                    > with the XHTML doctype and Firefox ends up wrapping only the LABEL
                    > instead of the LABEL and the AutoComplete DIV. Luckily this still
                    > works for what you're trying to do, but still, something to keep in
                    > mind.
                    Is this a known bug and can you direct me to any documentation
                    regarding this issue?

                    Thank you,
                    Keith


                    --- In ydn-javascript@yahoogroups.com, "sdezzi" <sdezzi@...> wrote:
                    >
                    > Keith,
                    >
                    > In your case, looking at the CSS on the linked page you provided,
                    > seems like it's the 'float:left' you have on the LABEL tag which is
                    > causing the DIV with id="hostAutocompleteContainer" to wrap around
                    > under the label (same for the "directoryAutocompleteContainer")
                    >
                    > Applying a 'float:left' to the #hostAutocompleteExternalDiv rule
                    > should probably fix it. This float gets cleared on the next P, so
                    > everything should look still look OK for the next LABEL.
                    >
                    > Or, you could apply a 'margin-left:120px' to the same rule, since
                    > you have a fixed 120px label.
                    >
                    > Either of these should stop the autocomplete div from wrapping
                    > around underneath the floated LABEL.
                    >
                    > I tried it out on IE6/WIN, OPERA9/WIN, FF1.5,2/WIN and works
                    > across all of them.
                    >
                    > NOTE: The 'P' tags you have do not seem to be interpreted correctly
                    > with the XHTML doctype and Firefox ends up wrapping only the LABEL
                    > instead of the LABEL and the AutoComplete DIV. Luckily this still
                    > works for what you're trying to do, but still, something to keep in
                    > mind.
                    >
                    >
                    > Assyriannation,
                    >
                    > If you could post your code or a link and we can see if it's a
                    > similar problem.
                    >
                    > Regards,
                    > Satyen
                    >
                    > --- In ydn-javascript@yahoogroups.com, "assyriannation"
                    > <neo.assyrian@> wrote:
                    > >
                    > > I'm having the same problem in my site too. Its working fine on
                    > the
                    > > IE, but not FireFox 2.0.
                    > > I havent touched the code, but also not sure since when the
                    > problem
                    > > started.
                    > > It used to work fine before.
                    > >
                    > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
                    > > wrote:
                    > > >
                    > > > Hi Keith,
                    > > >
                    > > > When I went to your site, I did see the problem. However, in
                    > order
                    > > to
                    > > > troubleshoot, I need to have a reproducible case locally. Since
                    > I'm
                    > > > not able to reproduce using the latest builds of the library,
                    > > > unfortunately I can't offer much advice on how to fix your
                    > problem.
                    > > >
                    > > > Regards,
                    > > > Jenny
                    > > >
                    > > >
                    > > >
                    > > >
                    > > >
                    > > > --- In ydn-javascript@yahoogroups.com, "mayfindher" <mayfindher@>
                    > > > wrote:
                    > > > >
                    > > > > Hi Jenny, thanks for responding.
                    > > > >
                    > > > > The version I am using is: 0.11.4
                    > > > >
                    > > > > Quick question:
                    > > > > When you went to the following link,
                    > > > > http://www.keithgill.info/auto-complete_ignorance/restore-
                    > > what.html
                    > > > > and typed "T" in the input field, were you able to see the
                    > > problem?
                    > > > > If not, what browser, version and OS are you running?
                    > > > >
                    > > > > Apart from updating to the latest version, do you have any
                    > > suggestions
                    > > > > as to how I can fix this issue?
                    > > > >
                    > > > > Thanks for your assistance Jenny.
                    > > > >
                    > > > > Sincerely,
                    > > > > Keith
                    > > > >
                    > > > >
                    > > > >
                    > > > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@>
                    > > wrote:
                    > > > > >
                    > > > > > Hi there,
                    > > > > >
                    > > > > > I'm not able to reproduce the problem using your code but
                    > > pointing to
                    > > > > > the latest YUI builds. Can you confirm which version you are
                    > > using?
                    > > > > >
                    > > > > > Thanks,
                    > > > > > Jenny
                    > > > > >
                    > > > > >
                    > > > > >
                    > > > > >
                    > > > > >
                    > > > > > --- In ydn-javascript@yahoogroups.com, "mayfindher"
                    > > <mayfindher@>
                    > > > > > wrote:
                    > > > > > >
                    > > > > > > The Issue is this:
                    > > > > > > In IE 6 & 7 the auto complete works as it should.
                    > > > > > > However, in Firefox 1.5, when data is entered into the
                    > imput
                    > > field
                    > > > > found
                    > > > > > > within a fieldset, the shadow and container do NOT drop
                    > below
                    > > the
                    > > > > imput
                    > > > > > > field, but instead appear below the label.
                    > > > > > >
                    > > > > > > Here's the link to see for yourself
                    > > > > > >
                    > > > <http://www.keithgill.info/auto-complete_ignorance/restore-
                    > > what.html>
                    > > > > > >
                    > > > > > > Notable:
                    > > > > > > The YUI CSS exists at block level, plus I am calling
                    > several
                    > > > external
                    > > > > > > styles. Even when removing these external styles, and
                    > using
                    > > the
                    > > > exact
                    > > > > > > YUI code, problems exist.
                    > > > > > >
                    > > > > > > Thanks in advance for your help.
                    > > > > > >
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                  • Satyen Desai
                    ... Hey Keith, It s probably because, as per spec, the markup you have is invalid. The P tag is only allowed to contain Inline elements.
                    Message 9 of 11 , Dec 18, 2006
                    • 0 Attachment

                      > Is this a known bug and can you direct me to any documentation
                      > regarding this issue?
                      >

                      Hey Keith,

                      It's probably because, as per spec, the markup you have is invalid. The P tag is only allowed to contain Inline elements.

                      http://www.w3.org/TR/xhtml1/dtds.html#dtdentry_xhtml1-strict.dtd_p

                      Hence, the browser decides to leave the LABEL (an inline elem) inside the P because it's valid. The DIV (a block elem) gets moved out, because it is not.  Same probably applies to HTML but haven't checked the various DTDs.

                      Hope that helps.

                      Satyen

                    • assyriannation
                      Thanks that did solve the problem and thanks for your little note. :) Cheers ... ( query , container2 , ... argument as ... looks ... or the ... attempt to
                      Message 10 of 11 , Dec 18, 2006
                      • 0 Attachment
                        Thanks that did solve the problem
                        and thanks for your little note. :)

                        Cheers
                        --- In ydn-javascript@yahoogroups.com, "Satyen Desai" <sdezzi@...>
                        wrote:
                        >
                        > Hey Assyriannation,
                        >
                        > Try changing
                        >
                        > var myAutoComp = new YAHOO.widget.AutoComplete
                        ("query","container2",
                        > myDataSource3);
                        >
                        > to
                        >
                        > var myAutoComp = new
                        > YAHOO.widget.AutoComplete("myInput","container2", myDataSource3);
                        >
                        > Your AutoComplete's INPUT markup is
                        >
                        > <input name="query" id="myInput" ....>
                        >
                        > And the AutoComplete constructor expects the ID as the first
                        argument as
                        > opposed to the NAME
                        >
                        >
                        > It probably works in IE with the name, because eventually
                        > document.getElementById is used to find the element, which in IE
                        looks
                        > up elements by NAME as well as ID
                        >
                        > Also, maybe a little more robust if you wait for the page to load
                        or the
                        > AutoComplete INPUT/DIV elements to be available before you
                        attempt to
                        > create the AutoComplete control instead of running the code inline,
                        just
                        > to make sure they are part of the DOM [ see
                        > http://developer.yahoo.com/yui/event/#onavailable
                        > <http://developer.yahoo.com/yui/event/#onavailable> for info on
                        the
                        > onAvailable event ].
                        >
                      Your message has been successfully submitted and would be delivered to recipients shortly.