Loading ...
Sorry, an error occurred while loading the content.

IE Window onLoad Event -> strange bug

Expand Messages
  • Alexx Alexx
    I figured out very strange behaviour in IE v6.0 while extending our Intranet applaction with YUI lib components. It s difficult to explain, but I ll try. I
    Message 1 of 1 , Oct 27, 2006
    • 0 Attachment
      I figured out very strange behaviour in IE v6.0 while
      extending our Intranet applaction with YUI lib
      components. It's difficult to explain, but I'll try.
      I have ths includes in Head (it's included via ASP):
      <link href='/yui_lib/css/container.css'
      rel='stylesheet' type='text/css'>
      <link href='/yui_lib/css/alexx_auto.css'
      rel='stylesheet' type='text/css'>

      <script src='/yui_lib/js/yui/yahoo-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/dom-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/event-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/container-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/connection-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/animation-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/dragdrop-min.js'
      type='text/javascript'></script>
      <script src='/yui_lib/js/yui/autocomplete-min.js'
      type='text/javascript'></script>
      <% if DEBUG_VER = 1 then %>
      <link href='/yui_lib/css/logger.css' rel='stylesheet'
      type='text/css'>
      <script src='/yui_lib/js/yui/logger-min.js'
      type='text/javascript'></script>
      <% end if %>
      <script src='/yui_lib/js/ajx_street_auto.js'
      type='text/javascript'></script>
      Thea last one is mine.
      Later on I use
      Yu.Event.on(window, "load", PageLoad);
      to Init some objects.
      In this file "ajx_street_auto.js" I use
      YAHOO.util.Event.onAvailable('id_street_name',
      autoCompInit); to init Autocomplete widget.
      So the problem - I get feedback from lots of users,
      that my new interface doesnt work. But Autocomplete -
      DOES! The only difference between other parts of
      Interfaces made by YUI in in event listener for
      initialisation:
      with
      YAHOO.util.Event.onAvailable('some_el', func1) -> it
      works, but via Yu.Event.on(window, "load", PageLoad)
      -> it doesnt work some times.

      What can be the purpose of this strange behaviour of
      IE?
      In adddition to this, I couldnt reproduce this bug on
      MY own machine. Perhaps because of I have 1GB Ram but
      users usually only 256. It's on Win2000 Pro + IE6 +
      SP1 + patches.

      PS: Once more little questiom - do you know whether
      it's possible to hide INSET and OUTSET BORDERs for
      <iframe>. I tried different styles: border: none;
      border: 1px solid black; But the border is still the
      same (like inset and outset borders in table).

      Thanks in advance!



      ----------------
      Best regards,
      Alexander

      __________________________________________________
      Do You Yahoo!?
      Tired of spam? Yahoo! Mail has the best spam protection around
      http://mail.yahoo.com
    Your message has been successfully submitted and would be delivered to recipients shortly.