Loading ...
Sorry, an error occurred while loading the content.

Multi-tiered menu bug?

Expand Messages
  • wmhh
    Consider the following codes:
    Message 1 of 3 , Sep 28, 2006
    • 0 Attachment
      Consider the following codes:

      <div id="mainmenu" class="yuimenu">
      <div class="bd">
      <ul class="first-of-type">
      <li class="yuimenuitem"><a href="./">{FUNC_INDEX}</a></li>
      <li class="yuimenuitem">{FUNC_DEMO}
      <div id="demo" class="yuimenu">
      <div class="bd">
      <ul class="first-of-type">
      <li class="yuimenuitem"><a href="testingForm.jsp">
      {FUNC_DEMO_FORM}</a></li>
      <li class="yuimenuitem"><a href="testingErrorCode.jsp">
      {FUNC_DEMO_ERRDEF}</a></li>
      </ul>
      </div>
      </div>
      </li>
      </ul>
      </div>
      </div>

      I found that if I don't give a link for {FUNC_DEMO}, I also can't
      link to {FUNC_DEMO_ERRDEF}. The link of {FUNC_DEMO_ERRDEF} seem don't
      work. Otherwise, if i have a link for {FUNC_DEMO}, then
      {FUNC_DEMO_ERRDEF} also works fine. Is that a bug? Or there's
      something I miss?
    • Todd Kloots
      Is the problem that the browser isn t following the URLs of menu items in submenus? If so, that was a bug in a previous version of menu and has since been
      Message 2 of 3 , Sep 28, 2006
      • 0 Attachment
        Is the problem that the browser isn't following the URLs of menu items in submenus? If so, that was a bug in a previous version of menu and has since been fixed. What version of the Menu API are you using?

        ----- Original Message ----
        From: wmhh <wmhh@...>
        To: ydn-javascript@yahoogroups.com
        Sent: Thursday, September 28, 2006 7:54:24 AM
        Subject: [ydn-javascript] Multi-tiered menu bug?


        Consider the following codes:

        <div id="mainmenu" class="yuimenu">
        <div class="bd">
        <ul class="first-of-type">
        <li class="yuimenuitem"><a href="./">{FUNC_INDEX}</a></li>
        <li class="yuimenuitem">{FUNC_DEMO}
        <div id="demo" class="yuimenu">
        <div class="bd">
        <ul class="first-of-type">
        <li class="yuimenuitem"><a href="testingForm.jsp">
        {FUNC_DEMO_FORM}</a></li>
        <li class="yuimenuitem"><a href="testingErrorCode.jsp">
        {FUNC_DEMO_ERRDEF}</a></li>
        </ul>
        </div>
        </div>
        </li>
        </ul>
        </div>
        </div>

        I found that if I don't give a link for {FUNC_DEMO}, I also can't
        link to {FUNC_DEMO_ERRDEF}. The link of {FUNC_DEMO_ERRDEF} seem don't
        work. Otherwise, if i have a link for {FUNC_DEMO}, then
        {FUNC_DEMO_ERRDEF} also works fine. Is that a bug? Or there's
        something I miss?








        Yahoo! Groups Links
      • wmhh
        I was using YUI v0.11.0 from Aptana. After I upgrade the APIs to v0.11.4, the submenu works fine now. Thank you very much. ... items in submenus? If so, that
        Message 3 of 3 , Sep 28, 2006
        • 0 Attachment
          I was using YUI v0.11.0 from Aptana. After I upgrade the APIs to
          v0.11.4, the submenu works fine now. Thank you very much.

          --- In ydn-javascript@yahoogroups.com, Todd Kloots <kloots@...> wrote:
          >
          > Is the problem that the browser isn't following the URLs of menu
          items in submenus? If so, that was a bug in a previous version of
          menu and has since been fixed. What version of the Menu API are you
          using?
          >
          > ----- Original Message ----
          > From: wmhh <wmhh@...>
          > To: ydn-javascript@yahoogroups.com
          > Sent: Thursday, September 28, 2006 7:54:24 AM
          > Subject: [ydn-javascript] Multi-tiered menu bug?
          >
          >
          > Consider the following codes:
          >
          > <div id="mainmenu" class="yuimenu">
          > <div class="bd">
          > <ul class="first-of-type">
          > <li class="yuimenuitem"><a href="./">{FUNC_INDEX}</a></li>
          > <li class="yuimenuitem">{FUNC_DEMO}
          > <div id="demo" class="yuimenu">
          > <div class="bd">
          > <ul class="first-of-type">
          > <li class="yuimenuitem"><a href="testingForm.jsp">
          > {FUNC_DEMO_FORM}</a></li>
          > <li class="yuimenuitem"><a href="testingErrorCode.jsp">
          > {FUNC_DEMO_ERRDEF}</a></li>
          > </ul>
          > </div>
          > </div>
          > </li>
          > </ul>
          > </div>
          > </div>
          >
          > I found that if I don't give a link for {FUNC_DEMO}, I also can't
          > link to {FUNC_DEMO_ERRDEF}. The link of {FUNC_DEMO_ERRDEF} seem
          don't
          > work. Otherwise, if i have a link for {FUNC_DEMO}, then
          > {FUNC_DEMO_ERRDEF} also works fine. Is that a bug? Or there's
          > something I miss?
          >
          >
          >
          >
          >
          >
          >
          >
          > Yahoo! Groups Links
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.