Loading ...
Sorry, an error occurred while loading the content.

Submenus dissapearing in IE7

Expand Messages
  • Carlos Vadillo
    I have seen many threads on this topic, and I have a new insight on it. The zoom: 1 works fine if you are in IE7 quirks mode. But if you try to use html4 or
    Message 1 of 2 , Oct 6, 2009
    • 0 Attachment
      I have seen many threads on this topic, and I have a new insight on it. The zoom: 1 works fine if you are in IE7 quirks mode. But if you try to use html4 or xhtml and add a line in your page like

      <?xml version="1.0" encoding="ISO-8859-1" ?>
      <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd">

      Or any or many other variations then the problem appears again.

      Does anyone found a solution for this problem. MenuBar works fine in IE6, Firefox and others but it is very annoying in IE7 and certainly our product cannot go on production with this problem.
    • Todd Kloots
      Carlos - Todd Kloots here, author of YUI Menu. My understanding was that this was only an issue with IE 7 when in Quirks Mode. I have never seen it reported
      Message 2 of 2 , Oct 7, 2009
      • 0 Attachment
        Carlos -

        Todd Kloots here, author of YUI Menu. My understanding was that this
        was only an issue with IE 7 when in Quirks Mode. I have never seen it
        reported as being an issue when IE 7 is in strict/standards mode.
        Hence my solution in the Known Issues section of the YUI Menu landing
        page:

        http://developer.yahoo.com/yui/menu/#knownissues

        If you have a URL that reproduces this issue in IE 7 in standards
        mode, then can you forward it on to me so that I can take a look at
        the issue for you?

        - Todd


        On Oct 6, 2009, at 12:30 PM, Carlos Vadillo wrote:

        > I have seen many threads on this topic, and I have a new insight on
        > it. The zoom: 1 works fine if you are in IE7 quirks mode. But if you
        > try to use html4 or xhtml and add a line in your page like
        >
        > <?xml version="1.0" encoding="ISO-8859-1" ?>
        > <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Frameset//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-frameset.dtd
        > ">
        >
        > Or any or many other variations then the problem appears again.
        >
        > Does anyone found a solution for this problem. MenuBar works fine in
        > IE6, Firefox and others but it is very annoying in IE7 and certainly
        > our product cannot go on production with this problem.
        >
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.