Loading ...
Sorry, an error occurred while loading the content.

tooltip x coordinate does not seem to be acknowleged

Expand Messages
  • shantek81
    i am using 2.7, my tooltip (the message is fine) is displaying on the far left of the page each time i select an icon within my datatable. even when i hardcode
    Message 1 of 3 , Sep 30, 2009
    • 0 Attachment
      i am using 2.7, my tooltip (the message is fine) is displaying on the far left of the page each time i select an icon within my datatable. even when i hardcode an x value it still displays on the left side. the y coordinate appears to be fine. it lines up with the positioning of the icon but just on the left side of the page. any suggestions? or what am i doing wrong?

      i followed this example exactly minus the "timer code":
      http://www.satyam.com.ar/yui/2.6.0/tooltips.html

      problem seems to be within:
      var xy = [parseInt(oArgs.event.clientX,10) + 10 ,parseInt(oArgs.event.clientY,10) + 10 ];
      tt.cfg.setProperty('xy',xy);

      i do get what may be the correct positioning values when i just display the values of xy

      have this same problem even when i use the example:
      http://developer.yahoo.com/yui/examples/container/tooltip.html
    • shantek81
      NOTE: tt.cfg.getProperty(xy) returns x with a value of 6 and the y coordinate with the correct value based on positioning. seems the problem may be in the
      Message 2 of 3 , Oct 1, 2009
      • 0 Attachment
        NOTE: tt.cfg.getProperty(xy) returns x with a value of 6 and the y coordinate with the correct value based on positioning. seems the problem may be in the cfg.setProperty since i do get the correct positioning values when i just display the values of xy.
        ?????

        --- In ydn-javascript@yahoogroups.com, "shantek81" <shantek81@...> wrote:
        >
        > i am using 2.7, my tooltip (the message is fine) is displaying on the far left of the page each time i select an icon within my datatable. even when i hardcode an x value it still displays on the left side. the y coordinate appears to be fine. it lines up with the positioning of the icon but just on the left side of the page. any suggestions? or what am i doing wrong?
        >
        > i followed this example exactly minus the "timer code":
        > http://www.satyam.com.ar/yui/2.6.0/tooltips.html
        >
        > problem seems to be within:
        > var xy = [parseInt(oArgs.event.clientX,10) + 10 ,parseInt(oArgs.event.clientY,10) + 10 ];
        > tt.cfg.setProperty('xy',xy);
        >
        > i do get what may be the correct positioning values when i just display the values of xy
        >
        > have this same problem even when i use the example:
        > http://developer.yahoo.com/yui/examples/container/tooltip.html
        >
      • shantek81
        NOTE: tt.cfg.getProperty(xy) returns x with a value of 6 and the y coordinate with the correct value based on positioning. seems the problem may be in the
        Message 3 of 3 , Oct 1, 2009
        • 0 Attachment
          NOTE: tt.cfg.getProperty(xy) returns x with a value of 6 and the y coordinate with the correct value based on positioning. seems the problem may be in the cfg.setProperty since i do get the correct positioning values when i just display the values of xy.
          ?????

          --- In ydn-javascript@yahoogroups.com, "shantek81" <shantek81@...> wrote:
          >
          > i am using 2.7, my tooltip (the message is fine) is displaying on the far left of the page each time i select an icon within my datatable. even when i hardcode an x value it still displays on the left side. the y coordinate appears to be fine. it lines up with the positioning of the icon but just on the left side of the page. any suggestions? or what am i doing wrong?
          >
          > i followed this example exactly minus the "timer code":
          > http://www.satyam.com.ar/yui/2.6.0/tooltips.html
          >
          > problem seems to be within:
          > var xy = [parseInt(oArgs.event.clientX,10) + 10 ,parseInt(oArgs.event.clientY,10) + 10 ];
          > tt.cfg.setProperty('xy',xy);
          >
          > i do get what may be the correct positioning values when i just display the values of xy
          >
          > have this same problem even when i use the example:
          > http://developer.yahoo.com/yui/examples/container/tooltip.html
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.