Loading ...
Sorry, an error occurred while loading the content.

RE: [ydn-javascript] Safari Problems with Carousel/Button/Menu/Pagination Implementation

Expand Messages
  • Satyen Desai
    Hey Craig, Try a few things: a). Move your style block into HEAD. b). Assign a width to the li or img elements (they end up being 100px, so try assigning that
    Message 1 of 2 , May 1, 2009
    View Source
    • 0 Attachment
      Hey Craig,

      Try a few things:

      a). Move your style block into HEAD.
      b). Assign a width to the li or img elements (they end up being 100px, so try assigning that width before you construct the carousel).

      It appears that the carousel cannot determine the width of the carousel items while the images are loading, since they have no pre-defined width - so the width of the carousel clipping region ends up being too small (this also happens on FF3 if you clear cache)

      In messing around with a local copy of your page, that fixed the problem for me (I also changed the doctype to a strict doctype)

      Hope that helps,
      Satyen

      ________________________________________
      From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Craig Anderson
      Sent: Thursday, April 30, 2009 9:43 AM
      To: ydn-javascript@yahoogroups.com
      Subject: [ydn-javascript] Safari Problems with Carousel/Button/Menu/Pagination Implementation




      Hello All! I just completed quite the photo gallery implementation that makes use of the Carousel, Button, Menu and Pagination components. I began with the Carousel/Pagination example from the YUI site and modified it from there to work a bit differently.


      Incredibly, IE really didn't give me many problems and I was able to go through the development process relatively pain free - until I test Safari. Safari isn't showing any of the five thumbnails, it only shows about 20% of the first one for some reason. All of the other functionality seems to work fine.

      You can view it here:

      http://www.gibsonhomeimprovement.com/portfolio.idea.html

      Anyone have any ideas as to what the problem might be?
    Your message has been successfully submitted and would be delivered to recipients shortly.