Loading ...
Sorry, an error occurred while loading the content.

4-level deep div and yahoo tab widget

Expand Messages
  • mrokner
    I m not sure how to explain this problem, but I ll do my best. I m using the CodeCharge Studio IDE for development. It has a built-in wizard for including
    Message 1 of 1 , Apr 30, 2009
    • 0 Attachment
      I'm not sure how to explain this problem, but I'll do my best. I'm using the CodeCharge Studio IDE for development. It has a built-in wizard for including yahoo tabs. It just so happens I'm using this on one of the pages. Now on this same page, I load a "modal" div. This "modal" div is actually just a div that exists as an overlay on top of the page; the page itself is darkened to give the appearance that it's dimmed out and the active window is the "modal" div itself.
      This "modal" div is called "UniversalModalPanel".

      I needed to create tabs inside this "modal" div. So, instead of using codecharge to build it, I did it manually by following how codecharge sets it up, since it's just client-side code. The tabbed interface has, at most, 3 divs. The 1st div is called "Modal1", which is contained inside "UniversalModalPanel". The second div is called "Tab1", which is the name of the tab and contained inside "Modal1". And, finally, the third div is called "Tab1Info", which is inside the "Tab1" div. So, in summary, at most, I can go 4 levels deep.

      After that long explanation, here's the problem:

      The "modal" div (it functions as a window so I'll call it window) loads fine! It loads the tabbed interface quite perfectly, actually. I write out the HTML to be displayed in javascript and then i pass it to "UniversalModalPanel"'s innerHTML object. Works well.

      However, if I try to modify the innerHTML object of "Tab1", I get an error. Why? Well, "Tab1" doesn't exist! Why? I have no idea. It displays correctly and with no problems in the "modal" window. But after the "modal" loads, if I try to access the "Tab1" div, it throws it's hands up. The strange thing is the "Modal1" div can be manipulated. Anything after "Modal1" does not exist, though! So, "Tab1" and "Tab1Info" are not attached to the DOM, I think, but "Modal1" works fine. So, how the heck does the "Modal" window load completely fine, yet trying to manipulate any divs that start at 3-level deep or below, after the "Modal" window has been loaded!, doesn't work!!

      I tried using createElement to create the "Tab1" div, and that didn't do anything. I'm using IE8 Beta, by the way. I would REALLY appreciate a solution, because I am absolutely stumped!!!!

      Thank you!
    Your message has been successfully submitted and would be delivered to recipients shortly.