Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Problem with using DataSource

Expand Messages
  • Satyam
    I would check the dependencies, is Event loaded? Is it loaded just once? Are they loaded in the right order?
    Message 1 of 4 , Apr 30, 2009
    • 0 Attachment
      I would check the dependencies, is Event loaded? Is it loaded just
      once? Are they loaded in the right order?

      jr_searles escribió:
      > I am trying to use the XHRDataSource with an AutoComplete widget. The DataSource is failing when instantiating the object. I stepped through the code and it is failing during the first call to create an event... this.createEvent("cacheRequestEvent"); (line 77 in the non-minimized code). I see that the DataSource is augmented by EventProvider, however the "createEvent" function is not available and causing the error. Any suggestions?
      >
      > Thanks,
      >
      > Josh
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      > ------------------------------------------------------------------------
      >
      >
      > No virus found in this incoming message.
      > Checked by AVG - www.avg.com
      > Version: 8.5.287 / Virus Database: 270.12.8/2086 - Release Date: 04/29/09 06:37:00
      >
      >
    • jr_searles
      Yes, that s what i initially thought so i verified that. All the dependencies are loaded in the same order as they are listed in the user guide. I am using the
      Message 2 of 4 , Apr 30, 2009
      • 0 Attachment
        Yes, that's what i initially thought so i verified that. All the dependencies are loaded in the same order as they are listed in the user guide. I am using the non-minimized versions for development.

        --- In ydn-javascript@yahoogroups.com, Satyam <satyam@...> wrote:
        >
        > I would check the dependencies, is Event loaded? Is it loaded just
        > once? Are they loaded in the right order?
        >
        > jr_searles escribió:
        > > I am trying to use the XHRDataSource with an AutoComplete widget. The DataSource is failing when instantiating the object. I stepped through the code and it is failing during the first call to create an event... this.createEvent("cacheRequestEvent"); (line 77 in the non-minimized code). I see that the DataSource is augmented by EventProvider, however the "createEvent" function is not available and causing the error. Any suggestions?
        > >
        > > Thanks,
        > >
        > > Josh
        > >
        > >
        > >
        > > ------------------------------------
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > > ------------------------------------------------------------------------
        > >
        > >
        > > No virus found in this incoming message.
        > > Checked by AVG - www.avg.com
        > > Version: 8.5.287 / Virus Database: 270.12.8/2086 - Release Date: 04/29/09 06:37:00
        > >
        > >
        >
      • jr_searles
        I figured it out. Thanks for the response. Josh
        Message 3 of 4 , Apr 30, 2009
        • 0 Attachment
          I figured it out. Thanks for the response.

          Josh

          --- In ydn-javascript@yahoogroups.com, Satyam <satyam@...> wrote:
          >
          > I would check the dependencies, is Event loaded? Is it loaded just
          > once? Are they loaded in the right order?
          >
          > jr_searles escribió:
          > > I am trying to use the XHRDataSource with an AutoComplete widget. The DataSource is failing when instantiating the object. I stepped through the code and it is failing during the first call to create an event... this.createEvent("cacheRequestEvent"); (line 77 in the non-minimized code). I see that the DataSource is augmented by EventProvider, however the "createEvent" function is not available and causing the error. Any suggestions?
          > >
          > > Thanks,
          > >
          > > Josh
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > > ------------------------------------------------------------------------
          > >
          > >
          > > No virus found in this incoming message.
          > > Checked by AVG - www.avg.com
          > > Version: 8.5.287 / Virus Database: 270.12.8/2086 - Release Date: 04/29/09 06:37:00
          > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.