Loading ...
Sorry, an error occurred while loading the content.

a href not working with left click on 2.7 Treeview Control

Expand Messages
  • samsouhrada
    I just upgraded to the new treeview control and am having an issue where you cannot left-click to open an href link. When you click on the link it just loads
    Message 1 of 7 , Feb 23, 2009
    • 0 Attachment
      I just upgraded to the new treeview control and am having an issue
      where you cannot left-click to open an href link. When you click on the
      link it just loads the blank "#" link rather than the one that is coded
      in the page. What do I need to do in order to have the left click open
      the link on the tree node?

      Thanks
    • samsouhrada
      Has anyone else had this issue? This occurs across all browsers. ... the ... coded ... open
      Message 2 of 7 , Feb 24, 2009
      • 0 Attachment
        Has anyone else had this issue? This occurs across all browsers.


        --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@...>
        wrote:
        >
        > I just upgraded to the new treeview control and am having an issue
        > where you cannot left-click to open an href link. When you click on
        the
        > link it just loads the blank "#" link rather than the one that is
        coded
        > in the page. What do I need to do in order to have the left click
        open
        > the link on the tree node?
        >
        > Thanks
        >
      • cjavajim
        ... Yup, 2.7.0 busted it. Are you going to file a defect ticket? http://yuilibrary.com/projects/yui2/wiki (You have to log-in to file a ticket)
        Message 3 of 7 , Feb 24, 2009
        • 0 Attachment
          --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@...>
          wrote:
          >
          > Has anyone else had this issue? This occurs across all browsers.
          >
          >
          > --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@>
          > wrote:
          > >
          > > I just upgraded to the new treeview control and am having an issue
          > > where you cannot left-click to open an href link. When you click on
          > the
          > > link it just loads the blank "#" link rather than the one that is
          > coded
          > > in the page. What do I need to do in order to have the left click
          > open
          > > the link on the tree node?
          > >
          > > Thanks
          > >
          >

          Yup, 2.7.0 busted it. Are you going to file a defect ticket?

          http://yuilibrary.com/projects/yui2/wiki (You have to log-in to file a
          ticket)
        • cjavajim
          ... I went ahead on created a new ticket: http://yuilibrary.com/projects/yui2/ticket/2527720
          Message 4 of 7 , Feb 24, 2009
          • 0 Attachment
            --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@...>
            wrote:
            >
            > I just upgraded to the new treeview control and am having an issue
            > where you cannot left-click to open an href link. When you click on the
            > link it just loads the blank "#" link rather than the one that is coded
            > in the page. What do I need to do in order to have the left click open
            > the link on the tree node?
            >
            > Thanks
            >

            I went ahead on created a new ticket:

            http://yuilibrary.com/projects/yui2/ticket/2527720
          • samsouhrada
            Thanks for creating a ticket. I thought something drastic had changed in 2.7 but I suppose not. This is surprising to me because I would think it s part of the
            Message 5 of 7 , Feb 25, 2009
            • 0 Attachment
              Thanks for creating a ticket. I thought something drastic had changed
              in 2.7 but I suppose not. This is surprising to me because I would
              think it's part of the core functionality of the treeview. I will use
              2.6 for now until something is done about this issue. Thanks for the
              information about this defect.



              --- In ydn-javascript@yahoogroups.com, "cjavajim" <cjavajim@...>
              wrote:
              >
              > --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@>
              > wrote:
              > >
              > > I just upgraded to the new treeview control and am having an
              issue
              > > where you cannot left-click to open an href link. When you click
              on the
              > > link it just loads the blank "#" link rather than the one that is
              coded
              > > in the page. What do I need to do in order to have the left click
              open
              > > the link on the tree node?
              > >
              > > Thanks
              > >
              >
              > I went ahead on created a new ticket:
              >
              > http://yuilibrary.com/projects/yui2/ticket/2527720
              >
            • Satyam
              Sorry for the delay in replying, the fix will be available from Github: http://github.com/yui/yui2/tree/master Check the status on the ticket:
              Message 6 of 7 , Mar 4 12:52 PM
              • 0 Attachment
                Sorry for the delay in replying, the fix will be available from Github:

                http://github.com/yui/yui2/tree/master

                Check the status on the ticket:

                http://yuilibrary.com/projects/yui2/ticket/2527720

                to find out when it gets merged into the main trunk. Then, it can be
                downloaded. Such fixes don't become part of either YAHOO or Google's
                CDN so while the rest of the files may be loaded from any of them,
                patched files cannot and they have to be delivered from your own servers.

                Thanks for filing the bug report, it is the best help, so issues don't
                fall through the cracks. Sorry about the bug and the delay in fixing it.

                Satyam



                cjavajim escribió:
                > --- In ydn-javascript@yahoogroups.com, "samsouhrada" <samsouhrada@...>
                > wrote:
                >
                >> I just upgraded to the new treeview control and am having an issue
                >> where you cannot left-click to open an href link. When you click on the
                >> link it just loads the blank "#" link rather than the one that is coded
                >> in the page. What do I need to do in order to have the left click open
                >> the link on the tree node?
                >>
                >> Thanks
                >>
                >>
                >
                > I went ahead on created a new ticket:
                >
                > http://yuilibrary.com/projects/yui2/ticket/2527720
                >
                >
                >
                >
                > ------------------------------------
                >
                > Yahoo! Groups Links
                >
                >
                >
                > ------------------------------------------------------------------------
                >
                >
                > No virus found in this incoming message.
                > Checked by AVG - www.avg.com
                > Version: 8.0.237 / Virus Database: 270.11.3/1970 - Release Date: 02/24/09 13:35:00
                >
                >
              • Satyam
                Keep an eye on ticket: http://yuilibrary.com/projects/yui2/ticket/2527720 Any fix will be reported there. Satyam
                Message 7 of 7 , Mar 4 1:06 PM
                • 0 Attachment
                  Keep an eye on ticket:

                  http://yuilibrary.com/projects/yui2/ticket/2527720

                  Any fix will be reported there.

                  Satyam

                  samsouhrada escribió:
                  > I just upgraded to the new treeview control and am having an issue
                  > where you cannot left-click to open an href link. When you click on the
                  > link it just loads the blank "#" link rather than the one that is coded
                  > in the page. What do I need to do in order to have the left click open
                  > the link on the tree node?
                  >
                  > Thanks
                  >
                  >
                  >
                  > ------------------------------------
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  > ------------------------------------------------------------------------
                  >
                  >
                  > No virus found in this incoming message.
                  > Checked by AVG - www.avg.com
                  > Version: 8.0.237 / Virus Database: 270.11.3/1966 - Release Date: 02/22/09 17:21:00
                  >
                  >
                Your message has been successfully submitted and would be delivered to recipients shortly.