Loading ...
Sorry, an error occurred while loading the content.

Re: "extend" error from yahoo-dom-event.js

Expand Messages
  • kammy_scorpi
    Cool..Thanks for your replies. KJ
    Message 1 of 7 , Dec 30, 2008
    • 0 Attachment
      Cool..Thanks for your replies.

      KJ

      --- In ydn-javascript@yahoogroups.com, Eric Miraglia <miraglia@...> wrote:
      >
      > KJ,
      >
      > YUI modules are used "a la carte," which allows you to use chunks of
      > functionality without including the whole library. Each of the files
      > in your list contains a YUI module -- probably one that you're
      > directly using or one that is a dependency of one of the modules
      > required in your implementation.
      >
      > The best way to calculate your dependencies is to use the
      > Configurator. For YUI 2.x, that tool is here:
      >
      > http://developer.yahoo.com/yui/articles/hosting/#configure
      >
      > The Configurator will return the dependencies you need, in the correct
      > order, and gives you options including combining the scripts into a
      > single file, loading the files from Yahoo or Google CDNs, etc.
      >
      > Regards,
      > Eric
      >
      >
      > On Dec 30, 2008, at 9:31 AM, kammy_scorpi wrote:
      >
      > > Yes, I was looking at that section, but I did not know that the order
      > > mattered !!
      > > Thanks a lot, now it works.
      > >
      > > On the same note, could you(anyone) please tell me what the following
      > > scripts are for:
      > >
      > > 1)build/element/element-beta.js
      > > 2)build/button/button.js
      > > 3)build/container/container.js
      > > 4)build/connection/connection.js
      > >
      > > Thanks again
      > > KJ
      > >
      > > --- In ydn-javascript@yahoogroups.com, "lou_tribal" <lou_tribal@>
      > > wrote:
      > > >
      > > > One javascript file dependency is not loaded correctly.
      > > > You need to check your imported js files to ensure that all the
      > > needed
      > > > dependencies are imported in the correct order.
      > > > Look at http://developer.yahoo.com/yui/treeview/ in the getting
      > > > started section to see the list of needed files.
      > > >
      > > > <
      > > >
      > > > --- In ydn-javascript@yahoogroups.com, "kammy_scorpi"
      > > > <kammy_scorpi@> wrote:
      > > > >
      > > > > newTree = YAHOO.widget.TreeView.getTree(inputTreeID);
      > > > >
      > > > > I keep getting this javascript error at the above line in my code.
      > > > > I am trying to get a handle to the tree with the id represented
      > > by the
      > > > > 'inputTreeID' variable.
      > > > >
      > > > > error: extend failed, please check all dependencies are included
      > > > >
      > > > > What am I doing wrong?
      > > > >
      > > > > Thanks
      > > > > KJ
      > > > >
      > > >
      > >
      > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.