Loading ...
Sorry, an error occurred while loading the content.

Datatable inline cell editor problem with empty string

Expand Messages
  • jellyrhubarb
    I m using the cell editor. It s fab except that whenever the user updates the current value to be , empty string the cell still shows the old value after
    Message 1 of 3 , Nov 26, 2008
    • 0 Attachment
      I'm using the cell editor. It's fab except that whenever the user
      updates the current value to be "", empty string the cell still shows
      the old value after the editor closes.

      If I bring the editor up again the value is gone. So, the record is
      being updated but not the display in the data table row.

      Any help appreciated.

      Thanks,
      Rachel
    • Satyam
      I ve just tried to do that in the simple cell editing example in the YUI docs and have not been able to reproduce it. That example uses both textboxes and
      Message 2 of 3 , Nov 27, 2008
      • 0 Attachment
        I've just tried to do that in the simple cell editing example in the YUI
        docs and have not been able to reproduce it. That example uses both
        textboxes and textareas and neither fails as you describe. Can we have
        a look at the page that is producing that error?

        Satyam


        jellyrhubarb wrote:
        > I'm using the cell editor. It's fab except that whenever the user
        > updates the current value to be "", empty string the cell still shows
        > the old value after the editor closes.
        >
        > If I bring the editor up again the value is gone. So, the record is
        > being updated but not the display in the data table row.
        >
        > Any help appreciated.
        >
        > Thanks,
        > Rachel
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
        > ------------------------------------------------------------------------
        >
        >
        > No virus found in this incoming message.
        > Checked by AVG - http://www.avg.com
        > Version: 8.0.175 / Virus Database: 270.9.10/1813 - Release Date: 26/11/2008 8:53
        >
        >
      • jellyrhubarb
        Thank you for confirming that it does work! I inherited some code from a co-worker who has departed. He swore the issue was a yui bug. Now that I ve
        Message 3 of 3 , Dec 1, 2008
        • 0 Attachment
          Thank you for confirming that it does work! I inherited some code
          from a co-worker who has departed. He swore the issue was a yui
          bug. Now that I've delved deeper into his code I see it was his
          error in some formatting code after update. Sigh. Sorry and
          thanks. Rachel


          --- In ydn-javascript@yahoogroups.com, Satyam <satyam@...> wrote:
          >
          > I've just tried to do that in the simple cell editing example in
          the YUI
          > docs and have not been able to reproduce it. That example uses
          both
          > textboxes and textareas and neither fails as you describe. Can we
          have
          > a look at the page that is producing that error?
          >
          > Satyam
          >
          >
          > jellyrhubarb wrote:
          > > I'm using the cell editor. It's fab except that whenever the
          user
          > > updates the current value to be "", empty string the cell still
          shows
          > > the old value after the editor closes.
          > >
          > > If I bring the editor up again the value is gone. So, the record
          is
          > > being updated but not the display in the data table row.
          > >
          > > Any help appreciated.
          > >
          > > Thanks,
          > > Rachel
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > > ------------------------------------------------------------------
          ------
          > >
          > >
          > > No virus found in this incoming message.
          > > Checked by AVG - http://www.avg.com
          > > Version: 8.0.175 / Virus Database: 270.9.10/1813 - Release Date:
          26/11/2008 8:53
          > >
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.