Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Carousel + 2.4.1

Expand Messages
  • Eric Miraglia
    Wilson, Glad to hear that worked for you. If you want to get something like the utilities.js rollup, but using the version hybrid you re employing, you may try
    Message 1 of 6 , Nov 13, 2008
    • 0 Attachment
      Wilson,

      Glad to hear that worked for you.

      If you want to get something like the utilities.js rollup, but using the version hybrid you're employing, you may try something like:


      You may have to add/remove some utilities if my list doesn't match your usage, but this pattern should work for you and give you a single file coming off of Yahoo's CDN.  (If you want it on your own server, you can of course save the source and host it yourself.)

      Regards,
      Eric


      On Nov 13, 2008, at 12:08 PM, wilsonsheldon wrote:

      Hi everyone,

      Just wanted to confirm as well, that this does appear to work. I lost
      the benefit of the rolled up utilities.js, but was able to insert the
      very nice carousel with minimal fuss.

      Thanks again for your help.

      Wilson

      --- In ydn-javascript@ yahoogroups. com, "wilsonsheldon"
      <wilsonsheldon@ ...> wrote:
      >
      > Thanks guys! I'm doing the integration today and will post my results.
      > 
      > Best,
      > Wilson
      > 
      > --- In ydn-javascript@ yahoogroups. com, "Gopal Venkatesan
      > (गोपाल वेंकटेसन)" <gopal@> wrote:
      > >
      > > On Thu, Nov 13, 2008 at 3:43 AM, wilsonsheldon <wilsonsheldon@ >
      > wrote:
      > > > Hi everyone,
      > > >
      > > > I've got a massive site built using 2.4.1, in which, I'm unable to
      > > > upgrade. However, the client would like the YUI carousel installed.
      > > > I've been working with it, but it doesn't seem to like the 2.4.1
      > > > utilities lib.
      > > >
      > > > Has anyone had any success installing the carousel with an older
      YUI?
      > > >
      > > > The primary error I get is
      > > >
      > > > i.onFocus is not a function.
      > > >
      > > > Just curious if it's simply a matter of pulling a couple
      functions for
      > > > the 2.6.0 utilities.js.
      > > 
      > > Wilson-
      > > 
      > > Like Eric suggested, if possible you can use the 2.6.0 version of
      > > Event utility + YUI Carousel component. The rest can be 2.4.1
      > > dependencies.
      > > 
      > > The problem is that the "onFocus" and "onBlur" events are missing in
      > > the 2.4.1 Event utility, but it is backward compatible with the rest
      > > of the stack.
      > > 
      > > I tested the above (2.4.1 dependencies + 2.6.0 Event + YUI Carousel)
      > > with a few examples and they worked!
      > > HTH.
      > > 
      > > PS. I did not do an extensive testing though.
      > > 
      > > -- 
      > > Gopal Venkatesan
      > > http://g13n. in/
      > > 
      > > Note: if you see question marks (?????) after my name in the From
      > > header, then your mail tool is not Unicode enabled!
      > > You should see my name (Gopal Venkatesan) in Hindi (गोपाल
      > वेंकटेसन)
      > >
      >


    Your message has been successfully submitted and would be delivered to recipients shortly.