Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Grid positioning alerts not displaying correctly in IE 7

Expand Messages
  • Nate Koechley
    Hey Brendan, Here s a test page with 10 alerts interspersed with 10 strings of text. I put them in a plain document without any YUI code, and indeed without
    Message 1 of 3 , Oct 30, 2008
    • 0 Attachment
      Hey Brendan,

      Here's a test page with 10 alerts interspersed with 10 strings of text. I put them in a plain document without any YUI code, and indeed without any other CSS/JS/Markup. You're right, it's inconsistent across browsers. I am not sure why. When you find out, please let us know :)

      In IE6/Firefox/Safari, it alerts once, then paints the string, then alerts again, the paints again, etc.
      In Opera, it alerts 10 times and then paints the 10 strings.
      In IE7, it alerts once, paints once, and then alerts twice, paints twice, alerts twice, paints twice until its finished. 

      Again, I'm not sure why this is happens, but I can't see a correlation between this peculiarity and YUI.

      Here's my test page:

      Thanks,
      Nate


      On Oct 30, 2008, at 9:20 AM, Brendan Vogt wrote:

      Has no one an idea why this is happening?


      2008/10/29 Brendan Vogt <brendan.vogt@...>
      Hi,

      I have the following layout:

      <body>

         <div id="doc4" class="yui-t6">
            <div id="hd"><script type="text/javascript">alert('1');</script>1 Text</div>
            <div id="bd">

               <div id="yui-main">
                  <div class="yui-b"><script type="text/javascript">alert('2');</script>2 Text</div>
               </div>
               <div class="yui-b"><script type="text/javascript">alert('3');</script>3 Text</div>

            </div>
            <div id="ft"><script type="text/javascript">alert('4');</script>4 Text</div>
          </div>

      </body>

      After each alert that text must display.  It works 100% in Firefox, Opera, Avant, but not in IE7.  In IE7 a popup comes up to allow popups.  Then only does my alerts display.  It looks like the following:

      After alert 1 "1 Text" displays
      After alert 2 "2 Text" does not display
      After alert 3 "2 Text" and "3 Text" displays
      After alert 4 "4 Text" displays

      Any ideas why this is happening?

      Thanks
      Brendan


    Your message has been successfully submitted and would be delivered to recipients shortly.