Loading ...
Sorry, an error occurred while loading the content.

Problem with HTMLNode

Expand Messages
  • kevin_conaway
    When I attempt to use an HTMLNode in my Treeview, it doesn t render correctly. Here is the code I use: var html = test
    Message 1 of 2 , Mar 2 12:59 PM
    • 0 Attachment
      When I attempt to use an HTMLNode in my Treeview, it doesn't render
      correctly.

      Here is the code I use:
      var html = '<div id="test"><span>test label</span></div>';
      var myobj = { html: html } ;
      var tmpNode = new YAHOO.widget.HTMLNode(myobj, root, false, true);

      And the output is:
      onmouseover="this.className=YAHOO.widget.TreeView.getNode('subDocTree',1).getHoverStyle()"
      onmouseout="this.className=YAHOO.widget.TreeView.getNode('subDocTree',1).getStyle()"
      test label

      Why is it printing out onmouseover and onmouseout?

      Thanks,

      Kevin
    • Adam Moore
      ... There is problem with HTMLNode when you have the icon turned on. Its been pointed out a couple of times on the list, along with a fix for it that you can
      Message 2 of 2 , Mar 2 1:47 PM
      • 0 Attachment
        On Thu, Mar 02, 2006 at 08:59:20PM -0000, kevin_conaway wrote:
        > When I attempt to use an HTMLNode in my Treeview, it doesn't render
        > correctly.

        There is problem with HTMLNode when you have the icon turned on. Its been
        pointed out a couple of times on the list, along with a fix for it that you
        can use until the next release:

        http://groups.yahoo.com/group/ydn-javascript/message/258


        -Adam
      Your message has been successfully submitted and would be delivered to recipients shortly.