Loading ...
Sorry, an error occurred while loading the content.

RE: [ydn-javascript] Version of app using Bill Scott's Carousel never returns from "addItem()"

Expand Messages
  • Karr, David
    Never mind. I got it working. When I changed my configuration from using a defined function object to an anonymous function that calls the defined function
    Message 1 of 2 , Aug 31, 2008
    • 0 Attachment
      Never mind.  I got it working.  When I changed my configuration from using a defined function object to an anonymous function that calls the defined function object, the called function gets called inside a different context (this) which was invalid.  I changed the anonymous function body to pass "this" into the other function, which now references that parameter instead of "this".  I'm not certain why the context changed because of that, but at least I saw it was happening.
       
      I wouldn't have seen this if I hadn't figured out how to run two separate Firefox profiles at the same time.


      From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Karr, David
      Sent: Saturday, August 30, 2008 5:20 PM
      To: ydn-javascript@yahoogroups.com
      Subject: [ydn-javascript] Version of app using Bill Scott's Carousel never returns from "addItem()"

      YUI 2.5.2, Carousel 0.6.3, FireFox 3.0.1.

      I could use some help with something that may not be YUI-specific. I have a small prototype app using Bill Scott's Carousel component. I got one simple version working, but I tried to refactor it in preparation for some more changes, and now I'm finding that the images never display. Stepping through the code with Firebug, when I step over the "carousel.addItem( )" call, instead of going to the next line of code after it, it seems to "go elsewhere" and none of the images ever display.

      I've loaded both the old and new version to:
      old: http://www.rattiewo rldocomfort. com/carousel/ mdkcarousel. html
      new: http://www.rattiewo rldocomfort. com/carouseltest /mdkcarousel. html

      When you mouseover an image, a fullsize version is supposed to display below the carousel. As the new version doesn't display any of the thumbnails, the mouseover won't work, either.

      If you can tell what's wrong, I'd appreciate even more knowing how I could have detected it, perhaps using Firebug.

      (I posted a question about this to the "ycarousel" group, but the traffic on that list is pretty light.)

    Your message has been successfully submitted and would be delivered to recipients shortly.