Loading ...
Sorry, an error occurred while loading the content.

Re: YUI Uploader with Firefox 3 on Mac and Windows

Expand Messages
  • Allen Rabinovich
    I ll look into verifying this. See if you can circumvent it by loading uploader.swf with a random urlvar, so that there is no caching. Something like:
    Message 1 of 8 , Aug 29, 2008
    • 0 Attachment
      I'll look into verifying this. See if you can circumvent it by loading
      uploader.swf with a random urlvar, so that there is no caching.
      Something like:
      "http://yui.yahooapis.com/2.5.2/build/uploader/assets/Uploader.swf?foo=RANDOM_STRING"




      --- In ydn-javascript@yahoogroups.com, "jiro.tanaka" <jiro.tanaka@...>
      wrote:
      >
      > Hi all,
      >
      > I think I may have found an issue with the Uploader and FF(3.0.1), but
      > I'm not exactly sure what the cause is. Maybe it's related. If you'd
      > like to try and reproduce the error:
      >
      > - If you have firebug installed, open it up and head to the 'Net' tab.
      >
      > 1. go to: http://tivac.com/upload/ (sorry for re-using this url, Pat!)
      >
      > - When the page has finished loading you should see two get requests to
      > http://yui.yahooapis.com/2.5.2/build/uploader/assets/Uploader.swf
      >
      > 2. on the page, click the 'browse' button and select a file.
      >
      > - the file you selected should appear on the page.
      >
      > 3. DON'T upload the file, go to a completely different page.
      >
      > 4. click the back button to return to http://tivac.com/upload/
      >
      > - When you load the page this time, the page will not make any
      > requests to
      > http://yui.yahooapis.com/2.5.2/build/uploader/assets/Uploader.swf
      >
      > 5. click the 'browse' button again and select a file.
      >
      > - the file you selected won't appear on the page.
      >
      > 6. If you clear your cache and refresh the page, you will be able to
      > upload a file again.
      >
      > If I was to make a guess, I would say this might be a problem with the
      > way FF 3.0.1 is loading the cached uploader.swf. At this time, I can't
      > reproduce this bug with IE, only FF 3.0.1. It would be great if
      > someone else is able to reproduce this.
      >
      > Thanks,
      >
      > Jiro
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.