Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Animation Issues since upgrade to 0.11.2

Expand Messages
  • Matt Sweeney
    I ve pinned this down to the fact that you create a new animation object every time the page scrolls. While scrolling, the scroll event is fired continuously,
    Message 1 of 8 , Aug 1, 2006
    • 0 Attachment
      I've pinned this down to the fact that you create a new animation object every time the page scrolls.

      While scrolling, the scroll event is fired continuously, which means you may have quite a number of animation instances attempting to animate the "top" of the same element.  This causes some competition between the animation objects, as they are all feeding slightly different values to the element.

      If you create the element once, and then reuse for subsequent animations (you may need to stop() the animation before calling animate() again), it should fix this issue.


      caigesn wrote:
      Thanks Matt,
      The only difference between the two is the YUI version. Version 0.10
      works fine, version 0.11.2 has the flickering issue.
      --- In ydn-javascript@yahoogroups.com, Matt Sweeney <msweeney@...> wrote:
      Hi Caige,
      I can see the flicker on the left element as you've described.  I'll 
      investigate and see if I can pinpoint the cause.
      Is the only diff between your examples the YUI version?
      caigesn wrote:
      I've increased the size of the center container so there is more area
      to scroll. Again, the animation works fine in Internet Explorer. The
      problem is evident in Firefox, Flock 0.7.1, and older gecko
      versions. If animation.js is replaced with the 0.10 version the
      animation works fine. I'll be uploading a video screen capture of the
      problem soon. Watch the left container after scrolling. I've tested
      this on many systems and the problem does not appear to be isolated.
      --- In ydn-javascript@yahoogroups.com, "Chris Thatcher"
      <thatchman@> wrote:
      I see no flickering (Firefox
      On 7/28/06, caigesn <caigesn@> wrote:
       --- In ydn-javascript@yahoogroups.com
      "vividsilvernl" <yahoo@> wrote:
      No flickering for me on W2K, IE6 (latest updates).
      --- In ydn-javascript@yahoogroups.com
      "caigesn" <caigesn@> wrote:
      I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
      experiencing some strange animation issues. There are basically
      containers on the page. The left and right containers follow
      you as
      you scroll down the page. The center container is intended for
      content. In version 0.10.0 the animation works fine, but in
      0.11.2 the left container flickers after it is done animating.
      If I
      reverse the order in which I initialize the left and right
      then the flickering will happen on the right container. I have
      the example on my site:
      YUI Version 0.10.0
      YUI Version 0.11.2
      I have the source for this example loaded into a syntax
      the center container. The scripts/loadPage.js initializes the
      animation and sets the onscroll events for the containers. If
      knows what might be causing this issue please respond.
      I should have mentioned that it works fine in IE. The flickering only
      happens in Firefox. I am using Firefox
      Yahoo! Groups Links
      Yahoo! Groups Links
      <*> To visit your group on the web, go to:
      <*> To unsubscribe from this group, send an email to:
      <*> Your use of Yahoo! Groups is subject to:

    Your message has been successfully submitted and would be delivered to recipients shortly.