Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Image Not Loading - Overlay

Expand Messages
  • Frank Dietrich
    Raja, hi, ... Did You try to split the URL as I did in my code? As You can see, I also dynamically write the code to the overlay when I move over it. Maybe You
    Message 1 of 11 , Jul 31, 2008
    View Source
    • 0 Attachment
      Raja, hi,

      >the same image wont load on my overlay. Could this be an image loading
      >issue, the image is rendered dynamically on mouseover over some cells
      >in my Table. The image is not loaded when the window load occurs.

      Did You try to split the URL as I did in my code?

      As You can see, I also dynamically write the code to the overlay when
      I move over it. Maybe You can compare What You do to what I did in my
      sample.
    • Raja
      Hi, this is what I have tried : theOverlay.setBody(companyName +
      Message 2 of 11 , Jul 31, 2008
      View Source
      • 0 Attachment
        Hi,

        this is what I have tried :

        theOverlay.setBody(companyName + "<img id='quoteChart'
        src='http://app.quotemedia.com/quotetools/getChart.go?webmasterId=91664&chtype=AreaChart&"

        +"symbol=YHOO&chmrg=3&chwid=160&chhig=130&chbg=ffffff&chln=104E8B&chgrd=CAE1FF&chxyc=000000&chton=off'
        border='1' hspace='3'><br>" + chartNav);
        theOverlay.setFooter(generateFooter(symbol));
        theOverlay.render(document.body);
        theOverlay.symbolCell.addClass('hoversymbol_active');
        theOverlay.align();
        theOverlay.show();

        Thank You,
        Raja

        --- In ydn-javascript@yahoogroups.com, "Frank Dietrich"
        <fdietrich@...> wrote:
        >
        >
        > Raja, hi,
        >
        > >the same image wont load on my overlay. Could this be an image loading
        > >issue, the image is rendered dynamically on mouseover over some cells
        > >in my Table. The image is not loaded when the window load occurs.
        >
        > Did You try to split the URL as I did in my code?
        >
        > As You can see, I also dynamically write the code to the overlay when
        > I move over it. Maybe You can compare What You do to what I did in my
        > sample.
        >
      • Frank Dietrich
        Raja, sorry. Had no time to look into this yet... Already 10pm here *********** REPLY SEPARATOR ***********
        Message 3 of 11 , Aug 1, 2008
        View Source
        • 0 Attachment
          Raja,

          sorry. Had no time to look into this yet... Already 10pm here

          *********** REPLY SEPARATOR ***********

          On 31.07.08 at 22:49 Raja wrote:

          >Hi,
          >
          >this is what I have tried :
          >
          >theOverlay.setBody(companyName + "<img id='quoteChart'
          >src='http://app.quotemedia.com/quotetools/getChart.go?webmasterId=91664&chtype=AreaChart&"
          >
          >+"symbol=YHOO&chmrg=3&chwid=160&chhig=130&chbg=ffffff&chln=104E8B&chgrd=CAE1FF&chxyc=000000&chton=off'
          >border='1' hspace='3'><br>" + chartNav);
          > theOverlay.setFooter(generateFooter(symbol));
          > theOverlay.render(document.body);
          > theOverlay.symbolCell.addClass('hoversymbol_active');
          > theOverlay.align();
          > theOverlay.show();
          >
          >Thank You,
          >Raja
          >
          >--- In ydn-javascript@yahoogroups.com, "Frank Dietrich"
          ><fdietrich@...> wrote:
          >>
          >>
          >> Raja, hi,
          >>
          >> >the same image wont load on my overlay. Could this be an image loading
          >> >issue, the image is rendered dynamically on mouseover over some cells
          >> >in my Table. The image is not loaded when the window load occurs.
          >>
          >> Did You try to split the URL as I did in my code?
          >>
          >> As You can see, I also dynamically write the code to the overlay when
          >> I move over it. Maybe You can compare What You do to what I did in my
          >> sample.
          >>
          >
          >
          >
          >------------------------------------
          >
          >Yahoo! Groups Links
          >
          >
          >
        • dietrich.frank
          Raja, ... src= http://app.quotemedia.com/quotetools/getChart.go?webmasterId=91664& chtype=AreaChart& ... late, but I ve tried. I have copied Your code
          Message 4 of 11 , Aug 1, 2008
          View Source
          • 0 Attachment
            Raja,

            > this is what I have tried :
            >
            > theOverlay.setBody(companyName + "<img id='quoteChart'
            > src='http://app.quotemedia.com/quotetools/getChart.go?webmasterId=91664&chtype=AreaChart&"...


            late, but I've tried. I have copied Your code exactely in my example and created dummy variables for the ones You use. I only commented the SetFooter() and the setclass() points out.

            Works wonderful. You don't need the render(document.body) everytime, only the first time it's needed.

            http://www.personalplanung.com/YUI/test_OverlayFollowsMouse.html 


            This is the code:

                if (o.target.id.substr(0,3) == "Raj"){

                    if (o.target.id == currentTarget) {
                        // nothing
                    }
                    else {
                        // Test using code from Raja

                        // some dummy-vars, so that

                        // his code works
                        var companyName = "dd-tech.de";
                        var chartNav    = "-- Nav here --";

                        // check if the overlay is there; if not, create it
                        checkOverlay();

                        var theOverlay = toolTip;

                        theOverlay.setBody(companyName +
                             "<img id='quoteChart' src='http://app.quotemedia.com/quotetools/getChart.go?webmasterId=91664&chtype=AreaChart&"
                             +"symbol=YHOO&chmrg=3&chwid=160&chhig=130&chbg=ffffff&chln=104E8B&chgrd=CAE1FF&chxyc=000000&chton=off' border='1' hspace='3'><br>" + chartNav);

                         // theOverlay.setFooter(generateFooter(symbol));
                         theOverlay.render(document.body);
                         // theOverlay.symbolCell.addClass('hoversymbol_active');
                         theOverlay.align();
                         theOverlay.show();
                   }
                }

             

            from my side this works great.  If You still can't get it to work, start reducing things or try to follow the script in firebug. Maybe it vanishes somewhere without producing an error.

            some of the YUI-methods use TRY...CATCH blocks that simply catch errors without complaining.

            HTH

            Frank
          • dietrich.frank
            Raja, FYI,I just tried the sample locally calling it via http://localhost... and I don t see the images either. as soon as I call it via file:// , via my
            Message 5 of 11 , Aug 1, 2008
            View Source
            • 0 Attachment
              Raja,

              FYI,I just tried the sample locally calling it via
              "http://localhost..." and I don't see the images either.
              as soon as I call it via "file://", via my local ip address
              (http://195.168...) or call it on my webserver, the images appear

              Maybe this is the issue in Your case.
            • Raja
              Thanks! Frank, I m working on it, I observed the same. Waiting on the other team to include a doctype, and retry the same. Cheers, Raja
              Message 6 of 11 , Aug 4, 2008
              View Source
              • 0 Attachment
                Thanks! Frank,

                I'm working on it, I observed the same. Waiting on the other team to
                include a doctype, and retry the same.

                Cheers,
                Raja
                --- In ydn-javascript@yahoogroups.com, "dietrich.frank"
                <fdietrich@...> wrote:
                >
                >
                >
                > Raja,
                >
                > FYI,I just tried the sample locally calling it via
                > "http://localhost..." and I don't see the images either.
                > as soon as I call it via "file://", via my local ip address
                > (http://195.168...) or call it on my webserver, the images appear
                >
                > Maybe this is the issue in Your case.
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.