Loading ...
Sorry, an error occurred while loading the content.
 

Animation Issues since upgrade to 0.11.2

Expand Messages
  • caigesn
    I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am experiencing some strange animation issues. There are basically three containers on the page.
    Message 1 of 8 , Jul 28, 2006
      I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
      experiencing some strange animation issues. There are basically three
      containers on the page. The left and right containers follow you as
      you scroll down the page. The center container is intended for
      content. In version 0.10.0 the animation works fine, but in version
      0.11.2 the left container flickers after it is done animating. If I
      reverse the order in which I initialize the left and right containers
      then the flickering will happen on the right container. I have setup
      the example on my site:

      YUI Version 0.10.0
      http://www.sevenblend.com/followMe_yui_10

      YUI Version 0.11.2
      http://www.sevenblend.com/followMe_yui_112

      I have the source for this example loaded into a syntax highlighter in
      the center container. The scripts/loadPage.js initializes the
      animation and sets the onscroll events for the containers. If anyone
      knows what might be causing this issue please respond.
    • vividsilvernl
      Hi, No flickering for me on W2K, IE6 (latest updates). Maurice. ... three ... containers ... in
      Message 2 of 8 , Jul 28, 2006
        Hi,

        No flickering for me on W2K, IE6 (latest updates).

        Maurice.

        --- In ydn-javascript@yahoogroups.com, "caigesn" <caigesn@...> wrote:
        >
        > I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
        > experiencing some strange animation issues. There are basically
        three
        > containers on the page. The left and right containers follow you as
        > you scroll down the page. The center container is intended for
        > content. In version 0.10.0 the animation works fine, but in version
        > 0.11.2 the left container flickers after it is done animating. If I
        > reverse the order in which I initialize the left and right
        containers
        > then the flickering will happen on the right container. I have setup
        > the example on my site:
        >
        > YUI Version 0.10.0
        > http://www.sevenblend.com/followMe_yui_10
        >
        > YUI Version 0.11.2
        > http://www.sevenblend.com/followMe_yui_112
        >
        > I have the source for this example loaded into a syntax highlighter
        in
        > the center container. The scripts/loadPage.js initializes the
        > animation and sets the onscroll events for the containers. If anyone
        > knows what might be causing this issue please respond.
        >
      • caigesn
        ... I should have mentioned that it works fine in IE. The flickering only happens in Firefox. I am using Firefox 1.5.0.5
        Message 3 of 8 , Jul 28, 2006
          --- In ydn-javascript@yahoogroups.com, "vividsilvernl" <yahoo@...> wrote:
          >
          > Hi,
          >
          > No flickering for me on W2K, IE6 (latest updates).
          >
          > Maurice.
          >
          > --- In ydn-javascript@yahoogroups.com, "caigesn" <caigesn@> wrote:
          > >
          > > I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
          > > experiencing some strange animation issues. There are basically
          > three
          > > containers on the page. The left and right containers follow you as
          > > you scroll down the page. The center container is intended for
          > > content. In version 0.10.0 the animation works fine, but in version
          > > 0.11.2 the left container flickers after it is done animating. If I
          > > reverse the order in which I initialize the left and right
          > containers
          > > then the flickering will happen on the right container. I have setup
          > > the example on my site:
          > >
          > > YUI Version 0.10.0
          > > http://www.sevenblend.com/followMe_yui_10
          > >
          > > YUI Version 0.11.2
          > > http://www.sevenblend.com/followMe_yui_112
          > >
          > > I have the source for this example loaded into a syntax highlighter
          > in
          > > the center container. The scripts/loadPage.js initializes the
          > > animation and sets the onscroll events for the containers. If anyone
          > > knows what might be causing this issue please respond.
          > >
          >

          I should have mentioned that it works fine in IE. The flickering only
          happens in Firefox. I am using Firefox 1.5.0.5
        • Chris Thatcher
          I see no flickering (Firefox 1.5.0.5) ... -- ~Chris
          Message 4 of 8 , Jul 31, 2006
            I see no flickering (Firefox 1.5.0.5)

            On 7/28/06, caigesn <caigesn@...> wrote:

            --- In ydn-javascript@yahoogroups.com , "vividsilvernl" <yahoo@...> wrote:
            >
            > Hi,
            >
            > No flickering for me on W2K, IE6 (latest updates).
            >
            > Maurice.
            >
            > --- In ydn-javascript@yahoogroups.com, "caigesn" <caigesn@> wrote:
            > >
            > > I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
            > > experiencing some strange animation issues. There are basically
            > three
            > > containers on the page. The left and right containers follow you as
            > > you scroll down the page. The center container is intended for
            > > content. In version 0.10.0 the animation works fine, but in version
            > > 0.11.2 the left container flickers after it is done animating. If I
            > > reverse the order in which I initialize the left and right
            > containers
            > > then the flickering will happen on the right container. I have setup
            > > the example on my site:
            > >
            > > YUI Version 0.10.0
            > > http://www.sevenblend.com/followMe_yui_10
            > >
            > > YUI Version 0.11.2
            > > http://www.sevenblend.com/followMe_yui_112
            > >
            > > I have the source for this example loaded into a syntax highlighter
            > in
            > > the center container. The scripts/loadPage.js initializes the
            > > animation and sets the onscroll events for the containers. If anyone
            > > knows what might be causing this issue please respond.
            > >
            >

            I should have mentioned that it works fine in IE. The flickering only
            happens in Firefox. I am using Firefox 1.5.0.5




            --
            ~Chris
          • caigesn
            I ve increased the size of the center container so there is more area to scroll. Again, the animation works fine in Internet Explorer. The problem is evident
            Message 5 of 8 , Aug 1, 2006
              I've increased the size of the center container so there is more area
              to scroll. Again, the animation works fine in Internet Explorer. The
              problem is evident in Firefox 1.5.0.5, Flock 0.7.1, and older gecko
              versions. If animation.js is replaced with the 0.10 version the
              animation works fine. I'll be uploading a video screen capture of the
              problem soon. Watch the left container after scrolling. I've tested
              this on many systems and the problem does not appear to be isolated.

              -Caige


              --- In ydn-javascript@yahoogroups.com, "Chris Thatcher"
              <thatchman@...> wrote:
              >
              > I see no flickering (Firefox 1.5.0.5)
              >
              > On 7/28/06, caigesn <caigesn@...> wrote:
              > >
              > > --- In ydn-javascript@yahoogroups.com
              <ydn-javascript%40yahoogroups.com>,
              > > "vividsilvernl" <yahoo@> wrote:
              > > >
              > > > Hi,
              > > >
              > > > No flickering for me on W2K, IE6 (latest updates).
              > > >
              > > > Maurice.
              > > >
              > > > --- In ydn-javascript@yahoogroups.com
              <ydn-javascript%40yahoogroups.com>,
              > > "caigesn" <caigesn@> wrote:
              > > > >
              > > > > I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
              > > > > experiencing some strange animation issues. There are basically
              > > > three
              > > > > containers on the page. The left and right containers follow
              you as
              > > > > you scroll down the page. The center container is intended for
              > > > > content. In version 0.10.0 the animation works fine, but in
              version
              > > > > 0.11.2 the left container flickers after it is done animating.
              If I
              > > > > reverse the order in which I initialize the left and right
              > > > containers
              > > > > then the flickering will happen on the right container. I have
              setup
              > > > > the example on my site:
              > > > >
              > > > > YUI Version 0.10.0
              > > > > http://www.sevenblend.com/followMe_yui_10
              > > > >
              > > > > YUI Version 0.11.2
              > > > > http://www.sevenblend.com/followMe_yui_112
              > > > >
              > > > > I have the source for this example loaded into a syntax
              highlighter
              > > > in
              > > > > the center container. The scripts/loadPage.js initializes the
              > > > > animation and sets the onscroll events for the containers. If
              anyone
              > > > > knows what might be causing this issue please respond.
              > > > >
              > > >
              > >
              > > I should have mentioned that it works fine in IE. The flickering only
              > > happens in Firefox. I am using Firefox 1.5.0.5
              > >
              > >
              > >
              >
              >
              >
              > --
              > ~Chris
              >
            • Matt Sweeney
              Hi Caige, I can see the flicker on the left element as you ve described. I ll investigate and see if I can pinpoint the cause. Is the only diff between your
              Message 6 of 8 , Aug 1, 2006
                Hi Caige,

                I can see the flicker on the left element as you've described.  I'll investigate and see if I can pinpoint the cause.

                Is the only diff between your examples the YUI version?

                Thanks,

                Matt

                caigesn wrote:
                I've increased the size of the center container so there is more area
                to scroll. Again, the animation works fine in Internet Explorer. The
                problem is evident in Firefox 1.5.0.5, Flock 0.7.1, and older gecko
                versions. If animation.js is replaced with the 0.10 version the
                animation works fine. I'll be uploading a video screen capture of the
                problem soon. Watch the left container after scrolling. I've tested
                this on many systems and the problem does not appear to be isolated.
                
                -Caige
                
                
                --- In ydn-javascript@yahoogroups.com, "Chris Thatcher"
                <thatchman@...> wrote:
                  
                I see no flickering (Firefox 1.5.0.5)
                
                On 7/28/06, caigesn <caigesn@...> wrote:
                    
                  --- In ydn-javascript@yahoogroups.com
                      
                <ydn-javascript%40yahoogroups.com>,
                  
                "vividsilvernl" <yahoo@> wrote:
                      
                Hi,
                
                No flickering for me on W2K, IE6 (latest updates).
                
                Maurice.
                
                --- In ydn-javascript@yahoogroups.com
                        
                <ydn-javascript%40yahoogroups.com>,
                  
                "caigesn" <caigesn@> wrote:
                      
                I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
                experiencing some strange animation issues. There are basically
                          
                three
                        
                containers on the page. The left and right containers follow
                          
                you as
                  
                you scroll down the page. The center container is intended for
                content. In version 0.10.0 the animation works fine, but in
                          
                version
                  
                0.11.2 the left container flickers after it is done animating.
                          
                If I
                  
                reverse the order in which I initialize the left and right
                          
                containers
                        
                then the flickering will happen on the right container. I have
                          
                setup
                  
                the example on my site:
                
                YUI Version 0.10.0
                http://www.sevenblend.com/followMe_yui_10
                
                YUI Version 0.11.2
                http://www.sevenblend.com/followMe_yui_112
                
                I have the source for this example loaded into a syntax
                          
                highlighter
                  
                in
                        
                the center container. The scripts/loadPage.js initializes the
                animation and sets the onscroll events for the containers. If
                          
                anyone
                  
                knows what might be causing this issue please respond.
                
                          
                I should have mentioned that it works fine in IE. The flickering only
                happens in Firefox. I am using Firefox 1.5.0.5
                
                 
                
                      
                
                -- 
                ~Chris
                
                    
                
                
                
                
                
                
                 
                Yahoo! Groups Links
                
                <*> To visit your group on the web, go to:
                    http://groups.yahoo.com/group/ydn-javascript/
                
                <*> To unsubscribe from this group, send an email to:
                    ydn-javascript-unsubscribe@yahoogroups.com
                
                <*> Your use of Yahoo! Groups is subject to:
                    http://docs.yahoo.com/info/terms/
                 
                
                
                
                
                  

              • caigesn
                Thanks Matt, The only difference between the two is the YUI version. Version 0.10 works fine, version 0.11.2 has the flickering issue. -Caige
                Message 7 of 8 , Aug 1, 2006
                  Thanks Matt,

                  The only difference between the two is the YUI version. Version 0.10
                  works fine, version 0.11.2 has the flickering issue.

                  -Caige

                  --- In ydn-javascript@yahoogroups.com, Matt Sweeney <msweeney@...> wrote:
                  >
                  > Hi Caige,
                  >
                  > I can see the flicker on the left element as you've described. I'll
                  > investigate and see if I can pinpoint the cause.
                  >
                  > Is the only diff between your examples the YUI version?
                  >
                  > Thanks,
                  >
                  > Matt
                  >
                  > caigesn wrote:
                  >
                  > >I've increased the size of the center container so there is more area
                  > >to scroll. Again, the animation works fine in Internet Explorer. The
                  > >problem is evident in Firefox 1.5.0.5, Flock 0.7.1, and older gecko
                  > >versions. If animation.js is replaced with the 0.10 version the
                  > >animation works fine. I'll be uploading a video screen capture of the
                  > >problem soon. Watch the left container after scrolling. I've tested
                  > >this on many systems and the problem does not appear to be isolated.
                  > >
                  > >-Caige
                  > >
                  > >
                  > >--- In ydn-javascript@yahoogroups.com, "Chris Thatcher"
                  > ><thatchman@> wrote:
                  > >
                  > >
                  > >>I see no flickering (Firefox 1.5.0.5)
                  > >>
                  > >>On 7/28/06, caigesn <caigesn@> wrote:
                  > >>
                  > >>
                  > >>> --- In ydn-javascript@yahoogroups.com
                  > >>>
                  > >>>
                  > ><ydn-javascript%40yahoogroups.com>,
                  > >
                  > >
                  > >>>"vividsilvernl" <yahoo@> wrote:
                  > >>>
                  > >>>
                  > >>>>Hi,
                  > >>>>
                  > >>>>No flickering for me on W2K, IE6 (latest updates).
                  > >>>>
                  > >>>>Maurice.
                  > >>>>
                  > >>>>--- In ydn-javascript@yahoogroups.com
                  > >>>>
                  > >>>>
                  > ><ydn-javascript%40yahoogroups.com>,
                  > >
                  > >
                  > >>>"caigesn" <caigesn@> wrote:
                  > >>>
                  > >>>
                  > >>>>>I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
                  > >>>>>experiencing some strange animation issues. There are basically
                  > >>>>>
                  > >>>>>
                  > >>>>three
                  > >>>>
                  > >>>>
                  > >>>>>containers on the page. The left and right containers follow
                  > >>>>>
                  > >>>>>
                  > >you as
                  > >
                  > >
                  > >>>>>you scroll down the page. The center container is intended for
                  > >>>>>content. In version 0.10.0 the animation works fine, but in
                  > >>>>>
                  > >>>>>
                  > >version
                  > >
                  > >
                  > >>>>>0.11.2 the left container flickers after it is done animating.
                  > >>>>>
                  > >>>>>
                  > >If I
                  > >
                  > >
                  > >>>>>reverse the order in which I initialize the left and right
                  > >>>>>
                  > >>>>>
                  > >>>>containers
                  > >>>>
                  > >>>>
                  > >>>>>then the flickering will happen on the right container. I have
                  > >>>>>
                  > >>>>>
                  > >setup
                  > >
                  > >
                  > >>>>>the example on my site:
                  > >>>>>
                  > >>>>>YUI Version 0.10.0
                  > >>>>>http://www.sevenblend.com/followMe_yui_10
                  > >>>>>
                  > >>>>>YUI Version 0.11.2
                  > >>>>>http://www.sevenblend.com/followMe_yui_112
                  > >>>>>
                  > >>>>>I have the source for this example loaded into a syntax
                  > >>>>>
                  > >>>>>
                  > >highlighter
                  > >
                  > >
                  > >>>>in
                  > >>>>
                  > >>>>
                  > >>>>>the center container. The scripts/loadPage.js initializes the
                  > >>>>>animation and sets the onscroll events for the containers. If
                  > >>>>>
                  > >>>>>
                  > >anyone
                  > >
                  > >
                  > >>>>>knows what might be causing this issue please respond.
                  > >>>>>
                  > >>>>>
                  > >>>>>
                  > >>>I should have mentioned that it works fine in IE. The flickering only
                  > >>>happens in Firefox. I am using Firefox 1.5.0.5
                  > >>>
                  > >>>
                  > >>>
                  > >>>
                  > >>>
                  > >>
                  > >>--
                  > >>~Chris
                  > >>
                  > >>
                  > >>
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >Yahoo! Groups Links
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  > >
                  >
                • Matt Sweeney
                  I ve pinned this down to the fact that you create a new animation object every time the page scrolls. While scrolling, the scroll event is fired continuously,
                  Message 8 of 8 , Aug 1, 2006
                    I've pinned this down to the fact that you create a new animation object every time the page scrolls.

                    While scrolling, the scroll event is fired continuously, which means you may have quite a number of animation instances attempting to animate the "top" of the same element.  This causes some competition between the animation objects, as they are all feeding slightly different values to the element.

                    If you create the element once, and then reuse for subsequent animations (you may need to stop() the animation before calling animate() again), it should fix this issue.

                    Matt

                    caigesn wrote:
                    Thanks Matt,
                    
                    The only difference between the two is the YUI version. Version 0.10
                    works fine, version 0.11.2 has the flickering issue.
                    
                    -Caige
                    
                    --- In ydn-javascript@yahoogroups.com, Matt Sweeney <msweeney@...> wrote:
                      
                    Hi Caige,
                    
                    I can see the flicker on the left element as you've described.  I'll 
                    investigate and see if I can pinpoint the cause.
                    
                    Is the only diff between your examples the YUI version?
                    
                    Thanks,
                    
                    Matt
                    
                    caigesn wrote:
                    
                        
                    I've increased the size of the center container so there is more area
                    to scroll. Again, the animation works fine in Internet Explorer. The
                    problem is evident in Firefox 1.5.0.5, Flock 0.7.1, and older gecko
                    versions. If animation.js is replaced with the 0.10 version the
                    animation works fine. I'll be uploading a video screen capture of the
                    problem soon. Watch the left container after scrolling. I've tested
                    this on many systems and the problem does not appear to be isolated.
                    
                    -Caige
                    
                    
                    --- In ydn-javascript@yahoogroups.com, "Chris Thatcher"
                    <thatchman@> wrote:
                     
                    
                          
                    I see no flickering (Firefox 1.5.0.5)
                    
                    On 7/28/06, caigesn <caigesn@> wrote:
                       
                    
                            
                     --- In ydn-javascript@yahoogroups.com
                         
                    
                              
                    <ydn-javascript%40yahoogroups.com>,
                     
                    
                          
                    "vividsilvernl" <yahoo@> wrote:
                         
                    
                              
                    Hi,
                    
                    No flickering for me on W2K, IE6 (latest updates).
                    
                    Maurice.
                    
                    --- In ydn-javascript@yahoogroups.com
                           
                    
                                
                    <ydn-javascript%40yahoogroups.com>,
                     
                    
                          
                    "caigesn" <caigesn@> wrote:
                         
                    
                              
                    I have recently upgraded YUI to version 0.11.2 from 0.10.0 and am
                    experiencing some strange animation issues. There are basically
                             
                    
                                  
                    three
                           
                    
                                
                    containers on the page. The left and right containers follow
                             
                    
                                  
                    you as
                     
                    
                          
                    you scroll down the page. The center container is intended for
                    content. In version 0.10.0 the animation works fine, but in
                             
                    
                                  
                    version
                     
                    
                          
                    0.11.2 the left container flickers after it is done animating.
                             
                    
                                  
                    If I
                     
                    
                          
                    reverse the order in which I initialize the left and right
                             
                    
                                  
                    containers
                           
                    
                                
                    then the flickering will happen on the right container. I have
                             
                    
                                  
                    setup
                     
                    
                          
                    the example on my site:
                    
                    YUI Version 0.10.0
                    http://www.sevenblend.com/followMe_yui_10
                    
                    YUI Version 0.11.2
                    http://www.sevenblend.com/followMe_yui_112
                    
                    I have the source for this example loaded into a syntax
                             
                    
                                  
                    highlighter
                     
                    
                          
                    in
                           
                    
                                
                    the center container. The scripts/loadPage.js initializes the
                    animation and sets the onscroll events for the containers. If
                             
                    
                                  
                    anyone
                     
                    
                          
                    knows what might be causing this issue please respond.
                    
                             
                    
                                  
                    I should have mentioned that it works fine in IE. The flickering only
                    happens in Firefox. I am using Firefox 1.5.0.5
                    
                    
                    
                         
                    
                              
                    -- 
                    ~Chris
                    
                       
                    
                            
                    
                    
                    
                    
                    
                    
                    Yahoo! Groups Links
                    
                    
                    
                    
                    
                    
                    
                    
                     
                    
                          
                    
                    
                    
                    
                    
                    
                     
                    Yahoo! Groups Links
                    
                    <*> To visit your group on the web, go to:
                        http://groups.yahoo.com/group/ydn-javascript/
                    
                    <*> To unsubscribe from this group, send an email to:
                        ydn-javascript-unsubscribe@yahoogroups.com
                    
                    <*> Your use of Yahoo! Groups is subject to:
                        http://docs.yahoo.com/info/terms/
                     
                    
                    
                    
                    
                    
                      

                  Your message has been successfully submitted and would be delivered to recipients shortly.