Loading ...
Sorry, an error occurred while loading the content.
 

Re: [ydn-javascript] Re: Flash above yui overlay

Expand Messages
  • Brian Jackson
    It s a known bug with Linux, Firefox, and Flash. It s somewhere in Mozilla s bug database. The normal wmode tricks don t work. --Brian Jackson -- Come visit us
    Message 1 of 9 , Jun 30 10:55 AM
      It's a known bug with Linux, Firefox, and Flash. It's somewhere in Mozilla's
      bug database. The normal wmode tricks don't work.

      --Brian Jackson

      --
      Come visit us on IRC
      #yui on irc.freenode.net


      On Monday 30 June 2008 12:49:40 pm blocky97 wrote:
      > Hey all, I Notice something peculiar:
      >
      > the sample below:
      > http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
      >
      > works on Windows with FF 2.0.0.14 and IE 6.x
      > But on my centOS 5.X box with FF 2.0.0.14 it still does not work.
      > Granted the market share for that is small enough that I really don't
      > care...but its just something to be aware of...and if anyone has a
      > solution to get it to work in linux that would be great.
      >
      > thanks
      > seth
      >
      > --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
      > > Thanks for posting the link. I got it to work. I discovered that you
      > > have to set wmode as both a parameter and in the embed.
      > >
      > > <param name="wmode" value="opaque"/>
      > >
      > > <embed
      > > src="http://d.yimg.com/static.video.yahoo.com/yep/YV_YEP.swf?ver=2.0.44"
      > > type="application/x-shockwave-flash" width="300" height="260"
      > > allowFullScreen="true" wmode="opaque"></embed>
      > >
      > > --- In ydn-javascript@yahoogroups.com, "Satyen Desai" <sdesai@> wrote:
      > > > Hi,
      > > > My understanding is that setting the "wmode" parameter to
      > >
      > > "transparent" or "opaque" is required to allow the Flash movie object
      > > to respect z-index.
      > >
      > > > You'd still need to manage z-index stacking contexts as you would do
      > >
      > > for any other content on your page which maybe your problem.
      > >
      > > > See:
      > > > http://developer.yahoo.com/yui/container/overlay/index.html#stack
      > > >
      > > > If you can post a URL I can take a look at it.
      > > >
      > > > Here's a test URL which works fine with wmode set to "opaque" on the
      > >
      > > A-Grade set of browsers:
      >
      > http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
      >
      > > > NOTE:
      > > >
      > > > * If on the above page, we don't set wmode, so that it defaults to
      > >
      > > "window", the flash movie appears on top of the overlay, on all
      >
      > browsers.
      >
      > > > * Enabling the iframe shim will only help keep the overlay on top of
      > >
      > > the flash movie in IE. The other browsers all need wmode set to
      > > "opaque" or "transparent".
      > >
      > > > Regards,
      > > > Satyen
    Your message has been successfully submitted and would be delivered to recipients shortly.