Loading ...
Sorry, an error occurred while loading the content.
 

Re: [ydn-javascript] URL problem in DataSource

Expand Messages
  • nihar bhatt
    Yes,,,, it worked.... Thanks... Satyam..
    Message 1 of 6 , May 5, 2008
      Yes,,,, it worked.... Thanks... Satyam..

      On Mon, May 5, 2008 at 4:09 PM, Satyam <satyam@...> wrote:

      Try setting initialRequest to "" in the DataTable configuration options, the fourth argument to the DataTable constructor.  I remember this was an issue once and thought it had been solved.  It would seem it has not.
       
      Satyam
       
      ----- Original Message -----
      Sent: Monday, May 05, 2008 10:29 AM
      Subject: Re: [ydn-javascript] URL problem in DataSource

      well... i am not using any query parameter .... as in my case it is not required.
      because the servlet CompanyList is returning only XML format.

      i just want to use REST like URL http://localhost:8080/company/CompanyList
      i don't want any query parameters but if i omit ? character then it is showing me the
      error like u said in firebug... and as far as the removal of xxx-beta-min is concern..
      i am using YUI loader and i don;t know how to remove xxx-beta-min from that ...

      .

      On Mon, May 5, 2008 at 12:57 PM, Satyam <satyam@...> wrote:

      If you are using query arguments in the initialRequest configuration attributes, you do need the ? to separate them from the URL.  If you don't put it there, the query arguments will be concatenated to the base URL with no separator and they will come out as part of the page name.  If you are using Firebug, go to the Net tab and you might see the URL in red due to an error.
       
      If you want your error messages to make any sense, do not load the minified (xxx-min.js) files.  Object 'A' is the shortened name of some variable that the YUI compressor made up and that in the non-minified version does have a meaningful name.
       
      Satyam
       
      ----- Original Message -----
      Sent: Monday, May 05, 2008 8:19 AM
      Subject: [ydn-javascript] URL problem in DataSource

      Hi,

      I am using remote DataSource in YUI and loading the data into a data table
      the source is  "http://localhost:8080/company/CompanyList" and returning an xml format

      but when i am appending '?' character at the end of URL it is working nice...
      and as soon as i remove '?' character i am getting error "A has no properties" in datasource-beta-min.js .....

      so could someone point me out why it is happening so ...........because i don;t want '?' sign in my code...

      Thanking You,
      Nihar


      No virus found in this incoming message.
      Checked by AVG.
      Version: 7.5.524 / Virus Database: 269.23.8/1413 - Release Date: 03/05/2008 11:22


      No virus found in this incoming message.
      Checked by AVG.
      Version: 7.5.524 / Virus Database: 269.23.8/1414 - Release Date: 04/05/2008 12:31

    Your message has been successfully submitted and would be delivered to recipients shortly.