Loading ...
Sorry, an error occurred while loading the content.

Dialog and Select boxes not posting correctly in IE

Expand Messages
  • mirkomirko16
    Hello! I have a problem using the Dialog with Internet Explorer. The dialog form submits fine in Firefox and Safari, but in IE all the select box fields are
    Message 1 of 2 , May 1, 2008
    • 0 Attachment
      Hello!

      I have a problem using the Dialog with Internet Explorer. The dialog
      form submits fine in Firefox and Safari, but in IE all the select box
      fields are not posted to the PHP script. Additionally, when I try to
      access a select box value like I do with other fields
      (data.selectboxname), the value is always undefined in IE. It seems
      like there is some issue grabbing the value from select box fields.
      Anybody else can confirm this?

      Thanks!
    • Satyen Desai
      Hi, The Dialog Quickstart example: http://developer.yahoo.com/yui/examples/container/dialog-quickstart_clean.html Handles the select element OK (it s a
      Message 2 of 2 , May 1, 2008
      • 0 Attachment
        Hi,
        The Dialog Quickstart example:

        http://developer.yahoo.com/yui/examples/container/dialog-quickstart_clean.html

        Handles the select element OK (it's a multiple select box, but I tested the same page with a single select also).

        It maybe a function of what you're naming your selects? Also, which version of YUI are you on?

        - Satyen

        ________________________________________
        From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of mirkomirko16
        Sent: Thursday, May 01, 2008 2:37 PM
        To: ydn-javascript@yahoogroups.com
        Subject: [ydn-javascript] Dialog and Select boxes not posting correctly in IE

        Hello!

        I have a problem using the Dialog with Internet Explorer. The dialog
        form submits fine in Firefox and Safari, but in IE all the select box
        fields are not posted to the PHP script. Additionally, when I try to
        access a select box value like I do with other fields
        (data.selectboxname), the value is always undefined in IE. It seems
        like there is some issue grabbing the value from select box fields.
        Anybody else can confirm this?

        Thanks!
      Your message has been successfully submitted and would be delivered to recipients shortly.