Loading ...
Sorry, an error occurred while loading the content.

Flash above yui overlay

Expand Messages
  • Chris Czerniak
    I created an overlay on one of my pages that has a flash object and the flash appears above the overlay. I have the overlays zindex set to 200 and the flashes
    Message 1 of 9 , Apr 10, 2008
    • 0 Attachment
      I created an overlay on one of my pages that has a flash object and
      the flash appears above the overlay. I have the overlays zindex set to
      200 and the flashes zindex set to 1.

      Does anyone know how to get the flash to appear under the overlay.

      Thanks in advance.
    • Josh Tynjala
      Set the wmode parameter on the Flash content to opaque or transparent. -Josh ________________________________ From: ydn-javascript@yahoogroups.com
      Message 2 of 9 , Apr 10, 2008
      • 0 Attachment

        Set the wmode parameter on the Flash content to opaque or transparent.

        -Josh

         


        From: ydn-javascript@yahoogroups.com [mailto: ydn-javascript@yahoogroups.com ] On Behalf Of Chris Czerniak
        Sent: Thursday, April 10, 2008 10:09 AM
        To: ydn-javascript@yahoogroups.com
        Subject: [ydn-javascript] Flash above yui overlay

         

        I created an overlay on one of my pages that has a flash object and
        the flash appears above the overlay. I have the overlays zindex set to
        200 and the flashes zindex set to 1.

        Does anyone know how to get the flash to appear under the overlay.

        Thanks in advance.

      • Chris Czerniak
        Thanks for the quick reply. I tried this but the flash is still appearing over the overlay. Any other ideas.
        Message 3 of 9 , Apr 10, 2008
        • 0 Attachment
          Thanks for the quick reply. I tried this but the flash is still
          appearing over the overlay. Any other ideas.

          --- In ydn-javascript@yahoogroups.com, "Josh Tynjala" <jtynjala@...>
          wrote:
          >
          > Set the wmode parameter on the Flash content to opaque or transparent.
          >
          > -Josh
          >
          >
          >
          > ________________________________
          >
          > From: ydn-javascript@yahoogroups.com
          > [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Chris Czerniak
          > Sent: Thursday, April 10, 2008 10:09 AM
          > To: ydn-javascript@yahoogroups.com
          > Subject: [ydn-javascript] Flash above yui overlay
          >
          >
          >
          > I created an overlay on one of my pages that has a flash object and
          > the flash appears above the overlay. I have the overlays zindex set to
          > 200 and the flashes zindex set to 1.
          >
          > Does anyone know how to get the flash to appear under the overlay.
          >
          > Thanks in advance.
          >
        • mikhail.petrovsky
          I had the same problem... I had to set style.visibility= hidden to every Flash object on my page while the overlay was shown and then set back the visibility
          Message 4 of 9 , Apr 10, 2008
          • 0 Attachment
            I had the same problem... I had to set style.visibility='hidden' to
            every Flash object on my page while the overlay was shown and then set
            back the visibility when the overlay was hidden, I couldn't find
            another way to solve it.

            Fortunately, this didn't affect very much the esthetics of my site,
            since all the flash objects in the pages were small.

            --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
            >
            > Thanks for the quick reply. I tried this but the flash is still
            > appearing over the overlay. Any other ideas.
            >
            > --- In ydn-javascript@yahoogroups.com, "Josh Tynjala" <jtynjala@>
            > wrote:
            > >
            > > Set the wmode parameter on the Flash content to opaque or transparent.
            > >
            > > -Josh
            > >
            > >
            > >
            > > ________________________________
            > >
            > > From: ydn-javascript@yahoogroups.com
            > > [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Chris Czerniak
            > > Sent: Thursday, April 10, 2008 10:09 AM
            > > To: ydn-javascript@yahoogroups.com
            > > Subject: [ydn-javascript] Flash above yui overlay
            > >
            > >
            > >
            > > I created an overlay on one of my pages that has a flash object and
            > > the flash appears above the overlay. I have the overlays zindex set to
            > > 200 and the flashes zindex set to 1.
            > >
            > > Does anyone know how to get the flash to appear under the overlay.
            > >
            > > Thanks in advance.
            > >
            >
          • Satyen Desai
            Hi, My understanding is that setting the wmode parameter to transparent or opaque is required to allow the Flash movie object to respect z-index. You d
            Message 5 of 9 , Apr 10, 2008
            • 0 Attachment
              Hi,
              My understanding is that setting the "wmode" parameter to "transparent" or "opaque" is required to allow the Flash movie object to respect z-index.

              You'd still need to manage z-index stacking contexts as you would do for any other content on your page which maybe your problem.

              See:
              http://developer.yahoo.com/yui/container/overlay/index.html#stack

              If you can post a URL I can take a look at it.

              Here's a test URL which works fine with wmode set to "opaque" on the A-Grade set of browsers:

              http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html

              NOTE:

              * If on the above page, we don't set wmode, so that it defaults to "window", the flash movie appears on top of the overlay, on all browsers.

              * Enabling the iframe shim will only help keep the overlay on top of the flash movie in IE. The other browsers all need wmode set to "opaque" or "transparent".

              Regards,
              Satyen

              ________________________________________
              From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of mikhail.petrovsky
              Sent: Thursday, April 10, 2008 11:52 AM
              To: ydn-javascript@yahoogroups.com
              Subject: [ydn-javascript] Re: Flash above yui overlay

              I had the same problem... I had to set style.visibility='hidden' to
              every Flash object on my page while the overlay was shown and then set
              back the visibility when the overlay was hidden, I couldn't find
              another way to solve it.

              Fortunately, this didn't affect very much the esthetics of my site,
              since all the flash objects in the pages were small.

              --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
              >
              > Thanks for the quick reply. I tried this but the flash is still
              > appearing over the overlay. Any other ideas.
              >
              > --- In ydn-javascript@yahoogroups.com, "Josh Tynjala" <jtynjala@>
              > wrote:
              > >
              > > Set the wmode parameter on the Flash content to opaque or transparent.
              > >
              > > -Josh
              > >
              > >
              > >
              > > ________________________________
              > >
              > > From: ydn-javascript@yahoogroups.com
              > > [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Chris Czerniak
              > > Sent: Thursday, April 10, 2008 10:09 AM
              > > To: ydn-javascript@yahoogroups.com
              > > Subject: [ydn-javascript] Flash above yui overlay
              > >
              > >
              > >
              > > I created an overlay on one of my pages that has a flash object and
              > > the flash appears above the overlay. I have the overlays zindex set to
              > > 200 and the flashes zindex set to 1.
              > >
              > > Does anyone know how to get the flash to appear under the overlay.
              > >
              > > Thanks in advance.
              > >
              >
            • Jesse Sightler
              Are you using Linux? If so, Flash transparency tends not to work so well. A description along with a solution (a variant of the iframe hacks) does supposedly
              Message 6 of 9 , Apr 10, 2008
              • 0 Attachment
                Are you using Linux?  If so, Flash transparency tends not to work so well.

                A description along with a solution (a variant of the iframe hacks) does supposedly work:
                http://blog.marcoos.com/2006/07/21/html-div-above-a-flash-animation-on-linux-its-possible/


                On 4/10/08, Satyen Desai <sdesai@...> wrote:

                Hi,
                My understanding is that setting the "wmode" parameter to "transparent" or "opaque" is required to allow the Flash movie object to respect z-index.

                You'd still need to manage z-index stacking contexts as you would do for any other content on your page which maybe your problem.

                See:
                http://developer.yahoo.com/yui/container/overlay/index.html#stack

                If you can post a URL I can take a look at it.

                Here's a test URL which works fine with wmode set to "opaque" on the A-Grade set of browsers:

                http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html

                NOTE:

                * If on the above page, we don't set wmode, so that it defaults to "window", the flash movie appears on top of the overlay, on all browsers.

                * Enabling the iframe shim will only help keep the overlay on top of the flash movie in IE. The other browsers all need wmode set to "opaque" or "transparent".

                Regards,
                Satyen

                ________________________________________
                From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of mikhail.petrovsky
                Sent: Thursday, April 10, 2008 11:52 AM
                To: ydn-javascript@yahoogroups.com
                Subject: [ydn-javascript] Re: Flash above yui overlay

                I had the same problem... I had to set style.visibility='hidden' to
                every Flash object on my page while the overlay was shown and then set
                back the visibility when the overlay was hidden, I couldn't find
                another way to solve it.

                Fortunately, this didn't affect very much the esthetics of my site,
                since all the flash objects in the pages were small.

                --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
                >
                > Thanks for the quick reply. I tried this but the flash is still
                > appearing over the overlay. Any other ideas.
                >
                > --- In ydn-javascript@yahoogroups.com, "Josh Tynjala" <jtynjala@>
                > wrote:
                > >
                > > Set the wmode parameter on the Flash content to opaque or transparent.
                > >
                > > -Josh
                > >
                > >
                > >
                > > ________________________________
                > >
                > > From: ydn-javascript@yahoogroups.com
                > > [mailto:ydn-javascript@yahoogroups.com] On Behalf Of Chris Czerniak
                > > Sent: Thursday, April 10, 2008 10:09 AM
                > > To: ydn-javascript@yahoogroups.com
                > > Subject: [ydn-javascript] Flash above yui overlay
                > >
                > >
                > >
                > > I created an overlay on one of my pages that has a flash object and
                > > the flash appears above the overlay. I have the overlays zindex set to
                > > 200 and the flashes zindex set to 1.
                > >
                > > Does anyone know how to get the flash to appear under the overlay.
                > >
                > > Thanks in advance.
                > >
                >


              • Chris Czerniak
                Thanks for posting the link. I got it to work. I discovered that you have to set wmode as both a parameter and in the embed.
                Message 7 of 9 , Apr 11, 2008
                • 0 Attachment
                  Thanks for posting the link. I got it to work. I discovered that you
                  have to set wmode as both a parameter and in the embed.

                  <param name="wmode" value="opaque"/>

                  <embed
                  src="http://d.yimg.com/static.video.yahoo.com/yep/YV_YEP.swf?ver=2.0.44"
                  type="application/x-shockwave-flash" width="300" height="260"
                  allowFullScreen="true" wmode="opaque"></embed>

                  --- In ydn-javascript@yahoogroups.com, "Satyen Desai" <sdesai@...> wrote:
                  >
                  > Hi,
                  > My understanding is that setting the "wmode" parameter to
                  "transparent" or "opaque" is required to allow the Flash movie object
                  to respect z-index.
                  >
                  > You'd still need to manage z-index stacking contexts as you would do
                  for any other content on your page which maybe your problem.
                  >
                  > See:
                  > http://developer.yahoo.com/yui/container/overlay/index.html#stack
                  >
                  > If you can post a URL I can take a look at it.
                  >
                  > Here's a test URL which works fine with wmode set to "opaque" on the
                  A-Grade set of browsers:
                  >
                  > http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
                  >
                  > NOTE:
                  >
                  > * If on the above page, we don't set wmode, so that it defaults to
                  "window", the flash movie appears on top of the overlay, on all browsers.
                  >
                  > * Enabling the iframe shim will only help keep the overlay on top of
                  the flash movie in IE. The other browsers all need wmode set to
                  "opaque" or "transparent".
                  >
                  > Regards,
                  > Satyen
                  >
                • blocky97
                  Hey all, I Notice something peculiar: the sample below: http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html works on Windows with FF
                  Message 8 of 9 , Jun 30, 2008
                  • 0 Attachment
                    Hey all, I Notice something peculiar:

                    the sample below:
                    http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html

                    works on Windows with FF 2.0.0.14 and IE 6.x
                    But on my centOS 5.X box with FF 2.0.0.14 it still does not work.
                    Granted the market share for that is small enough that I really don't
                    care...but its just something to be aware of...and if anyone has a
                    solution to get it to work in linux that would be great.

                    thanks
                    seth

                    --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
                    >
                    > Thanks for posting the link. I got it to work. I discovered that you
                    > have to set wmode as both a parameter and in the embed.
                    >
                    > <param name="wmode" value="opaque"/>
                    >
                    > <embed
                    > src="http://d.yimg.com/static.video.yahoo.com/yep/YV_YEP.swf?ver=2.0.44"
                    > type="application/x-shockwave-flash" width="300" height="260"
                    > allowFullScreen="true" wmode="opaque"></embed>
                    >
                    > --- In ydn-javascript@yahoogroups.com, "Satyen Desai" <sdesai@> wrote:
                    > >
                    > > Hi,
                    > > My understanding is that setting the "wmode" parameter to
                    > "transparent" or "opaque" is required to allow the Flash movie object
                    > to respect z-index.
                    > >
                    > > You'd still need to manage z-index stacking contexts as you would do
                    > for any other content on your page which maybe your problem.
                    > >
                    > > See:
                    > > http://developer.yahoo.com/yui/container/overlay/index.html#stack
                    > >
                    > > If you can post a URL I can take a look at it.
                    > >
                    > > Here's a test URL which works fine with wmode set to "opaque" on the
                    > A-Grade set of browsers:
                    > >
                    > >
                    http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
                    > >
                    > > NOTE:
                    > >
                    > > * If on the above page, we don't set wmode, so that it defaults to
                    > "window", the flash movie appears on top of the overlay, on all
                    browsers.
                    > >
                    > > * Enabling the iframe shim will only help keep the overlay on top of
                    > the flash movie in IE. The other browsers all need wmode set to
                    > "opaque" or "transparent".
                    > >
                    > > Regards,
                    > > Satyen
                    > >
                    >
                  • Brian Jackson
                    It s a known bug with Linux, Firefox, and Flash. It s somewhere in Mozilla s bug database. The normal wmode tricks don t work. --Brian Jackson -- Come visit us
                    Message 9 of 9 , Jun 30, 2008
                    • 0 Attachment
                      It's a known bug with Linux, Firefox, and Flash. It's somewhere in Mozilla's
                      bug database. The normal wmode tricks don't work.

                      --Brian Jackson

                      --
                      Come visit us on IRC
                      #yui on irc.freenode.net


                      On Monday 30 June 2008 12:49:40 pm blocky97 wrote:
                      > Hey all, I Notice something peculiar:
                      >
                      > the sample below:
                      > http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
                      >
                      > works on Windows with FF 2.0.0.14 and IE 6.x
                      > But on my centOS 5.X box with FF 2.0.0.14 it still does not work.
                      > Granted the market share for that is small enough that I really don't
                      > care...but its just something to be aware of...and if anyone has a
                      > solution to get it to work in linux that would be great.
                      >
                      > thanks
                      > seth
                      >
                      > --- In ydn-javascript@yahoogroups.com, "Chris Czerniak" <chris@...> wrote:
                      > > Thanks for posting the link. I got it to work. I discovered that you
                      > > have to set wmode as both a parameter and in the embed.
                      > >
                      > > <param name="wmode" value="opaque"/>
                      > >
                      > > <embed
                      > > src="http://d.yimg.com/static.video.yahoo.com/yep/YV_YEP.swf?ver=2.0.44"
                      > > type="application/x-shockwave-flash" width="300" height="260"
                      > > allowFullScreen="true" wmode="opaque"></embed>
                      > >
                      > > --- In ydn-javascript@yahoogroups.com, "Satyen Desai" <sdesai@> wrote:
                      > > > Hi,
                      > > > My understanding is that setting the "wmode" parameter to
                      > >
                      > > "transparent" or "opaque" is required to allow the Flash movie object
                      > > to respect z-index.
                      > >
                      > > > You'd still need to manage z-index stacking contexts as you would do
                      > >
                      > > for any other content on your page which maybe your problem.
                      > >
                      > > > See:
                      > > > http://developer.yahoo.com/yui/container/overlay/index.html#stack
                      > > >
                      > > > If you can post a URL I can take a look at it.
                      > > >
                      > > > Here's a test URL which works fine with wmode set to "opaque" on the
                      > >
                      > > A-Grade set of browsers:
                      >
                      > http://yuiblog.com/sandbox/yui/v251/examples/container/overlayflash.html
                      >
                      > > > NOTE:
                      > > >
                      > > > * If on the above page, we don't set wmode, so that it defaults to
                      > >
                      > > "window", the flash movie appears on top of the overlay, on all
                      >
                      > browsers.
                      >
                      > > > * Enabling the iframe shim will only help keep the overlay on top of
                      > >
                      > > the flash movie in IE. The other browsers all need wmode set to
                      > > "opaque" or "transparent".
                      > >
                      > > > Regards,
                      > > > Satyen
                    Your message has been successfully submitted and would be delivered to recipients shortly.