Loading ...
Sorry, an error occurred while loading the content.

Simple Uploader Question (IO Error)

Expand Messages
  • patorjk
    hey all, This is probably something stupid, but I figured ask since I don t seem to be having much luck tonight. I decided to take a look at the Uploader
    Message 1 of 2 , Mar 29, 2008
    • 0 Attachment
      hey all,

      This is probably something stupid, but I figured ask since I don't
      seem to be having much luck tonight. I decided to take a look at the
      Uploader utility. I downloaded both the simple and advanced examples,
      yet I can't seem to get them working. I have all the YUI files
      uploaded, and I changed the example files to point to what I uploaded,
      however, every time I try to upload a file I get an "IO Error". The
      table below the upload button also gets stuck in a "Loading data..."
      state. You can see the example here:

      http://patorjk.com/common/uploader-advanced/uploader-advanced_source.html

      The only things I changed were the source paths (including the swf
      path) and the "uploader.upload" line. I tried using both a full path
      and a relative path for the upload directory.

      I have the same problem when I run the files on my local machine too.

      - Pat
    • j_s_shirley
      Hi Pat, Where is the script you are uploading to? You have to have a script on your server that accepts the upload and returns a valid response. A good sample
      Message 2 of 2 , Apr 2, 2008
      • 0 Attachment
        Hi Pat,

        Where is the script you are uploading to? You have to have a script
        on your server that accepts the upload and returns a valid response.

        A good sample script is available here:
        http://patcavit.com/2008/03/01/yui-uploader-implementation/

        He has a full demonstration and working PHP+JS (that is quite a bit
        nicer than the example JS that is on the YUI site)

        Hope this helps,
        -Jay

        --- In ydn-javascript@yahoogroups.com, "patorjk" <patorjk@...> wrote:
        >
        > hey all,
        >
        > This is probably something stupid, but I figured ask since I don't
        > seem to be having much luck tonight. I decided to take a look at the
        > Uploader utility. I downloaded both the simple and advanced examples,
        > yet I can't seem to get them working. I have all the YUI files
        > uploaded, and I changed the example files to point to what I uploaded,
        > however, every time I try to upload a file I get an "IO Error". The
        > table below the upload button also gets stuck in a "Loading data..."
        > state. You can see the example here:
        >
        >
        http://patorjk.com/common/uploader-advanced/uploader-advanced_source.html
        >
        > The only things I changed were the source paths (including the swf
        > path) and the "uploader.upload" line. I tried using both a full path
        > and a relative path for the upload directory.
        >
        > I have the same problem when I run the files on my local machine too.
        >
        > - Pat
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.