Loading ...
Sorry, an error occurred while loading the content.
 

Re: [ydn-javascript] Re: Dialog async request and timeouts.

Expand Messages
  • Neil Brideau
    ... Thanks Thomas. I have already reviewed all possible directives in the php.ini which would cause an premature abort. I have assumed that 128M memory limit
    Message 1 of 3 , Nov 2, 2007
      tssha wrote:
      >
      >
      > --- In ydn-javascript@yahoogroups.com
      > <mailto:ydn-javascript%40yahoogroups.com>, Neil Brideau <corn@...> wrote:
      >>
      >>
      >> TGIF! Im having a little trouble with a application I wrote and I
      >> need some advice. Basically I have a bunch of Dialog's on a page. Once
      >> you open a dialog you choose a file to upload and upload it. On success
      >> or in YUI the "upload" callback is called I use a datatable to display a
      >> log for the processing that occurred.
      >>
      >> The live dataset is quite large and I have already had to increase
      >> the php max_execution time and upload_max_filesize and the like. However
      >> I am still running into problems with incomplete requests.
      >>
      >> I believe these may be due to timeouts in the dialog's connection
      >> object. However this object seems pretty buried inside the dialog code.
      >> Can I add an abort callback to the dialogs callback methods and will
      >> this tell me if I am timing out? Should I be timing out how would I
      >> specify a timeout to the dialogs connection object.
      >
      > If you do not explicitly define a timeout within the callback, or call
      > abort, Connection Manager would not automatically issue an abort call.
      >
      > To define an abort within the callback, simply add the timeout
      > property to the callback with a time threshold in milliseconds. For
      > example:
      >
      > var callback = {
      > upload:uploadHandler,
      > timeout:3000 //3 seconds
      > };
      >
      > Since you appear to be running PHP(e.g., upload_max_filesize), have
      > you modified any of these other settings(not exhaustive):
      >
      > * post_max_size
      > * max_input_time
      > * memory_limit
      >
      > If you are running Apache, what is the value of the LimitRequestBody
      > directive?
      >
      > Regards,
      > Thomas

      Thanks Thomas. I have already reviewed all possible directives in the
      php.ini which would cause an premature abort. I have assumed that 128M
      memory limit is sufficient as my larges files are just over 5M. So
      essentially the connection manager has no timeout unless specified. The
      application is actually going to be running on IIS. Its a contract so I
      could not specify the environment. Thanks for the reply thats very helpful.

      Regards,
      Neil


      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.