Loading ...
Sorry, an error occurred while loading the content.

Trying to convert from 2..2.2 to 2.3.1; error with datatable

Expand Messages
  • j2ee20072007
    Hi I m trying to convert from 2.2.2 to 2.3.1 and I m having an issue getting an old screen to work that uess datatable. It s erroring out on a line and I m not
    Message 1 of 6 , Oct 31, 2007
    • 0 Attachment
      Hi I'm trying to convert from 2.2.2 to 2.3.1 and I'm having an issue
      getting an old screen to work that uess datatable. It's erroring out
      on a line and I'm not sure why; I've checked the includes and all
      looks good. What's odd is that it's erroring out on this line; any
      ideas why?

      YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
      sClassName) {
      var elCell = this._elMsgTd;
      if(YAHOO.lang.isString(sHTML)) {
      elCell.innerHTML = sHTML;
      }
      if(YAHOO.lang.isString(sClassName)) {
      YAHOO.util.Dom.addClass(elCell, sClassName);
      }
      this._elMsgTbody.style.display = "";
      this.fireEvent("tableMsgShowEvent", {html:sHTML,
      className:sClassName}); -- "Object does not support this property or
      method"
      };

      Thanks
    • j2ee20072007
      Anyone??
      Message 2 of 6 , Nov 1, 2007
      • 0 Attachment
        Anyone??
      • jennykhan
        Hi there, Can you confirm that you are including the Element Utility, which is a new dependency as of version 2.3.0? Regards, Jenny
        Message 3 of 6 , Nov 5, 2007
        • 0 Attachment
          Hi there,

          Can you confirm that you are including the Element Utility, which is a
          new dependency as of version 2.3.0?

          Regards,
          Jenny



          --- In ydn-javascript@yahoogroups.com, "j2ee20072007"
          <j2ee20072007@...> wrote:
          >
          > Hi I'm trying to convert from 2.2.2 to 2.3.1 and I'm having an issue
          > getting an old screen to work that uess datatable. It's erroring out
          > on a line and I'm not sure why; I've checked the includes and all
          > looks good. What's odd is that it's erroring out on this line; any
          > ideas why?
          >
          > YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
          > sClassName) {
          > var elCell = this._elMsgTd;
          > if(YAHOO.lang.isString(sHTML)) {
          > elCell.innerHTML = sHTML;
          > }
          > if(YAHOO.lang.isString(sClassName)) {
          > YAHOO.util.Dom.addClass(elCell, sClassName);
          > }
          > this._elMsgTbody.style.display = "";
          > this.fireEvent("tableMsgShowEvent", {html:sHTML,
          > className:sClassName}); -- "Object does not support this property or
          > method"
          > };
          >
          > Thanks
          >
        • john hartley
          Hello, I am also getting this error while Trying to convert from 2.2.0 to 2.4.0 The Element utility IS being included. The code works fine using YAHOO UI 2.2.0
          Message 4 of 6 , Dec 10, 2008
          • 0 Attachment
            Hello,

            I am also getting this error while Trying to convert from 2.2.0 to 2.4.0

            The Element utility IS being included. The code works fine using YAHOO UI 2.2.0

            During the construction of the DataTable, the initEl method is called which calls :

            YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,  sClassName) {
             var elCell = this._elMsgTd;
             if(YAHOO.lang.isString(sHTML)) {
             elCell.innerHTML = sHTML;
             }
             if(YAHOO.lang.isString(sClassName)) {
             YAHOO.util.Dom.addClass(elCell, sClassName);
             }
             this._elMsgTbody.style.display = "";

            /*And this fails:*/     this.fireEvent("tableMsgShowEvent", {html:sHTML,
             className:sClassName});

            Error is:  "Object does not support this property or  method" 

            Any other ideas out there???


            TIA

            JR






            --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@...> wrote:
            >
            > Hi there,
            >
            > Can you confirm that you are including the Element Utility, which is a
            > new dependency as of version 2.3.0?
            >
            > Regards,
            > Jenny
            >
            >
            >
            > --- In ydn-javascript@yahoogroups.com, "j2ee20072007"
            > j2ee20072007@ wrote:
            > >
            > > Hi I'm trying to convert from 2.2.2 to 2.3.1 and I'm having an issue
            > > getting an old screen to work that uess datatable. It's erroring out
            > > on a line and I'm not sure why; I've checked the includes and all
            > > looks good. What's odd is that it's erroring out on this line; any
            > > ideas why?
            > >
            > > YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
            > > sClassName) {
            > > var elCell = this._elMsgTd;
            > > if(YAHOO.lang.isString(sHTML)) {
            > > elCell.innerHTML = sHTML;
            > > }
            > > if(YAHOO.lang.isString(sClassName)) {
            > > YAHOO.util.Dom.addClass(elCell, sClassName);
            > > }
            > > this._elMsgTbody.style.display = "";
            > > this.fireEvent("tableMsgShowEvent", {html:sHTML,
            > > className:sClassName}); -- "Object does not support this property or
            > > method"
            > > };
            > >
            > > Thanks
            > >
            >
          • jennykhan
            Hi John, Can you confirm that the Element build file is being included before the DataTable build file? Jenny
            Message 5 of 6 , Dec 10, 2008
            • 0 Attachment
              Hi John,

              Can you confirm that the Element build file is being included before
              the DataTable build file?

              Jenny



              --- In ydn-javascript@yahoogroups.com, "john hartley" <jhartley@...>
              wrote:
              >
              >
              > Hello,
              >
              > I am also getting this error while Trying to convert from 2.2.0 to 2.4.0
              >
              > The Element utility IS being included. The code works fine using YAHOO
              > UI 2.2.0
              >
              > During the construction of the DataTable, the initEl method is called
              > which calls :
              >
              > YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
              > sClassName) {
              > var elCell = this._elMsgTd;
              > if(YAHOO.lang.isString(sHTML)) {
              > elCell.innerHTML = sHTML;
              > }
              > if(YAHOO.lang.isString(sClassName)) {
              > YAHOO.util.Dom.addClass(elCell, sClassName);
              > }
              > this._elMsgTbody.style.display = "";
              >
              > /*And this fails:*/ this.fireEvent("tableMsgShowEvent", {html:sHTML,
              > className:sClassName});
              >
              > Error is: "Object does not support this property or method"
              >
              > Any other ideas out there???
              >
              >
              > TIA
              >
              > JR
              >
              >
              >
              >
              >
              >
              > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@> wrote:
              > >
              > > Hi there,
              > >
              > > Can you confirm that you are including the Element Utility, which is a
              > > new dependency as of version 2.3.0?
              > >
              > > Regards,
              > > Jenny
              > >
              > >
              > >
              > > --- In ydn-javascript@yahoogroups.com, "j2ee20072007"
              > > j2ee20072007@ wrote:
              > > >
              > > > Hi I'm trying to convert from 2.2.2 to 2.3.1 and I'm having an issue
              > > > getting an old screen to work that uess datatable. It's erroring out
              > > > on a line and I'm not sure why; I've checked the includes and all
              > > > looks good. What's odd is that it's erroring out on this line; any
              > > > ideas why?
              > > >
              > > > YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
              > > > sClassName) {
              > > > var elCell = this._elMsgTd;
              > > > if(YAHOO.lang.isString(sHTML)) {
              > > > elCell.innerHTML = sHTML;
              > > > }
              > > > if(YAHOO.lang.isString(sClassName)) {
              > > > YAHOO.util.Dom.addClass(elCell, sClassName);
              > > > }
              > > > this._elMsgTbody.style.display = "";
              > > > this.fireEvent("tableMsgShowEvent", {html:sHTML,
              > > > className:sClassName}); -- "Object does not support this property
              > or
              > > > method"
              > > > };
              > > >
              > > > Thanks
              > > >
              > >
              >
            • john hartley
              Jenny, I changed the order of the includes and got past the problem, Thanks! Now on to the next thing... ... 2.4.0 ... {html:sHTML, ... which is a ... issue
              Message 6 of 6 , Dec 11, 2008
              • 0 Attachment
                Jenny,

                I changed the order of the includes and got past the problem, Thanks!

                Now on to the next thing...


                --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@...> wrote:
                >
                > Hi John,
                >
                > Can you confirm that the Element build file is being included before
                > the DataTable build file?
                >
                > Jenny
                >
                >
                >
                > --- In ydn-javascript@yahoogroups.com, "john hartley" <jhartley@>
                > wrote:
                > >
                > >
                > > Hello,
                > >
                > > I am also getting this error while Trying to convert from 2.2.0 to
                2.4.0
                > >
                > > The Element utility IS being included. The code works fine using YAHOO
                > > UI 2.2.0
                > >
                > > During the construction of the DataTable, the initEl method is called
                > > which calls :
                > >
                > > YAHOO.widget.DataTable.prototype.showTableMessage = function(sHTML,
                > > sClassName) {
                > > var elCell = this._elMsgTd;
                > > if(YAHOO.lang.isString(sHTML)) {
                > > elCell.innerHTML = sHTML;
                > > }
                > > if(YAHOO.lang.isString(sClassName)) {
                > > YAHOO.util.Dom.addClass(elCell, sClassName);
                > > }
                > > this._elMsgTbody.style.display = "";
                > >
                > > /*And this fails:*/ this.fireEvent("tableMsgShowEvent",
                {html:sHTML,
                > > className:sClassName});
                > >
                > > Error is: "Object does not support this property or method"
                > >
                > > Any other ideas out there???
                > >
                > >
                > > TIA
                > >
                > > JR
                > >
                > >
                > >
                > >
                > >
                > >
                > > --- In ydn-javascript@yahoogroups.com, "jennykhan" <jennyhan@> wrote:
                > > >
                > > > Hi there,
                > > >
                > > > Can you confirm that you are including the Element Utility,
                which is a
                > > > new dependency as of version 2.3.0?
                > > >
                > > > Regards,
                > > > Jenny
                > > >
                > > >
                > > >
                > > > --- In ydn-javascript@yahoogroups.com, "j2ee20072007"
                > > > j2ee20072007@ wrote:
                > > > >
                > > > > Hi I'm trying to convert from 2.2.2 to 2.3.1 and I'm having an
                issue
                > > > > getting an old screen to work that uess datatable. It's
                erroring out
                > > > > on a line and I'm not sure why; I've checked the includes and all
                > > > > looks good. What's odd is that it's erroring out on this line; any
                > > > > ideas why?
                > > > >
                > > > > YAHOO.widget.DataTable.prototype.showTableMessage =
                function(sHTML,
                > > > > sClassName) {
                > > > > var elCell = this._elMsgTd;
                > > > > if(YAHOO.lang.isString(sHTML)) {
                > > > > elCell.innerHTML = sHTML;
                > > > > }
                > > > > if(YAHOO.lang.isString(sClassName)) {
                > > > > YAHOO.util.Dom.addClass(elCell, sClassName);
                > > > > }
                > > > > this._elMsgTbody.style.display = "";
                > > > > this.fireEvent("tableMsgShowEvent", {html:sHTML,
                > > > > className:sClassName}); -- "Object does not support this property
                > > or
                > > > > method"
                > > > > };
                > > > >
                > > > > Thanks
                > > > >
                > > >
                > >
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.