Loading ...
Sorry, an error occurred while loading the content.

Re: animation not working correctly in MSIE

Expand Messages
  • freyfogle
    Thanks for the help. We eventually figured it out - a tricky bug: I call YAHOO.util.Event.onAvailable( kw , function() { earlier in the page there was a form
    Message 1 of 6 , Sep 28 10:02 AM
    • 0 Attachment
      Thanks for the help.

      We eventually figured it out - a tricky bug:

      I call


      YAHOO.util.Event.onAvailable('kw', function() {

      earlier in the page there was a form element with the name (not the
      id) 'kw'. I guess this confuses MSIE - A word of warning always use
      unique names for everything!

      Ok, so that's solved (good times). Now a new bug. In my actual page,
      in the space below the animation that is supposed to gently be moved
      out of the way I have a google map. In firefox and safari all works
      well. In MSIE the map stays where it originally was and lays on top of
      the content. Lame. The div the map is in has no float or z-index
      property. As before no error messages of any sort are generated .

      Any one have any ideas why that content would be stuck there?

      sincere thanks for your help,











      --- In ydn-javascript@yahoogroups.com, "Adam" <adam.mcintyre@...> wrote:
      >
      > Can you post a link?
      >
      > If all else fails, try tinkering with and animating the line-height
      > property of the element containing your text. Sometimes (for reasons I
      > can't comprehend) IE likes to enforce line-height as if it were
      > actually height being set.
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.