Loading ...
Sorry, an error occurred while loading the content.

Tooltips blank.gif image not caching

Expand Messages
  • Julie Szmyd
    Hi, As I ve mentioned in a previous post, I have created tooltips on the Calendar control for certain dates that have events scheduled on them. I am displaying
    Message 1 of 4 , Jun 1, 2006
    • 0 Attachment
      Hi,

      As I've mentioned in a previous post, I have created tooltips on the
      Calendar control for certain dates that have events scheduled on them.
      I am displaying a 3 month view, so there is a potential for up to 90
      tooltips on the calendar (1 for each available date). Because I am
      running in Internet Explorer 6.0, the tooltips are being displayed
      inside of an iframe to prevent select drop downs from bleeding through
      the tooltips. The iframe is loading an image: /i/promo/m/irs/blank.gif
      from the host us.yimg.com. The following headers are being returned:

      HTTP/1.0 200 OK
      Content-Type: image/gif
      Content-Length: 43
      Last-Modified: Fri, 15 Apr 1994 00:00:00 GMT
      Expires: Thu, 15 Apr 2010 20:00:00 GMT

      I have Internet Explorer set to automatically check for newer versions
      of stored pages, but it seems to request this blank.gif image from the
      server every time. It is adversely affecting the amount of time it
      takes my calendar to load.

      So, my question is, is it really necessary for this image to be loaded?
      If so, can you change your headers so that my browser will cache the
      image? Or better yet, can you recommend what source code changes are
      needed to container.css to store and retrieve this image from my local
      server instead of yours?

      Thanks,
      Julie
    • lancelot_0ne
      Did you find an answer for this? Thx! Tooltips seems to load this for every tooltip. =( I ve only got 6 on my page and I get a clicky drumbeat like it s
      Message 2 of 4 , Jun 13, 2006
      • 0 Attachment
        Did you find an answer for this? Thx! Tooltips seems to load this
        for every tooltip. =(

        I've only got 6 on my page and I get a clicky drumbeat like it's
        reloading the page 6 times. As it loads this blank.gif 6 times "and
        who knows possibly refreshes the page?" <<shrug>>.

        Also it's not discriminant, in that during development, if I was
        just at Match.com and try to load my page, then the blank.gif trys
        to come FROM THERE!

        Any Tips much appreciated!


        --- In ydn-javascript@yahoogroups.com, Julie Szmyd <julie@...> wrote:
        >
        > Hi,
        >
        > As I've mentioned in a previous post, I have created tooltips on
        the
        > Calendar control for certain dates that have events scheduled on
        them.
        > I am displaying a 3 month view, so there is a potential for up to
        90
        > tooltips on the calendar (1 for each available date). Because I
        am
        > running in Internet Explorer 6.0, the tooltips are being displayed
        > inside of an iframe to prevent select drop downs from bleeding
        through
        > the tooltips. The iframe is loading an
        image: /i/promo/m/irs/blank.gif
        > from the host us.yimg.com. The following headers are being
        returned:
        >
        > HTTP/1.0 200 OK
        > Content-Type: image/gif
        > Content-Length: 43
        > Last-Modified: Fri, 15 Apr 1994 00:00:00 GMT
        > Expires: Thu, 15 Apr 2010 20:00:00 GMT
        >
        > I have Internet Explorer set to automatically check for newer
        versions
        > of stored pages, but it seems to request this blank.gif image from
        the
        > server every time. It is adversely affecting the amount of time
        it
        > takes my calendar to load.
        >
        > So, my question is, is it really necessary for this image to be
        loaded?
        > If so, can you change your headers so that my browser will cache
        the
        > image? Or better yet, can you recommend what source code changes
        are
        > needed to container.css to store and retrieve this image from my
        local
        > server instead of yours?
        >
        > Thanks,
        > Julie
        >
      • Jesse Dhillon
        You need to change container.js to get the image from a different server. It is in the docs as IMG_ROOT and IMG_ROOT_SSL. Jesse.
        Message 3 of 4 , Jun 13, 2006
        • 0 Attachment
          You need to change container.js to get the image from a different server.
          It is in the docs as IMG_ROOT and IMG_ROOT_SSL.

          Jesse.


          On Tue, June 13, 2006 2:33 am, lancelot_0ne wrote:
          > Did you find an answer for this? Thx! Tooltips seems to load this
          > for every tooltip. =(
          >
          > I've only got 6 on my page and I get a clicky drumbeat like it's
          > reloading the page 6 times. As it loads this blank.gif 6 times "and
          > who knows possibly refreshes the page?" <<shrug>>.
          >
          > Also it's not discriminant, in that during development, if I was
          > just at Match.com and try to load my page, then the blank.gif trys
          > to come FROM THERE!
          >
          > Any Tips much appreciated!
          >
          >
          > --- In ydn-javascript@yahoogroups.com, Julie Szmyd <julie@...> wrote:
          >>
          >> Hi,
          >>
          >> As I've mentioned in a previous post, I have created tooltips on
          > the
          >> Calendar control for certain dates that have events scheduled on
          > them.
          >> I am displaying a 3 month view, so there is a potential for up to
          > 90
          >> tooltips on the calendar (1 for each available date). Because I
          > am
          >> running in Internet Explorer 6.0, the tooltips are being displayed
          >> inside of an iframe to prevent select drop downs from bleeding
          > through
          >> the tooltips. The iframe is loading an
          > image: /i/promo/m/irs/blank.gif
          >> from the host us.yimg.com. The following headers are being
          > returned:
          >>
          >> HTTP/1.0 200 OK
          >> Content-Type: image/gif
          >> Content-Length: 43
          >> Last-Modified: Fri, 15 Apr 1994 00:00:00 GMT
          >> Expires: Thu, 15 Apr 2010 20:00:00 GMT
          >>
          >> I have Internet Explorer set to automatically check for newer
          > versions
          >> of stored pages, but it seems to request this blank.gif image from
          > the
          >> server every time. It is adversely affecting the amount of time
          > it
          >> takes my calendar to load.
          >>
          >> So, my question is, is it really necessary for this image to be
          > loaded?
          >> If so, can you change your headers so that my browser will cache
          > the
          >> image? Or better yet, can you recommend what source code changes
          > are
          >> needed to container.css to store and retrieve this image from my
          > local
          >> server instead of yours?
          >>
          >> Thanks,
          >> Julie
          >>
          >
          >
          >
          >
          >
          >
        • lancelot_0ne
          Just back. call me old fashioned, but I don t like to change standard lib code unless I know why. =) Can you elaborate? How this fixes it? Thx! Wondering,
          Message 4 of 4 , Jun 18, 2006
          • 0 Attachment
            Just back.

            call me old fashioned, but I don't like to change standard lib code
            unless I know why. =) Can you elaborate? How this fixes it? Thx!

            Wondering, does changing these constants effect other images as well?

            And what should a person change it too?

            Best,

            --- In ydn-javascript@yahoogroups.com, "Jesse Dhillon" <tobor@...>
            wrote:
            >
            > You need to change container.js to get the image from a different
            server.
            > It is in the docs as IMG_ROOT and IMG_ROOT_SSL.
            >
            > Jesse.
            >
            >
            > On Tue, June 13, 2006 2:33 am, lancelot_0ne wrote:
            > > Did you find an answer for this? Thx! Tooltips seems to load
            this
            > > for every tooltip. =(
            > >
            > > I've only got 6 on my page and I get a clicky drumbeat like it's
            > > reloading the page 6 times. As it loads this blank.gif 6
            times "and
            > > who knows possibly refreshes the page?" <<shrug>>.
            > >
            > > Also it's not discriminant, in that during development, if I was
            > > just at Match.com and try to load my page, then the blank.gif
            trys
            > > to come FROM THERE!
            > >
            > > Any Tips much appreciated!
            > >
            > >
            > > --- In ydn-javascript@yahoogroups.com, Julie Szmyd <julie@>
            wrote:
            > >>
            > >> Hi,
            > >>
            > >> As I've mentioned in a previous post, I have created tooltips on
            > > the
            > >> Calendar control for certain dates that have events scheduled on
            > > them.
            > >> I am displaying a 3 month view, so there is a potential for up
            to
            > > 90
            > >> tooltips on the calendar (1 for each available date). Because I
            > > am
            > >> running in Internet Explorer 6.0, the tooltips are being
            displayed
            > >> inside of an iframe to prevent select drop downs from bleeding
            > > through
            > >> the tooltips. The iframe is loading an
            > > image: /i/promo/m/irs/blank.gif
            > >> from the host us.yimg.com. The following headers are being
            > > returned:
            > >>
            > >> HTTP/1.0 200 OK
            > >> Content-Type: image/gif
            > >> Content-Length: 43
            > >> Last-Modified: Fri, 15 Apr 1994 00:00:00 GMT
            > >> Expires: Thu, 15 Apr 2010 20:00:00 GMT
            > >>
            > >> I have Internet Explorer set to automatically check for newer
            > > versions
            > >> of stored pages, but it seems to request this blank.gif image
            from
            > > the
            > >> server every time. It is adversely affecting the amount of time
            > > it
            > >> takes my calendar to load.
            > >>
            > >> So, my question is, is it really necessary for this image to be
            > > loaded?
            > >> If so, can you change your headers so that my browser will cache
            > > the
            > >> image? Or better yet, can you recommend what source code
            changes
            > > are
            > >> needed to container.css to store and retrieve this image from my
            > > local
            > >> server instead of yours?
            > >>
            > >> Thanks,
            > >> Julie
            > >>
            > >
            > >
            > >
            > >
            > >
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.