Loading ...
Sorry, an error occurred while loading the content.

Autocomplete with XML - own implementation not working

Expand Messages
  • walshgp
    Hi all, I ve been trying to implement the Autocomplete widget using my own proxy.php file that outputs XML. I ve copied and adjusted the input page at
    Message 1 of 2 , May 31, 2006
    • 0 Attachment
      Hi all,

      I've been trying to implement the Autocomplete widget using my own
      proxy.php file that outputs XML. I've copied and adjusted the input
      page at
      http://developer.yahoo.com/yui/examples/autocomplete/ysearch_xml.html
      so I can see all the useful logging info.

      When I try to use the AC page, the log shows:
      "Data source for ysearchinput0 made source query for 'fion'", but then
      doesn't go any further... But when I query proxy.php directly it spits
      back XML just fine.

      Do I need to have a WSD file (I've tried that too)? Or does anything
      else spring to mind for anyone?

      Thanks,

      Ger.
    • jennykhan
      Hi Ger, Can you double check your HTML to make sure your DataSource constructor points to the correct URL for your proxy? Remember, it needs to be a relative
      Message 2 of 2 , Jun 7, 2006
      • 0 Attachment
        Hi Ger,

        Can you double check your HTML to make sure your DataSource
        constructor points to the correct URL for your proxy? Remember, it
        needs to be a relative link to PHP hosted on the same server as your
        HTML. You do not need a WSD file to access a Yahoo! web service.

        Hope that helps,
        Jenny



        --- In ydn-javascript@yahoogroups.com, "walshgp" <walshgp@...> wrote:
        >
        > Hi all,
        >
        > I've been trying to implement the Autocomplete widget using my own
        > proxy.php file that outputs XML. I've copied and adjusted the input
        > page at
        > http://developer.yahoo.com/yui/examples/autocomplete/ysearch_xml.html
        > so I can see all the useful logging info.
        >
        > When I try to use the AC page, the log shows:
        > "Data source for ysearchinput0 made source query for 'fion'", but then
        > doesn't go any further... But when I query proxy.php directly it spits
        > back XML just fine.
        >
        > Do I need to have a WSD file (I've tried that too)? Or does anything
        > else spring to mind for anyone?
        >
        > Thanks,
        >
        > Ger.
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.