Loading ...
Sorry, an error occurred while loading the content.

Bug in container.js, line 6373

Expand Messages
  • Guogang Hu
    This line required presence of button control. Although I do not use button-beta on my web page, my program is broken if I don t include button.js. The
    Message 1 of 2 , Aug 31, 2007
    • 0 Attachment
      This line required presence of "button" control. Although I do not use
      button-beta on my web page, my program is broken if I don't include
      button.js.

      The original line:
      if (oButton instanceof YAHOO.widget.Button) {

      Something like like are preferrable:
      if (YAHOO.widget.Button && oButton instanceof YAHOO.widget.Button) {

      Environment: YUI 2.3, IE 7.0
      Problem: Error message: "Error: Function expected" appears when I call
      the "render" method of YUI "Dialog" control a second time on the web
      page. Turn out the offending line is here: container.js, line: 6373,

      if (oButton instanceof YAHOO.widget.Button) {
    • Satyen Desai
      Hi, The following Sourceforge bug covers this issue. The fix (the additional check for YAHOO.widget.Button) will be in the next patch release.
      Message 2 of 2 , Aug 31, 2007
      • 0 Attachment
        Hi,
         
        The following Sourceforge bug covers this issue. The fix (the additional check for YAHOO.widget.Button) will be in the next patch release.
         
        There's no really clean catchall workaround, short of including the button.js file, but if you need an alternative, please post an example of your code and I can look into something which may help for your particular use case.
         
        Sorry about the inconvience.
         
        Regards,
        Satyen

        ----- Original Message ----
        From: Guogang Hu <huguogang@...>
        To: ydn-javascript@yahoogroups.com
        Sent: Friday, August 31, 2007 11:06:10 AM
        Subject: [ydn-javascript] Bug in container.js, line 6373

        This line required presence of "button" control. Although I do not use
        button-beta on my web page, my program is broken if I don't include
        button.js.

        The original line:
        if (oButton instanceof YAHOO.widget. Button) {

        Something like like are preferrable:
        if (YAHOO.widget. Button && oButton instanceof YAHOO.widget. Button) {

        Environment: YUI 2.3, IE 7.0
        Problem: Error message: "Error: Function expected" appears when I call
        the "render" method of YUI "Dialog" control a second time on the web
        page. Turn out the offending line is here: container.js, line: 6373,

        if (oButton instanceof YAHOO.widget. Button) {




        Be a better Globetrotter. Get better travel answers from someone who knows.
        Yahoo! Answers - Check it out.
      Your message has been successfully submitted and would be delivered to recipients shortly.