Loading ...
Sorry, an error occurred while loading the content.

Re: How set no cache in the Datasource

Expand Messages
  • jennykhan
    Hi Marimuthu P, You should be able to disable your DataSource s cache by setting its property maxCacheEntries to 0. Hope that helps, Jenny
    Message 1 of 3 , Aug 1 9:46 AM
    • 0 Attachment
      Hi Marimuthu P,

      You should be able to disable your DataSource's cache by setting its
      property "maxCacheEntries" to 0.

      Hope that helps,
      Jenny



      --- In ydn-javascript@yahoogroups.com, "marimuthupg"
      <mponnambalam@...> wrote:
      >
      > Hi,
      >
      > I am using 2.2.2 beta.
      >
      > While I am querying thru datasource, it takes it from cache.
      >
      > Even though I am doing a flush.
      >
      > ds_report.flushCache();
      >
      > In my JSP I have set for no cache
      >
      > response.setHeader( "Pragma", "no-cache" );
      > response.addHeader( "Cache-Control", "must-revalidate" );
      > response.addHeader( "Cache-Control", "no-cache" );
      > response.addHeader( "Cache-Control", "no-store" );
      > response.addHeader("If-Modified-Since", "Sat, 1 Jan 2000
      > 00:00:00 GMT");
      > response.setDateHeader("Expires", 0);
      >
      >
      > Can some one help me how to set the datasource not to cache?
      >
      > Thanks in advance
      >
      > Marimuthu P
      >
    • Marimuthu
      Thanks for the help. I tried, it didn t work. I would be trying it with 2.3.0. Let me see if it helps. With regards P.Marimuthu _____ From:
      Message 2 of 3 , Aug 1 3:13 PM
      • 0 Attachment

        Thanks for the help.

         

        I tried, it didn’t work…

         

        I would be trying it with 2.3.0.

         

        Let me see if it helps.

         

        With regards

        P.Marimuthu

         

         

         


        From: ydn-javascript@yahoogroups.com [mailto:ydn-javascript@yahoogroups.com] On Behalf Of jennykhan
        Sent: Wednesday, August 01, 2007 9:46 AM
        To: ydn-javascript@yahoogroups.com
        Subject: [ydn-javascript] Re: How set no cache in the Datasource

         

        Hi Marimuthu P,

        You should be able to disable your DataSource's cache by setting its
        property "maxCacheEntries" to 0.

        Hope that helps,
        Jenny

        --- In ydn-javascript@ yahoogroups. com, "marimuthupg"
        <mponnambalam@ ...> wrote:

        >
        > Hi,
        >
        > I am using 2.2.2 beta.
        >
        > While I am querying thru datasource, it takes it from cache.
        >
        > Even though I am doing a flush.
        >
        > ds_report.flushCach e();
        >
        > In my JSP I have set for no cache
        >
        > response.setHeader( "Pragma", "no-cache" );
        > response.addHeader( "Cache-Control" ,
        "must-revalidate" );
        > response.addHeader( "Cache-Control" , "no-cache"
        );
        > response.addHeader( "Cache-Control" , "no-store"
        );
        > response.addHeader( "If-Modified- Since", "Sat, 1
        Jan 2000
        > 00:00:00 GMT");
        > response.setDateHea der("Expires" , 0);
        >
        >
        > Can some one help me how to set the datasource not to cache?
        >
        > Thanks in advance
        >
        > Marimuthu P
        >

      Your message has been successfully submitted and would be delivered to recipients shortly.