Loading ...
Sorry, an error occurred while loading the content.

Getting odd error when page first loads and JS debug mode on; anyone know why?

Expand Messages
  • j2ee20072007
    For some strange reason, I m getting an error when I m first including the scripts, without even having done anything yet... any idea why? I m not sure why it
    Message 1 of 1 , Jul 6, 2007
    • 0 Attachment
      For some strange reason, I'm getting an error when I'm first
      including the scripts, without even having done anything yet... any
      idea why? I'm not sure why it would error on this line#. The error
      is "Object does not support this property or method"

      This only pops up when I have the debug turned on for the browser:

      fire: function() {
      var len=this.subscribers.length;
      if (!len && this.silent) {
      return true;
      }

      var args=[], ret=true, i;

      for (i=0; i<arguments.length; ++i) {
      args.push(arguments[i]);
      }

      var argslength = args.length;

      if (!this.silent) {
      }

      for (i=0; i<len; ++i) {
      var s = this.subscribers[i];
      if (s) {
      if (!this.silent) {
      }

      var scope = s.getScope(this.scope);

      if (this.signature == YAHOO.util.CustomEvent.FLAT) {
      var param = null;
      if (args.length > 0) {
      param = args[0];
      }
      ret = s.fn.call(scope, param, s.obj);
      } else {
      ret = s.fn.call(scope, this.type, args,
      s.obj); // THIS IS THE LINE #
      }
      if (false === ret) {
      if (!this.silent) {
      }

      //break;
      return false;
      }
      }
      }

      return true;
      },
    Your message has been successfully submitted and would be delivered to recipients shortly.