Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Problems with YUI after Firefox Update

Expand Messages
  • Eric Miraglia
    Thanks for sleuthing that out, Erik. -Eric ______________________________________________ Eric Miraglia Yahoo! User Interface Library
    Message 1 of 8 , Jun 2, 2007
    • 0 Attachment
      Thanks for sleuthing that out, Erik.

      -Eric

      ______________________________________________
      Eric Miraglia
      Yahoo! User Interface Library


      On Jun 1, 2007, at 6:47 PM, eap_edc wrote:

      Ever since HTML 3, SELECT objects have "required" at least one OPTION
      element, so it must be something in FF 2.0.0.4 that is error checking
      on that.

      In fact, it turns out to be a known bug that somehow made it back into
      the build for 2.0.0.4:

      https://bugzilla.mozilla.org/show_bug.cgi?id=382600

      Good to know we're not all going too crazy.

      _Erik

      Erik Peterson
      elementalmarkup.com
      --- In ydn-javascript@yahoogroups.com, Eric Miraglia <miraglia@...> wrote:
      >
      > Dave,
      >
      > I don't have a good answer for you, but I don't think YUI (or even
      > your own scripts) are the issue here.
      >
      > 1. Take your file and strip out all of the YUI components and your
      > own scripts and CSS.
      > 2. Load the file in FF 2.0.0.4 with Firebug
      > 3. Go to the inspect mode and the HTML tab
      >
      > For me, immediately I see the XX in those selects. FireBug's DOM
      > inspection doesn't show us any contents of the <select>, but the XX's
      > are still showing up.
      >
      > The XX's can show up even with FireBug disabled, so I doubt it's
      > FireBug's issue, either.
      >
      > It seems to me I can make the effect go away just by adding an empty
      > <option> </option> to the <select>s that are exhibiting that behavior.
      >
      > Regards,
      > Eric
      >
      > ______________________________________________
      > Eric Miraglia
      > Yahoo! User Interface Library
      >
      >
      > On Jun 1, 2007, at 11:51 AM, davehaber wrote:
      >
      > > OK. It took me a little while because I'm having the actual trouble
      > > on an internal tool, but I've set up a functional demo of what I'm
      > > doing on an outside server:
      > >
      > > http://www.davidhaber.com/yuitest.html
      > >
      > > Error behavior: Select anything in any of the three drop-down boxes.
      > > The empty select boxes will change from empty to "xx".
      > >
      > > To see the page actually do some ajax and json: In the make dropdown,
      > > select "Ford" or "Chevrolet". The "alternate make" select box will
      > > automatically change to some corresponding makes. In the "new model"
      > > dropdown, "Cadillac Escalade" will cause the new model select box to
      > > change.
      > >
      > > I have confirmed, with this exact same page, it does not have
      > > the "xx" problem in Firefox 2.0.0.3 or any version of MSIE. This
      > > problem only occurs with Firefox 2.0.0.4 which came out yesterday
      > > morning.
      > >
      > > Any light you can shed on this would be most appreciated. Thanks!
      > >
      > > -Dave
      > >
      > >
      > >
      >


    Your message has been successfully submitted and would be delivered to recipients shortly.