Loading ...
Sorry, an error occurred while loading the content.

Re: DataSource, DataTable, and XML

Expand Messages
  • Peter Ford
    for xml with myDataSource.responseType = YAHOO.util.DataSource.TYPE_XML; you should change your schema to use resultNode instead of resultsList something
    Message 1 of 4 , Mar 29, 2007
    • 0 Attachment
      for xml with
      myDataSource.responseType = YAHOO.util.DataSource.TYPE_XML;

      you should change your schema to use 'resultNode' instead of
      'resultsList' something like:

      myDataSource.responseSchema = {
      resultNode: "site",
      fields: ["active","age","domain",
      "fname","location","protected","title","updated"]
      };
    • Dave Viner
      hm... that doesn t seem to solve it... http://dviner.amusive.com/ydn/test.html still has the same problem. in addition, firefox s javascript console says the
      Message 2 of 4 , Mar 30, 2007
      • 0 Attachment
        hm... that doesn't seem to solve it...
        http://dviner.amusive.com/ydn/test.html still has the same problem.

        in addition, firefox's javascript console says the following:

        Error: oRawResponse.getElementsByTagName is not a function
        Source File:
        http://yui.yahooapis.com/2.2.0/build/datasource/datasource-beta-min.js
        Line: 39

        ??

        thanks
        dave


        --- In ydn-javascript@yahoogroups.com, "Peter Ford" <pete@...> wrote:
        >
        > for xml with
        > myDataSource.responseType = YAHOO.util.DataSource.TYPE_XML;
        >
        > you should change your schema to use 'resultNode' instead of
        > 'resultsList' something like:
        >
        > myDataSource.responseSchema = {
        > resultNode: "site",
        > fields: ["active","age","domain",
        > "fname","location","protected","title","updated"]
        > };
        >
      • jennykhan
        Dave, It looks like your data MIME-type is set to text/plain instead of text/xml. Regards, Jenny
        Message 3 of 4 , Apr 9, 2007
        • 0 Attachment
          Dave,

          It looks like your data MIME-type is set to text/plain instead of
          text/xml.

          Regards,
          Jenny



          --- In ydn-javascript@yahoogroups.com, "Dave Viner" <daveviner@...> wrote:
          >
          > hm... that doesn't seem to solve it...
          > http://dviner.amusive.com/ydn/test.html still has the same problem.
          >
          > in addition, firefox's javascript console says the following:
          >
          > Error: oRawResponse.getElementsByTagName is not a function
          > Source File:
          > http://yui.yahooapis.com/2.2.0/build/datasource/datasource-beta-min.js
          > Line: 39
          >
          > ??
          >
          > thanks
          > dave
          >
          >
          > --- In ydn-javascript@yahoogroups.com, "Peter Ford" <pete@> wrote:
          > >
          > > for xml with
          > > myDataSource.responseType = YAHOO.util.DataSource.TYPE_XML;
          > >
          > > you should change your schema to use 'resultNode' instead of
          > > 'resultsList' something like:
          > >
          > > myDataSource.responseSchema = {
          > > resultNode: "site",
          > > fields: ["active","age","domain",
          > > "fname","location","protected","title","updated"]
          > > };
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.