Loading ...
Sorry, an error occurred while loading the content.

Re: [ydn-javascript] Re: Problem with YUI Buttons - Another cue...

Expand Messages
  • Todd Kloots
    Caridy - There are known issues with Button s built-in use of the Event utility s onAvailable method and a bug has already been logged:
    Message 1 of 3 , Mar 13, 2007
    View Source
    • 0 Attachment
      Caridy -

      There are known issues with Button's built-in use of the Event utility's onAvailable method and a bug has already been logged:

      https://sourceforge.net/tracker/index.php?func=detail&aid=1668511&group_id=165715&atid=836476

      For the time being, you can work around the problem by calling "addClass" inside an "init" event handler that you specify as one of the configuration attributes passed to the Button constructor. This technique is mentioned in my comments on the aforementioned bug as well as demonstrated in the following example:

      http://yuiblog.com/sandbox/yui/v220/examples/button/example03.php

      - Todd

      ----- Original Message ----
      From: Caridy Patiño Mayea <caridy@...>
      To: ydn-javascript@yahoogroups.com
      Sent: Tuesday, March 13, 2007 7:30:31 PM
      Subject: [ydn-javascript] Re: Problem with YUI Buttons - Another cue...

      Another cue: When I create the button from markup at the end of the
      page, which means that the markup it's already available, the
      className work fine... definitely the problem is related with the
      "isAvailable" mechanism inside the button control.

      Regards
      Caridy

      --- In ydn-javascript@yahoogroups.com, Caridy Patiño Mayea
      <caridy@...> wrote:
      >
      > Hello Fellows:
      >
      > I´m working with the Button Control, and I found another anomaly, here
      > is an example:
      >
      >
      http://bubbling.comarq.com/themes/bubbling/examples/widget.customized.buttons.html
      >
      > As you can see in the example, I´m trying to redefine the style for
      > all the buttons, creating a new class "tbutton", and applying this
      > class right after the button creation (for each one), but as you can
      > see, the dynamic buttons (From JavaScript) work very well, but the
      > other ones (From Markup), do not get the style correctly. Using
      > FireBug you can see that this buttons don´t have the new class
      > "tbutton". I think that this problem is related with the "isAvailable"
      > event inside the button control.
      >
      > Any Idea?
      >
      > Regards
      > Caridy
      >






      Yahoo! Groups Links
    Your message has been successfully submitted and would be delivered to recipients shortly.