Loading ...
Sorry, an error occurred while loading the content.

Autocomplete hell, help!

Expand Messages
  • ajbarickman
    Hello all, I am trying to use AutoComplete with Lotus Domino. I have been trying everything I can think of but still am having no luck. I am using XHR to
    Message 1 of 2 , Mar 1, 2007
    View Source
    • 0 Attachment
      Hello all,

      I am trying to use AutoComplete with Lotus Domino. I have been trying
      everything I can think of but still am having no luck. I am using XHR
      to return JSON. The JSON is well formed and I know it is coming back
      as expected. The issue is that I can never get anything displayed in
      the autocomplete div. I can switch to a static call to a JS_Array or
      JS_Funtion and the same markup works so its not that.

      I found that in the parseResponse method it has the data but did not
      have the 'this.responseType' value. I hardcoded this value temporarily
      and it continued but I still get nothing returned in the div. I have
      logging console on and am using the autocomplete_debug.js file it
      shows no errors.

      I have a feeling it has something to do with scope but after hours of
      playing I figured I would turn to the experts here. Any help is
      greatly appreciated.
    • jennykhan
      Hi there, If you are using version 0.12.0 or later, your response type definition should look like this: myDataSource.responseType =
      Message 2 of 2 , Mar 3, 2007
      View Source
      • 0 Attachment
        Hi there,

        If you are using version 0.12.0 or later, your response type
        definition should look like this:

        myDataSource.responseType = YAHOO.widget.DS_XHR.TYPE_JSON; // static
        constant

        Other than that, is your JSON response MIME type set correctly?

        Jenny





        --- In ydn-javascript@yahoogroups.com, "ajbarickman" <ajbarickman@...>
        wrote:
        >
        > Hello all,
        >
        > I am trying to use AutoComplete with Lotus Domino. I have been trying
        > everything I can think of but still am having no luck. I am using XHR
        > to return JSON. The JSON is well formed and I know it is coming back
        > as expected. The issue is that I can never get anything displayed in
        > the autocomplete div. I can switch to a static call to a JS_Array or
        > JS_Funtion and the same markup works so its not that.
        >
        > I found that in the parseResponse method it has the data but did not
        > have the 'this.responseType' value. I hardcoded this value temporarily
        > and it continued but I still get nothing returned in the div. I have
        > logging console on and am using the autocomplete_debug.js file it
        > shows no errors.
        >
        > I have a feeling it has something to do with scope but after hours of
        > playing I figured I would turn to the experts here. Any help is
        > greatly appreciated.
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.