Loading ...
Sorry, an error occurred while loading the content.

26573Re: [ydn-javascript] Re: long and complex PHP/JS/AJAX/RSS question

Expand Messages
  • Jing Ceawlin
    Mar 2 3:02 AM
    • 0 Attachment
      I don't have too much experience in this, but I just found one solution which might help.
      I think it's better you read it yourself ;) http://ajaxpatterns.org/Cross-Domain_Proxy#On-Demand_Javascript

      Best Regards,
      Jing

      On Sun, Mar 2, 2008 at 6:40 PM, Del <dhanoad@...> wrote:

      good point Jing, thanks.

      i think the problem here is that i would be trying to do an AJAX
      request across domains -- this is impossible to do.

      so a proxy script must be setup.. but I am unsure how to do this.

      can someone help?

      --- In ydn-javascript@yahoogroups.com, "Jing Ceawlin" <zjply4000@...>
      wrote:


      >
      > One thing is wrong for sure. You shouldn't have put <script
      > type="text/javascript">..........<script> inside your ssirss2.js
      file. :)
      >
      > Regards,
      > Jing
      >
      > On Sun, Mar 2, 2008 at 8:18 AM, Del <dhanoad@...> wrote:
      >
      > > how do I create a script that serves RSS headlines hosted on my
      server
      > > that users can cut and paste simple code to embed in their blogs/sites
      > > that outputs those RSS headlines?
      > >
      > > My Server: creates XML
      > >
      > > User Site: user cuts and pastes code into his/her site, something
      > > simple like:
      > >
      > > <script type="text/javascript"
      > > src="http://www.server.com/code.js"></script>
      > >
      > > how can this be done using YUI?
      > >
      > > -----
      > >
      > > Step 1: create the XML (done):
      > > http://www.gabbr.com/promotion/linkexchange/ssirss.php
      > >
      > > Step 2: create the "code.js" script (done)
      > > http://www.gabbr.com/promotion/linkexchange/ssirss2.js
      > >
      > > Step 3: cut and paste the JS onto an "external" site (done)
      > > http://www.gabbr.com/drdel/test.php
      > >
      > > problem is.. nothing displays.
      > >
      > > I am obviously doing something wrong. I don't even know if what I am
      > > doing is possible. This is just guess work/experimentation on my part.
      > >
      > > Can someone help me out?
      > >
      > >
      > >
      >


    • Show all 5 messages in this topic