Loading ...
Sorry, an error occurred while loading the content.

17669Re: [ydn-javascript] Re: Links in a DataTable

Expand Messages
  • Satyam
    Sep 4, 2007
    • 0 Attachment
      You are missing a double qute after '.html">


      ----- Original Message -----
      From: "ter31024" <ter@...>
      To: <ydn-javascript@yahoogroups.com>
      Sent: Tuesday, September 04, 2007 8:46 PM
      Subject: [ydn-javascript] Re: Links in a DataTable


      > Ooof, I celebrated too soon. Now this is bizarre. Everything is
      > working great in Firefox, however, if you load the page in IE7 the
      > links are completely gone and the cells are empty!
      >
      > What I have is...
      >
      > YAHOO.widget.DataTable.formatLink = function (el, oRecord, oColumn,
      > oData) {
      > el.innerHTML = '<a href="/views/' + oData + '.html>' + oData + '</a>';
      > };
      >
      > This overrides the default formatLink perfectly and gives me want I
      > want. Works like a charm in Firefox, however, now the links just show
      > up blank in IE6 and IE7. Not sure if it is a YUI bug or something I
      > need to add/am doing wrong.
      >
      > Thanks,
      > Tom
      >
      > --- In ydn-javascript@yahoogroups.com, "ter31024" <ter@...> wrote:
      >>
      >> Satyam, you rock!
      >>
      >> Thanks so much. All is working great now.
      >>
      >
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
      > --
      > No virus found in this incoming message.
      > Checked by AVG Free Edition.
      > Version: 7.5.485 / Virus Database: 269.13.3/986 - Release Date: 03/09/2007
      > 9:31
      >
      >
    • Show all 11 messages in this topic