Loading ...
Sorry, an error occurred while loading the content.

Unexpected behaviour of /BN

Expand Messages
  • hdrw54
    Hello folks - I m new here... I m using XXCOPY to update a backup held on a network disk (connected to a Linksys an NSLU2) and it s not doing what I expected.
    Message 1 of 2 , Sep 1, 2007
    View Source
    • 0 Attachment
      Hello folks - I'm new here...

      I'm using XXCOPY to update a backup held on a network disk (connected
      to a Linksys an NSLU2) and it's not doing what I expected.

      I want to update changed files, and copy new files, so I used:

      XXCOPY S:*.* T: /BN /S

      And it did one of three things with each file:

      - Copied it
      - said "Same Time"
      - asked "Overwrite (Y/N/A)?"

      It's the third one that I wasn't expecting - all the files it asked
      about were present on the backup and had the same size/date/time, so
      should have been skipped with "Same Time".

      As this is going from NTFS to whatever a network disk looks like, I
      added the /FF time to give it some leeway on the time matching, but
      the result was the same.

      The annoying thing is that there is no "No to all" option on the
      prompt itself, or on any parameter that I could find - it's as if the
      authors really want to make sure you don't miss anything! :-) I can
      understand it slightly, in that the main selection process should
      eliminate files that aren't needed, but it's failing to do so, and I
      can't find a way to get that right.

      Is this a bug, or is there some other subtle aspect that I've missed?
    • Garry Deane
      ... You re right that you normally use the selection switches to exclude files that you don t want to overwrite and you re also right that /FF should have done
      Message 2 of 2 , Sep 1, 2007
      View Source
      • 0 Attachment
        --- In xxcopy@yahoogroups.com, "hdrw54" <HDRW_Yahoo@...> wrote:
        >
        > Hello folks - I'm new here...
        >
        > I'm using XXCOPY to update a backup held on a network disk
        > (connected to a Linksys an NSLU2) and it's not doing what I
        > expected.
        >
        > I want to update changed files, and copy new files, so I used:
        >
        > XXCOPY S:*.* T: /BN /S
        >
        > And it did one of three things with each file:
        >
        > - Copied it
        > - said "Same Time"
        > - asked "Overwrite (Y/N/A)?"
        >
        > It's the third one that I wasn't expecting - all the files
        > it asked about were present on the backup and had the same
        > size/date/time, so should have been skipped with "Same Time".
        >
        > As this is going from NTFS to whatever a network disk looks
        > like, I added the /FF time to give it some leeway on the time
        > matching, but the result was the same.
        >
        > The annoying thing is that there is no "No to all" option on
        > the prompt itself, or on any parameter that I could find -
        > it's as if the authors really want to make sure you don't
        > miss anything! :-) I can understand it slightly, in that
        > the main selection process should eliminate files that aren't
        > needed, but it's failing to do so, and I can't find a way to
        > get that right.
        >
        > Is this a bug, or is there some other subtle aspect that
        > I've missed?

        You're right that you normally use the selection switches to
        exclude files that you don't want to overwrite and you're also
        right that /FF should have done the trick if the network drive
        is FAT and therefore has minor differences in the timestamps.

        I suspect that the problem may be with the network drive. I've
        had weird problems with these drives before and I think it may
        relate to how the OS/network API's are implemented by the drive.

        I can only suggest narrowing down the problem to one or a small
        number of files and confirm that xxcopy is really copying
        files that are the same size/time. You could try copying a file
        in both directions e.g. copy from the local drive to the network
        drive then copy it back to see if xxcopy skips it. You could also
        try experimenting with similar xxcopy switches to see whether
        xxcopy will skip these files. Some things to try:

        - use /d instead of /bn. /d will copy newer files but doesn't
        look at the file size like /bn does.
        - use /bz instead of /bn. This will skip files that have the
        same size.
        - try using a wider /FF range. It could be that the network
        drive is not implementing time zone standards and UTC correctly.
        You could also try the /fu and /fL switches to see it that makes
        a difference.

        Beyond that I'm stumped. In my case, I simply gave up on using
        the network drive for the purpose I had in mind.

        Garry
      Your message has been successfully submitted and would be delivered to recipients shortly.